Sound Blaster 16 CT1740 Repair

Discussion about old sound cards, MIDI devices and sound related accessories.

Sound Blaster 16 CT1740 Repair

Postby fitzpatr » 2017-9-30 @ 03:14

Hi, everyone,

I just received a CT1740 (059334) from eBay. Unfortunately, there appears to be some damage to a few components. Specifically, capacitor C15 only has two thin metal plates on the leads, and capacitor C11 is missing. I only really bought it for the removable, albeit fairly useless, CT 1748A CSP in the socket. Nevertheless, I'd like to repair this card. There are also a few exposed traces (the protecting layer is gone, bare copper is visible, but the traces appear intact.

I would appreciate some assistance from my fellow VOGONSers! What I need is:
What are the specifications of Caps C11 and C15?
What can I coat the exposed traces with to protect them?

This is the image which I'm using as reference. It is the same revision.
CT-1740 - 059334.jpg
Reference CT1740


This is my card:
CT-1740 - 059334 - Mine.jpg
CT1740 with Damage
Attachments
CT-1740 - 059334 - Mine Damage.jpg
Damage locations
MT-32 Old, CM-32L, CM-500, SC-55mkII, SC-88Pro, SC-D70, MU2000EX
P4EE 3.4GHz/P4C800-E/4GB Ballistix Tracer DDR-500/HD3850/Audigy 2ZS Platinum
PIII-1.4S/TUSL2-C/Voodoo5 5500/MX300
K6-III+/450/GA-5AX/G400 Max/Voodoo2 SLI/CT1750/MPU-401AT/Audigy 2ZS
fitzpatr
Member
 
Posts: 161
Joined: 2016-10-30 @ 06:50
Location: Canada

Re: Sound Blaster 16 CT1740 Repair

Postby Jo22 » 2017-9-30 @ 11:02

Hi, just checked the caps on my CT1740..

C11 = 4.7uF (50v)

C15 = 100uF (16v)


PS: I also attached a photograph.
Unfortunately, my cameras can't take close-up photos.
Attachments
1740.jpg
Jo22
Oldbie
 
Posts: 1987
Joined: 2009-12-13 @ 07:06

Re: Sound Blaster 16 CT1740 Repair

Postby fitzpatr » 2017-9-30 @ 14:27

Thank you very much, Jo22. That is very helpful.
MT-32 Old, CM-32L, CM-500, SC-55mkII, SC-88Pro, SC-D70, MU2000EX
P4EE 3.4GHz/P4C800-E/4GB Ballistix Tracer DDR-500/HD3850/Audigy 2ZS Platinum
PIII-1.4S/TUSL2-C/Voodoo5 5500/MX300
K6-III+/450/GA-5AX/G400 Max/Voodoo2 SLI/CT1750/MPU-401AT/Audigy 2ZS
fitzpatr
Member
 
Posts: 161
Joined: 2016-10-30 @ 06:50
Location: Canada

Re: Sound Blaster 16 CT1740 Repair

Postby 133MHz » 2017-9-30 @ 21:18

fitzpatr wrote:What can I coat the exposed traces with to protect them?

Clear nail polish would be fine for that. :)
User avatar
133MHz
Member
 
Posts: 427
Joined: 2012-1-18 @ 02:06
Location: Santiago, Chile

Re: Sound Blaster 16 CT1740 Repair

Postby gdjacobs » 2017-10-01 @ 02:10

A spray bomb of conformal coating is perfect, if you've got an electronics place near enough to you.
User avatar
gdjacobs
l33t
 
Posts: 4431
Joined: 2015-11-03 @ 05:51
Location: The Great White North

Re: Sound Blaster 16 CT1740 Repair

Postby fitzpatr » 2017-10-01 @ 02:22

133MHz wrote:
fitzpatr wrote:What can I coat the exposed traces with to protect them?

Clear nail polish would be fine for that. :)


That was my first thought.

gdjacobs wrote:A spray bomb of conformal coating is perfect, if you've got an electronics place near enough to you.


I will attempt to acquire some locally. Thank you for the advice.
MT-32 Old, CM-32L, CM-500, SC-55mkII, SC-88Pro, SC-D70, MU2000EX
P4EE 3.4GHz/P4C800-E/4GB Ballistix Tracer DDR-500/HD3850/Audigy 2ZS Platinum
PIII-1.4S/TUSL2-C/Voodoo5 5500/MX300
K6-III+/450/GA-5AX/G400 Max/Voodoo2 SLI/CT1750/MPU-401AT/Audigy 2ZS
fitzpatr
Member
 
Posts: 161
Joined: 2016-10-30 @ 06:50
Location: Canada

Re: Sound Blaster 16 CT1740 Repair

Postby kixs » 2017-11-19 @ 13:31

It seems my CT1740 also has some problems... The volume wheel doesn't do anything. Where to start checking?

This is the card:
Image

Any help welcome :)
My Amibay: SALE Last update 2017-10-19
My Amibay: BUY Last update 2017-10-20
User avatar
kixs
Oldbie
 
Posts: 1782
Joined: 2013-1-31 @ 02:08
Location: Slovenia, EU

Re: Sound Blaster 16 CT1740 Repair

Postby derSammler » 2017-11-19 @ 14:27

kixs wrote:It seems my CT1740 also has some problems... The volume wheel doesn't do anything. Where to start checking?

Change the two jumpers left from the speaker jack from line out to speaker out. ;)
derSammler
Oldbie
 
Posts: 744
Joined: 2017-4-14 @ 11:30
Location: Germany

Re: Sound Blaster 16 CT1740 Repair

Postby kixs » 2017-11-19 @ 17:15

Thanks! All good now :D

Now I have to find out what is wrong with CT3910 with playing only on one channel on Speaker out, line out is fine. And with CT3670 that also plays on one channel but on both speaker and line out :(
My Amibay: SALE Last update 2017-10-19
My Amibay: BUY Last update 2017-10-20
User avatar
kixs
Oldbie
 
Posts: 1782
Joined: 2013-1-31 @ 02:08
Location: Slovenia, EU

Re: Sound Blaster 16 CT1740 Repair

Postby fitzpatr » 2017-11-19 @ 17:35

kixs wrote:Thanks! All good now :D

Now I have to find out what is wrong with CT3910 with playing only on one channel on Speaker out, line out is fine. And with CT3670 that also plays on one channel but on both speaker and line out :(


Have you gone into the mixer utility?
MT-32 Old, CM-32L, CM-500, SC-55mkII, SC-88Pro, SC-D70, MU2000EX
P4EE 3.4GHz/P4C800-E/4GB Ballistix Tracer DDR-500/HD3850/Audigy 2ZS Platinum
PIII-1.4S/TUSL2-C/Voodoo5 5500/MX300
K6-III+/450/GA-5AX/G400 Max/Voodoo2 SLI/CT1750/MPU-401AT/Audigy 2ZS
fitzpatr
Member
 
Posts: 161
Joined: 2016-10-30 @ 06:50
Location: Canada

Re: Sound Blaster 16 CT1740 Repair

Postby kixs » 2017-11-19 @ 19:25

I guess it was a false alarm :blush:

In this setup I had mixer set in autoexec.bat and it seems both 3670 and 3910 work fine. Noob :lol:
My Amibay: SALE Last update 2017-10-19
My Amibay: BUY Last update 2017-10-20
User avatar
kixs
Oldbie
 
Posts: 1782
Joined: 2013-1-31 @ 02:08
Location: Slovenia, EU


Return to Sound

Who is online

Users browsing this forum: Google [Bot], SpeedySPCFan and 2 guests