Yamaha Audician 32 DOS music not working inside Windows 98.

Discussion about old sound cards, MIDI devices and sound related accessories.

Yamaha Audician 32 DOS music not working inside Windows 98.

Postby sketchus » 2017-11-16 @ 05:10

Hi all,

I have the sound card noted above.

For whatever reason I just can't get DOS music to work inside Windows 98. Sound effects work fine, but Doom won't play any music, and Duke3d says it can't detect an FM chip. I'm really scratching my head since inside of pure dos it works fine. I have a Dreamblaster S2 connected which works great inside DOS too, but not at all in Windows, even when reconfiguring IRQ etc.

What's weirder is I have a Atrend ATC-6631 which is almost identical to the Audician which also doesn't work.

I'm imagining it's some silly setting I haven't changed.

Any help would be great.
sketchus
Member
 
Posts: 176
Joined: 2017-2-15 @ 18:51

Re: Yamaha Audician 32 DOS music not working inside Windows 98.

Postby dr.zeissler » 2017-11-16 @ 06:02

You have installed the wrong driver, you need that one that installs dos-support within win9x.
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): 3dfx V3-3000
dr.zeissler
Oldbie
 
Posts: 1436
Joined: 2011-9-28 @ 15:33

Re: Yamaha Audician 32 DOS music not working inside Windows 98.

Postby sketchus » 2017-11-16 @ 09:28

I grabbed the one from Phil's website which is supposed to install that support though... I'll have a look on my cd when I get a chance.
sketchus
Member
 
Posts: 176
Joined: 2017-2-15 @ 18:51

Re: Yamaha Audician 32 DOS music not working inside Windows 98.

Postby badmojo » 2017-11-16 @ 12:15

What resources has Windows 98 given you for FM and the MPU-401? Maybe there was some conflict and you ended up with resources at locations the game isn't looking for.
If it's broke, then fix it!
User avatar
badmojo
l33t
 
Posts: 2921
Joined: 2011-10-11 @ 04:14
Location: Australia

Re: Yamaha Audician 32 DOS music not working inside Windows 98.

Postby sketchus » 2017-11-16 @ 13:17

I think I fixed it now. Stupid on my part really, I changed the port to 240 from 220 and it works fine, wavetable included. It wasn't showing as any conflicts and I've ran the card fine before so not sure what the issue was.
sketchus
Member
 
Posts: 176
Joined: 2017-2-15 @ 18:51


Return to Sound

Who is online

Users browsing this forum: No registered users and 4 guests