VOGONS


OPL3LPT : OPL3 FM Synthesis on parallel port

Topic actions

Reply 240 of 244, by Eimer

User metadata
Rank Newbie
Rank
Newbie
matze79 wrote on 2021-09-05, 09:36:

Look inside the Devices Manager for LPT.
It pretty sure use entirely different address.
It may only support legacy printers.

yea I did there is an option to set "legacy Port support" but it doesn't work.
I can't set the port manually.

Reply 241 of 244, by digger

User metadata
Rank Oldbie
Rank
Oldbie
Eimer wrote on 2021-09-04, 12:24:

Just wasted an entire friday getting my OPL3LPT to work on windows 10 using a LPT PCIe card with asix chipset.
tried many configuration including its legacy port support but Scummvm couldn't open port 278,378 or 3bc

Vincent Bernat implemented OPLxLPT support in ScummVM through use of the libieee1284 parallel port library. This library usually does a good job in terms of hardware abstraction, and only falls back to the legacy PC I/O ports that you listed if there is no other way to detect the I/O addresses of the parallel ports in the host OS. Or at least that's how the library works on UNIX-like (POSIX) operating systems. See his merge and the accompanying discussion here: https://github.com/scummvm/scummvm/pull/1137

So you might want to try this in Linux for better results. Alternatively, you could ask the libieee1284 developers to improve Windows support, or make such an improvement yourself and create a pull request for it, if you have the skills and time for it.

Reply 243 of 244, by matze79

User metadata
Rank l33t
Rank
l33t

Well some cards can be forced to legacy ports you can try select resources in device manager (if possible)

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 244 of 244, by Eimer

User metadata
Rank Newbie
Rank
Newbie
matze79 wrote on 2021-09-05, 20:59:

Well some cards can be forced to legacy ports you can try select resources in device manager (if possible)

Like I said there is a setting to enable legacy port support but you can’t select the port.
And by Ressources you mean the i/o area? I can’t see how to change that