VOGONS


MUS-1099 GameBlaster Sound Card

Topic actions

Reply 100 of 127, by Cyrix200+

User metadata
Rank Oldbie
Rank
Oldbie

47v4tG9l.jpg?1

Done. Well, not tested yet. Need to check everything when I'm a bit less tired and then test it 😀

It was a lot of fun!

1982 - 2001

Reply 102 of 127, by Cyrix200+

User metadata
Rank Oldbie
Rank
Oldbie
root42 wrote:

Looks fabulous! 😀

Your video was very useful, especially for the orientation of the tantalum cap and the bending of the pot legs. Bracket is also a perfect fit, thanks!

1982 - 2001

Reply 103 of 127, by Cyrix200+

User metadata
Rank Oldbie
Rank
Oldbie

It works! Monkey Island and Prince of Persia produce music!

I could only test with modern headphones, and the card is a bit noisy on that. Picks up a lot of sound from the computer itself.

Prince of Persia sounds a bit ... off? I tried it on a 486 sx 25MHz (with turbo on and off makes no difference). Will have to try another Game Blaster compatible card to verify it's just the way it is, or something is wrong. Would not expect MI to work and PoP not though... Might be speed related!

1982 - 2001

Reply 104 of 127, by root42

User metadata
Rank Oldbie
Rank
Oldbie

These cards are usually very noisy with headphones. The Adlib is similar.

Sierra games have a lot of CMS support as well. Good for testing. You can also try the CMS music player.

YouTube and Bonus
80386DX@25 MHz, 8 MiB RAM, Tseng ET4000 1 MiB, SnarkBarker & BlasterBoard, PC MIDI Card + SC55 + MT32, XT CF Lite, OSSC

Reply 105 of 127, by Scali

User metadata
Rank l33t
Rank
l33t
Cyrix200+ wrote:

Prince of Persia sounds a bit ... off? I tried it on a 486 sx 25MHz (with turbo on and off makes no difference). Will have to try another Game Blaster compatible card to verify it's just the way it is, or something is wrong. Would not expect MI to work and PoP not though... Might be speed related!

I've heard other people report that PoP has speed issues with CMS/GameBlaster (even real cards). The game's code appears to be buggy.

http://scalibq.wordpress.com/just-keeping-it- … ro-programming/

Reply 106 of 127, by Cyrix200+

User metadata
Rank Oldbie
Rank
Oldbie

Well, this is it. Go home MUS... You're drunk 😜

Also Monkey Island to prove it works

Last edited by Cyrix200+ on 2019-03-12, 12:55. Edited 1 time in total.

1982 - 2001

Reply 108 of 127, by Cyrix200+

User metadata
Rank Oldbie
Rank
Oldbie
keropi wrote:

yeah the card is really noisy, it's a design flaw IMHO

With (period-correct) speakers it's okay. Still some HDD seek noise and a weird fart when shutting down the system, but I remember those from my youth 😀

1982 - 2001

Reply 109 of 127, by Scali

User metadata
Rank l33t
Rank
l33t
keropi wrote:

yeah the card is really noisy, it's a design flaw IMHO

Sounds exactly like my SB Pro 2, so it's probably a good clone of the original Creative design 😀

http://scalibq.wordpress.com/just-keeping-it- … ro-programming/

Reply 110 of 127, by keropi

User metadata
Rank l33t++
Rank
l33t++

I had a real gameblaster I don't remember any of these parasites on mine ... could be my ICs as well - no idea.
I removed an amp from a cheap isa soundcard and used it on the MUS-1099 (in order to replace the first one that was behaving weird) but this also did not help. For example running my fingers on the amp pins produces more parasites. Could be another semi-dead amp but I did not investigate further , for now I am done with it.

I know this is a free open source design, maybe that is the length the creator wanted to bother with it - totally understandable - don't mean to sound ungrateful.
Maybe another more modern amp or some more filtering would go a long way. Anyways it is what it is, better than nothing 😀

🎵Link to buy a PCMIDI mpu
🎧Orpheus soundcard project
💻WTB Amstrad PC7486SLC-33 system

Reply 111 of 127, by Cyrix200+

User metadata
Rank Oldbie
Rank
Oldbie
Cyrix200+ wrote:

It works! Monkey Island and Prince of Persia produce music!

I could only test with modern headphones, and the card is a bit noisy on that. Picks up a lot of sound from the computer itself.

Prince of Persia sounds a bit ... off? I tried it on a 486 sx 25MHz (with turbo on and off makes no difference). Will have to try another Game Blaster compatible card to verify it's just the way it is, or something is wrong. Would not expect MI to work and PoP not though... Might be speed related!

About Prince of Persia sounding weird, this is mentioned here as well: Re: SB 2.0 CT1350 CMS chips dumped.

1982 - 2001

Reply 112 of 127, by root42

User metadata
Rank Oldbie
Rank
Oldbie

I have now ONE spare MUS1099. If anyone is interested PM me for details.

YouTube and Bonus
80386DX@25 MHz, 8 MiB RAM, Tseng ET4000 1 MiB, SnarkBarker & BlasterBoard, PC MIDI Card + SC55 + MT32, XT CF Lite, OSSC

Reply 113 of 127, by matze79

User metadata
Rank l33t
Rank
l33t

I build the Card, but it sounds weird 😀

had no time until now.

i had some things not at hand and replaced it, for example i had no 0.15uf Ceramic so i used foil..
But i don`t expect this the Problem.

It sounds like wrong clock..

https://www.youtube.com/watch?v=xHI6o-i3SgQ

gameblast.jpg
Filename
gameblast.jpg
File size
149.7 KiB
Views
61 views
File license
Fair use/fair dealing exception

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 114 of 127, by Cyrix200+

User metadata
Rank Oldbie
Rank
Oldbie

What machine are you testing in? That software might be speed sensitive. I know Prince of Persia sounds wrong on CMS at speeds higher than XT.

1982 - 2001

Reply 115 of 127, by matze79

User metadata
Rank l33t
Rank
l33t

Nec V20 4,77Mhz or 7.68Mhz or 9.54Mhz switchable.

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer

Reply 116 of 127, by Cyrix200+

User metadata
Rank Oldbie
Rank
Oldbie

That should be just fine. Another problem might be defective SAA1099 chip(s). You could swap them to see if it makes a difference.

Do you have other software to test it? Prince of Persia (1) (but not all 1.xx versions work with Game Blaster) or Monkey Island (1).

1982 - 2001

Reply 117 of 127, by matze79

User metadata
Rank l33t
Rank
l33t

Ok Prince of Persia and Monkey Island also sounds weird.

I checked all Logic ICs and they are fine, there are no solder bridges or something..

i had no resistor network at hand so i build mine myself, it looks like this:

3760e0
this should be fine 😒

https://dosreloaded.de - The German Retro DOS PC Community
https://www.retroianer.de - under constructing since ever

Co2 - for a endless Summer