Problem with SB16 and Wolf3D

Discussion about old sound cards, MIDI devices and sound related accessories.

Problem with SB16 and Wolf3D

Postby Groenegel » 2019-4-13 @ 21:39

Hello everybody,

I've just fitted my rig with an SB 16 which appears to work with all my games... unfortunately not with Wolfenstein 3D: digital effects eventually cease to play, usually after some "fizzing" in the speakers. FM sound is unaffected. Upon leaving the game I notice the card parameters (IRQ, etc) become completely upset (have to re-run autoexec.bat to set them back correctly).

The same problem occurs with Duke 3D (digital effects will play during the intro and then vanish, card parameters upset upon quitting). All the other games I tested would work fine. Had no problems on the same config with my previous card (SB 2.0). If anyone knows of such bugs or has a clue...

Computer is a 486 DX4-100, DOS 6.22 and there's the revision of my SB 16:
Image
Groenegel
Newbie
 
Posts: 2
Joined: 2019-4-13 @ 21:15

Re: Problem with SB16 and Wolf3D

Postby chinny22 » 2019-4-17 @ 09:43

Does the set blaster line match the setup settings?
What resources is it set to (IRQ/DMA) sounds like it may be conflicting with something else
User avatar
chinny22
l33t
 
Posts: 2292
Joined: 2011-8-26 @ 12:02
Location: Australian but living in the UK for now

Re: Problem with SB16 and Wolf3D

Postby Rawit » 2019-4-17 @ 10:00

Sounds like a High DMA issue. What are your BLASTER variables?
User avatar
Rawit
Member
 
Posts: 298
Joined: 2015-4-17 @ 07:01

Re: Problem with SB16 and Wolf3D

Postby Groenegel » 2019-4-17 @ 12:49

BLASTER variables are the same I had used with the previous card (IRQ 7, DMA 1, that never caused conflict). HDMA was initially set at 5 as per DIAGNOSE.EXE 's autoscan proposal. Tried other HMDA values and setting it at 7 may have alleviated the problem with Duke3D (had one long session, with proper sound all the way), unfortunately not with Wolf3D.
Groenegel
Newbie
 
Posts: 2
Joined: 2019-4-13 @ 21:15


Return to Sound

Who is online

Users browsing this forum: No registered users and 3 guests