VOGONS


First post, by Predator99

User metadata
Rank Oldbie
Rank
Oldbie

As the topic says: Somebody has this config running? My GUS (GF1-clone with 1MB) works fine under DOS.
I think my Windows Installation is also OK, couldnt find more up to date drivers for GF1.

MOD4WIN works with the Waveform-Output. But I am not able to select GUS-Hardware-Support.

Is this possible at all..? I remember I had this running with my Interwave-GUS but I never tried with a GF1.

Attachments

  • IMG_8615r.jpg
    Filename
    IMG_8615r.jpg
    File size
    1.38 MiB
    Views
    268 views
    File license
    Fair use/fair dealing exception

Reply 1 of 8, by Lennart

User metadata
Rank Newbie
Rank
Newbie

I think it should be possible to use it with a GF1, but my memory is fuzzy. It's possible that you downloaded the version of MOD4WIN which removed hardware mixing support. Make sure that you downloaded the correct version from the author's website: http://www.kay-bruns.de/mod4win/betatest.html The download link on the homepage goes to the version without hardware mixing, so you may have accidentally downloaded that one.

Reply 2 of 8, by Jo22

User metadata
Rank l33t
Rank
l33t

I think the same. The current "Last Beta" releases removed all hardware support (OPL4+Sample RAM, GUS, EWS64XL)..
To be on the safe side, also try the official homepage of this MOD4WIN colleague: http://meuble.radio.free.fr/mod4win/english.html
It mentions "Direct Hardware Support" explecitely.

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//

Reply 3 of 8, by Predator99

User metadata
Rank Oldbie
Rank
Oldbie

Yes, I also had this idea. But I double checked I use the correct version 2.40 and also tried 2.30.

The one from above link claims the program have been modified after install...it does not work.

I also installed the "Gravis Windecks 32" which claims to support MOD. But the button for "MOD" is missing at the top.

So for me it seems like the RAM is not detected. My idea is that this is caused by the combination of the rather old drivers written for Win95 and I am using Win98...

Reply 4 of 8, by Jo22

User metadata
Rank l33t
Rank
l33t
Predator99 wrote on 2020-04-02, 08:43:

So for me it seems like the RAM is not detected. My idea is that this is caused by the combination of the rather old drivers written for Win95 and I am using Win98...

That could be possible. I had nothing but trouble with the Windows driver for the GUS..
Especially on DOSBox 0.74. Unfortunately, I have no physical hardware to tinker with at the moment, so I can't say much about this.

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//

Reply 5 of 8, by 640K!enough

User metadata
Rank Oldbie
Rank
Oldbie

There are two "last beta" releases of 2.40; one without hardware mixing support, and one with hardware mixing support. Again, please double-check that you have downloaded the correct version from here (same page Lennart linked above). For native GUS/InterWave support, you will want the version that supports hardware mixing.

Also, usually no additional software is required. The standard installation usually includes a hardware-based tracker file player in the form of an MCI driver. If I remember correctly, it supports MOD, S3M and ULT formats. Have you tried playing these formats from the standard Media Player? If Media Player can play any of these formats, or even standard MIDI files, then the card is working correctly and the RAM is being detected. If you're using a standard GF1-based card with no additional CODEC chip (cards like the MAX, Extreme and GUS with recording daughterboard have the additional chip), it won't be able to play anything without RAM, so if you can get sound out of it at all, chances are that it has found some RAM.

Reply 6 of 8, by Predator99

User metadata
Rank Oldbie
Rank
Oldbie

Yes, I was able to listen to MOD4WINs software mixing using the Ultrasound-Wave-output driver as shown in the screenshot. I have a clone card installed and it doesnt seem to have an additional CODEC-chip.

The card is 100% OK, the GUS DOS installation doesnt complain and RAM test is successful. Final Reality and games run fine.

I think my Win98 install is already totally messed up. I had a AWE32 in the system before and after installing the GUS I tried several driver versions.

I will re-install the whole system...

This is the card:

IMG_8008r2.jpg
Filename
IMG_8008r2.jpg
File size
1.01 MiB
Views
134 views
File license
Fair use/fair dealing exception

Reply 7 of 8, by pyrogx

User metadata
Rank Newbie
Rank
Newbie

You could also try the following:
Open C:\WINDOWS\WIN.INI in an editor, and search for a section named [Player32]. Check if there is a key named
UseHardware=0
and set it to 1. Save and close the file. MOD4Win now should detect your GUS, and a hardware mixing device can be selected in the setup menu.

Reply 8 of 8, by Predator99

User metadata
Rank Oldbie
Rank
Oldbie

Have it running now...!

Re-Install of Win 98 did it.

I now use a driver that doesnt appear in the device manager but only in the multimedia settings.

Strange problem...

Thank you all for your help!!! Now I can enjoy my old mods again 😀

IMG_8620r.jpg
Filename
IMG_8620r.jpg
File size
1.09 MiB
Views
69 views
File license
Fair use/fair dealing exception