VOGONS


First post, by 65C02

User metadata
Rank Newbie
Rank
Newbie

I started playing this game again and am having issues with the sound. Right from the intro sequence, I hear popping and scratching. Now if that were the only issue, I'd try to live with it. But 5 minutes in, just before the first ghostly encounter, the game becomes unplayable. It drops to like 2fps and the audio completely breaks up. Sometimes it even starts screeching so loudly I have to rip my headphones off. The game then locks up and I have to alt-ctrl-del to get out of there. Windows continues to work, but I have to restart to get my sound driver back.

So at this point I've tried different sound drivers, moving the sound card to another PCI slot, and lowering the audio/visual options. No matter what I try, the sound driver just seems to go crazy at the same spot every time and it takes the rest of the game down with it.

I have an X-FI sound card but even with EAX disabled I get the popping, scratching and eventual lockup. FWIW the rest of the system is a P4 3.06GHz HT, Asus P4B533 mobo, BFG Geforce 6600 256MB.

The X-FI was an ebay purchase so I guess it could be a lemon, but it doesn't lock up any of my other games. Any thoughts?

Reply 1 of 3, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Which OS?
How much system ram?

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 3 of 3, by 65C02

User metadata
Rank Newbie
Rank
Newbie

OK so I put my old Sound Blaster Live back in and FEAR works fine!
So I guess there is something wrong with the X-FI. Really sucks because even the first 5 minutes of FEAR does sound more immersive through the X-FI. 🙁