VOGONS


First post, by McCarthy

User metadata
Rank Newbie
Rank
Newbie

Good morning all,

I have bought a T5720 off eBay and connected a pci riser cable. I also added the -12V mod so I actually get sound out of it. The problem is now that certain games just crash. Doom for example plays for a while and then crashes with gameticks < realticks??? (something like that). Duke 3D crashes with a weird garble outputted. I thought I try Win98SE, but with more or less the same outcome. Certain games are absolutely fine like Wolfenstein 3D or Raptor. Does anybody have the same setup and maybe a few suggestions?

Thank you

Reply 1 of 5, by Ydee

User metadata
Rank Member
Rank
Member
McCarthy wrote on 2022-08-19, 07:54:

Good morning all,

Doom for example plays for a while and then crashes with gameticks < realticks??? (something like that).

Like this? This is mentioned on Doom benchmark, do you have a full game running?

Attachments

  • doombench.jpg
    Filename
    doombench.jpg
    File size
    60.46 KiB
    Views
    130 views
    File license
    Fair use/fair dealing exception

Reply 2 of 5, by zyga64

User metadata
Rank Member
Rank
Member

You will probably get better compatibility with soundcards based on YMF7x4 or ALS4000 chipset.
https://vsynchmame.mameworld.info/ - SiS chipsets are mentioned here as compatible.

1) VLSI SCAMP /286@20 /4MB /CL-GD5422 /CMI8330
2) i420EX /486DX33 /16MB /TGUI9440 /YMF718+GUS
3) i440BX /P!!!750 /256MB /MX440 /SBLive!+Vibra16s

Reply 3 of 5, by McCarthy

User metadata
Rank Newbie
Rank
Newbie
Ydee wrote on 2022-08-19, 10:10:
McCarthy wrote on 2022-08-19, 07:54:

Good morning all,

Doom for example plays for a while and then crashes with gameticks < realticks??? (something like that).

Like this? This is mentioned on Doom benchmark, do you have a full game running?

Yeah, I have a full game running, it just crashes and goes back to prompt with “gametiks < realtiks” as the error message which apparently has something to do with network play??? I don’t even use IPX or stuff like that, only a simple single player game.

Reply 4 of 5, by Ydee

User metadata
Rank Member
Rank
Member

Weird, but this may be due to imperfect drivers for integrated VGA (SiS Mirage, ok?) under W98. Friends were buying a PCI riser and giving a different PCI graphics card - they were also freezing their games under W98/DOS.

Reply 5 of 5, by zyga64

User metadata
Rank Member
Rank
Member

Maybe try Fastdoom ?
If your problem is related to the VGA card, you should be able to run the game in any of the available modes (mode 13h, VBE 2.0, etc...)

1) VLSI SCAMP /286@20 /4MB /CL-GD5422 /CMI8330
2) i420EX /486DX33 /16MB /TGUI9440 /YMF718+GUS
3) i440BX /P!!!750 /256MB /MX440 /SBLive!+Vibra16s