First post, by ShovelKnight

User metadata
Rank Oldbie

I have encountered a very strange issue. Basically, I spent a stupid amount of time trying to get my Aztech Waverider 32+ working correctly in my main DOS PC, and I was only able to get it working by replacing the CPU. The PC configuration is as follows:

- Motherboard: GA-6BXC (i440BX)
- CPU: VIA C3 (Ezra) 866 MHz
- 384 MB of RAM
- GPU: GeForce2 MX400 (AGP)

The issue was that the wavetable and FM were working correctly, but the computer just hang every time I tried to play a digital sample. There were no IRQ or DMA conflicts, and every other sound card I tried was working perfectly using the same settings. I tried moving the Aztech card to a different ISA slot without any success. Then on a whim I decided to replace the VIA CPU with a Pentium III, and the sound card just started bloody working without changing any settings. I tried a different VIA C3 (800 MHz), I tried adjusting the CPU and the FSB frequency -- nothing helped. With the VIA C3, trying to play a digital sample always leads to hanging. With the Pentium III or a Pentium II, everything just works.

Very bizarre. In my opinion, a sound card from that era should not really care about the CPU...

Reply 1 of 1, by dionb

User metadata
Rank l33t++

"That era" was five years earlier than the CPUs you're using, so wouldn't rule it out.

That said, usually it's just a speed issue, but in that case a P3 would generally run rings around an Ezra, so puzzling that it's the Ezra it's having trouble with. Which P3 was it?