AGP graphics card not detected by games after drivers installed

Discussion about old graphics cards, monitors and video related things.

AGP graphics card not detected by games after drivers installed

Postby Elia1995 » 2017-11-27 @ 08:55

I had this Pentium 3 with Windows 98SE going on for a while, everything worked fine and dandy, Windows games running perfectly with my GeForce FX5500, no issue at all with the AGP GPU, but the MS-DOS mode suddenly didn't work anymore, I couldn't reboot into MS-DOS mode because the screen would go black and I had to hard reset it.
So yesterday I formatted it and reinstalled Windows 98SE, I then installed all drivers, rebooted, the graphics card drivers I always install are the 56.64, because the 81.98 are garbage. The graphics card seems to work just fine, I could set the resolution of the desktop to 1920x1080, set it in true colors 32-bit, in DXDIAG the hardware acceleration is enabled, I then tried to install Sim Theme Park World, it didn't run.
I then installed Toy Story 2, sometimes the graphics settings selection screen would pop up, with the nVidia GeForce FX5500 detected, rendering method "Hardware" and I could set any resolution I'd like, but as soon I press enter to confirm, the game would crash to desktop without any error.
If I try to open it up for the second time, the error "Unable to find a suitable device" would pop up.

As AGP driver, I've installed the VIA 4-in-1 4.37, which worked just fine with the previous installation before I formatted !!!
I've been formatting and reinstalling Windows 98SE since yesterday, this morning I reinstalled it again and I'm now at the 5th reinstallation in 2 days, but before installing ANY driver, I decided to post this here and wait.
I also tried another FX5500, but the same thing happens, so it's a driver issue and not an hardware issue.
The other AGP cards I have are either worse, thus worthless to exchange with the FX5500, or without Windows 98 drivers (the 7300GT, for example, I can't find any driver for Windows 98 for it).

Ah, I forgot, when dragging the windows, I also saw a lot of tearing after installing the drivers, yesterday, which didn't ever happen before, not even when the drivers aren't installed at all !!!
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 644
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: AGP graphics card not detected by games after drivers installed

Postby andreja6 » 2017-11-27 @ 09:20

Did MS DOS just suddenly stop working without provocation? No hardware changes at all? Did you change any BIOS Settings?

"I also saw a lot of tearing after installing the drivers, yesterday, which didn't ever happen before, not even when the drivers aren't installed at all"
I've had this happen with driver issues...
andreja6
Newbie
 
Posts: 87
Joined: 2017-10-03 @ 07:56

Re: AGP graphics card not detected by games after drivers installed

Postby Elia1995 » 2017-11-27 @ 09:23

Yeah, MS-DOS mode suddenly stopped working without any hardware change at all, from a day to another.
The prompt inside Windows still worked, but the "reboot into MS-DOS mode" just would cause a black screen and the computer froze until I hard reset it, I also noticed that the autoexec.exe file was completely BLANK.
Now the MS-DOS mode works just fine, but until I can't get this driver issue figured out, I can't get the graphics card 3D acceleration to work in any Windows game anymore...
curiously enough, I just tried launching "Litil Divil" and it gave me an error because it needed 580K of free memory (I have 252MB !!!), perhaps the VIA chipset driver will fix that, because Litil Divil worked just fine before.
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 644
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: AGP graphics card not detected by games after drivers installed

Postby clueless1 » 2017-11-27 @ 10:44

Any bulging caps on the motherboard, particularly near the AGP slot?
The more I learn, the more I realize how much I don't know.
Let's benchmark our systems with cache disabled
DOS PCI Graphics Card Benchmarks
User avatar
clueless1
l33t
 
Posts: 3644
Joined: 2015-12-22 @ 17:43
Location: Midwest US

Re: AGP graphics card not detected by games after drivers installed

Postby Elia1995 » 2017-11-27 @ 10:49

Not a single one.
Not on any of the 2 FX5500s I tried either, as I mentioned, the hardware is perfect, it's a driver only issue.
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 644
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: AGP graphics card not detected by games after drivers installed

Postby clueless1 » 2017-11-27 @ 11:31

What makes me wonder if it's hardware is you say the problem started out of nowhere, with no configuration changes between the time it worked and the problems started. Drivers typically don't start to get buggy after months of stability unless you change some variable in the system. What about DirectX, did you reinstall the same version you were using before the reinstalls?
The more I learn, the more I realize how much I don't know.
Let's benchmark our systems with cache disabled
DOS PCI Graphics Card Benchmarks
User avatar
clueless1
l33t
 
Posts: 3644
Joined: 2015-12-22 @ 17:43
Location: Midwest US

Re: AGP graphics card not detected by games after drivers installed

Postby mrau » 2017-11-27 @ 11:48

imho go for weaker card than can be used with your driver preferable and see how that works; also when You say msdos mode stopped working You really mean that switching to msdos mode stopped working?
mrau
Oldbie
 
Posts: 1005
Joined: 2015-11-28 @ 12:43

Re: AGP graphics card not detected by games after drivers installed

Postby Elia1995 » 2017-11-27 @ 12:23

Yes, whenever I had to reboot into MS-DOS mode, for example to run certain games in protected mode, the system would go black screen and freeze.
I also have an ATI Radeon 9200, which has the same amount of memory (256MB), but I read it has a slower clock speed.
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 644
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: AGP graphics card not detected by games after drivers installed

Postby mrau » 2017-11-27 @ 12:43

i would go for nvidia if possibla - this tests compatibility too, speed does not matter now, this is just a test
mrau
Oldbie
 
Posts: 1005
Joined: 2015-11-28 @ 12:43

Re: AGP graphics card not detected by games after drivers installed

Postby Elia1995 » 2017-11-27 @ 12:49

Well, I have an nVidia AGP TNT RIVA-something, but I think it use completely different drivers
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 644
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: AGP graphics card not detected by games after drivers installed

Postby Elia1995 » 2017-11-27 @ 20:26

clueless1 wrote:What makes me wonder if it's hardware is you say the problem started out of nowhere, with no configuration changes between the time it worked and the problems started. Drivers typically don't start to get buggy after months of stability unless you change some variable in the system. What about DirectX, did you reinstall the same version you were using before the reinstalls?

I was using DirectX 9.0c, the latest version supported by Windows 98SE.
Now, even after I install the drivers, I always get DirectX 6 in DxDiag and whenever I try to install DirectX 7, 8 or 9, I get the error "DirectX cannot be installed in this computer", or something like that.
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 644
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: AGP graphics card not detected by games after drivers installed

Postby andreja6 » 2017-11-28 @ 06:06

Driver version 81 was the version that added DirectX 9c support. I don't think you really have a choice there
andreja6
Newbie
 
Posts: 87
Joined: 2017-10-03 @ 07:56

Re: AGP graphics card not detected by games after drivers installed

Postby Elia1995 » 2017-11-28 @ 13:09

It still doesn't work even with v81.98, just tried (I uninstalled the 54.64 driver first and rebooted, obviously)
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 644
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: AGP graphics card not detected by games after drivers installed

Postby mrau » 2017-11-28 @ 14:10

i would expect that a reinstall was in place after this; but that's just a guess
mrau
Oldbie
 
Posts: 1005
Joined: 2015-11-28 @ 12:43

Re: AGP graphics card not detected by games after drivers installed

Postby Elia1995 » 2017-11-28 @ 16:04

Yep, after reinstalling Windows for the sixth time now, I installed 81.98 and the VIA 4-in1, still nothing. When I try to install DirectX 8.0a or 9.0c, I get this error: "DirectX does not install on current operating system.".

EDIT: I'm home now, so here's a screenshot (notice the half italian and half english OS due to the nusb31i version of the USB driver, at least it still shows up as "Windows 98 Second Edition" and not as "Windows ME" lol):

Image
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 644
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: AGP graphics card not detected by games after drivers installed

Postby mrau » 2017-11-28 @ 19:18

you got the wrong file i think, june 2006 to my knowledge, some pages mention december 2006 as the last compatible one
mrau
Oldbie
 
Posts: 1005
Joined: 2015-11-28 @ 12:43

Re: AGP graphics card not detected by games after drivers installed

Postby Elia1995 » 2017-11-28 @ 19:21

For what ?
That DirectX 8.0a setup is certainly older than June 2006 because it's in my The Sims: Complete Collection CD (2005, I think ?), although I'll try other setups
Or do you refer to the GeForce drivers ?
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 644
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: AGP graphics card not detected by games after drivers installed

Postby mrau » 2017-11-28 @ 19:45

i meant dx9; that game is not meant to run on windows 98 to my knowledge...
mrau
Oldbie
 
Posts: 1005
Joined: 2015-11-28 @ 12:43

Re: AGP graphics card not detected by games after drivers installed

Postby Elia1995 » 2017-11-29 @ 05:57

Well same happens with P. O.D., Star Wars Pod Racer, Soho, Slave Zero and some other 3D Win98 games I tried yesterday.
They all crash
Currently assembled vintage computers I own: 11

Most important ones:
A "modded" Olivetti M4 434 S (currently broken).
An Epson El Plus 386DX running MS-DOS 6.22 (currently broken).
Celeron Coppermine 1.10GHz on an M754LMRTP motherboard
User avatar
Elia1995
Oldbie
 
Posts: 644
Joined: 2016-4-21 @ 12:45
Location: Italy

Re: AGP graphics card not detected by games after drivers installed

Postby mrau » 2017-11-29 @ 06:43

what i mean is that the directx 8 version should specify windows 98 as compatible
mrau
Oldbie
 
Posts: 1005
Joined: 2015-11-28 @ 12:43

Next

Return to Video

Who is online

Users browsing this forum: firage, frankmonk, knowledge [bot] and 3 guests