Issues with ReelMagic EM7011 ISA card

Discussion about old graphics cards, monitors and video related things.

Re: Issues with ReelMagic EM7011 ISA card

Postby Uka » 2019-6-20 @ 02:21

I have made a video of the glitches in 'The Psychotron': https://youtu.be/ZJli0KpN52k

You can see the working MPEG videos and the working still MPEG image overlay (2:53; 3:10), but when zooming onto the tape recorder (3:01) and the wall safe (3:21), the overlays are sadly missing for me...
User avatar
Uka
Newbie
 
Posts: 47
Joined: 2019-4-09 @ 18:55
Location: Kiev

Re: Issues with ReelMagic EM7011 ISA card

Postby Uka » 2019-7-05 @ 14:06

I have to add that there is one more critical bug in 'Return to Zork' for me: the game freezes whenever I click on the sign right on the first screen.
Could that be something with the disk? It is clean and new though, I have bought it sealed...
User avatar
Uka
Newbie
 
Posts: 47
Joined: 2019-4-09 @ 18:55
Location: Kiev

Re: Issues with ReelMagic EM7011 ISA card

Postby uematsufreak » 2019-7-06 @ 02:46

I just bought a new motherboard since I kept getting crashes from disc read errors on RTZ-RM and oddly Simon the Sorcerer. O.O Now it runs just fine except I'm also getting the same issues you are with the keying. To put it shortly, it seems anything that is a true black on screen becomes transparent. I'm gonna keep playing with the DOS calibration and see what I get.

I had Psychotron working perfectly fine on my old mobo and setup, but I haven't tried it on the new one yet since I just tossed it back together. I'll have to get a hold of The Horde to test it, as well.
uematsufreak
Newbie
 
Posts: 22
Joined: 2018-11-09 @ 01:55

Re: Issues with ReelMagic EM7011 ISA card

Postby Uka » 2019-7-06 @ 03:14

Oh, that's interesting about 'The Psychotron'. You sure have the correct backgrounds against the wall safe and that recorder? Maybe I should get Maxima then instead of my Ultra II...

And can you please check if you can click on the sign in "Return to Zork"? The one the vulture is sitting on.
User avatar
Uka
Newbie
 
Posts: 47
Joined: 2019-4-09 @ 18:55
Location: Kiev

Re: Issues with ReelMagic EM7011 ISA card

Postby uematsufreak » 2019-7-06 @ 03:15

I'll double-check about those specific screens in Psychotron, and yeah. I can click the sign and dig up the bonding plant just fine. On my other motherboard, though, that was a really common crash point.
uematsufreak
Newbie
 
Posts: 22
Joined: 2018-11-09 @ 01:55

Re: Issues with ReelMagic EM7011 ISA card

Postby Uka » 2019-7-06 @ 03:21

uematsufreak, thanks for the info!
And what is your PC? 486?
User avatar
Uka
Newbie
 
Posts: 47
Joined: 2019-4-09 @ 18:55
Location: Kiev

Re: Issues with ReelMagic EM7011 ISA card

Postby uematsufreak » 2019-7-06 @ 03:26

Pentium MMX 233 underclocked to 120 atm, but it's been at 133 most of the time. SB16 CT2230, ReelMagic Maxima, Diamond Stealth 3D 2000 (S3 ViRGE).
uematsufreak
Newbie
 
Posts: 22
Joined: 2018-11-09 @ 01:55

Re: Issues with ReelMagic EM7011 ISA card

Postby Uka » 2019-7-06 @ 03:31

Well, mine is rather similar: PentiumMMX 233, 128 MB RAM, S3 Trio64 + Creative 3D Blaster Voodoo2, REALmagic Ultra II and Soundmaster 3D (C-Media 8330). Then it should rather be the problem with Ultra II...

Thanks for testing - and please check those screens in 'The Psychotron' that are pink for me!

Maybe it would be even possible to find the color calibration solution to the RTZ-transparency bug. Or maybe someone with the earlier ReelMagic/ReelMagic Lite card would check it.
User avatar
Uka
Newbie
 
Posts: 47
Joined: 2019-4-09 @ 18:55
Location: Kiev

Re: Issues with ReelMagic EM7011 ISA card

Postby Uka » 2019-7-06 @ 05:09

uematsufreak, and can you please list your fmpdrv.ini?
Maybe it is something in the settings of the driver...
User avatar
Uka
Newbie
 
Posts: 47
Joined: 2019-4-09 @ 18:55
Location: Kiev

Re: Issues with ReelMagic EM7011 ISA card

Postby uematsufreak » 2019-7-06 @ 17:04

Sure thing.

Code: Select all
;---------------------------------------------
;Initialization file for the ReelMagic Board
;---------------------------------------------

; for numbers, you can use hexadecimal in the style 0xFFFF or 0FFFFh
; for boolean values you can use <1,Yes,True,on> and <0,No,False,Off>

; for most of the values to take effect, you have to reboot your computer

[RealMagic]
Use=yes
Port=0x260

[MPEG]
Use=yes
Interrupt=10
Int=10
VideoInts=NO
ReduceInt=YES


[VGA]
Dithering=4
PaletteFix=no
WinVGAMode=12h
WinDacMode=00h
WinColorMode=4
WinRMMode=0000h
WinStaticPal1=00000000002A002A00002A2A2A00002A002A2A2A0021222300001500003F
WinStaticPal2=002A15002A3F2A00152A003F2A2A15303132

KeyRedmax=15 95 176
KeyBluemax=15 95 176
KeyGreenmax=15 95 176

DOSMode03=113 034 1026 0x86
DOSMode12=099 032 0998 0x8B
DOSMode13=104 034 0998 0x89
Res0800_f5_HF382=170 26 1031 8d
Res0800_eb_HF383=170 26 1031 8d
Res0640_e9_HF317=120 30 909 80

[MCI]
zoom=1
Key=008000
SeekAccurate=YES

[Mixer]
MPEGL=54
MPEGR=54
MainL=100
MainR=100

[Auto]
M_f5_Res_0800=382 0 0
M_eb_Res_0800=383 0
M_e9_Res_0640=317 0


EDIT: It seems playing with the KeyRedmax, etc. values has an effect. Gonna play around with them some and see what I can get.
EDIT 2: Bringing the first value of all three down to zero makes fewer things transparent by far, but the opening videos don't show at all anymore. I'm unfamiliar with this set of values being used here, so it's all trial and error for me. :P
EDIT 3: Playing with the color calibration in Windows and following its directions gets me with all three KeyColormax values being "11 89 164" at what seems to be the best, but it's far from fixed.
uematsufreak
Newbie
 
Posts: 22
Joined: 2018-11-09 @ 01:55

Re: Issues with ReelMagic EM7011 ISA card

Postby Uka » 2019-7-07 @ 08:27

Thanks for the info!

Unfortunately it seems that all those numbers are very specific to both card and configuration.
With your fmpdrv.ini and with keys as "11 89 164" I do not see any videos, and the 'pink screens' in 'The Psychotron' are still there (while the interface parts in 'Return to Zork' are ideal of course because of no MPEG background). My adjusted KeyColormax values are '34 112 194', although the transparency bug is there.

However, I am more concerned about that freeze on 'Sign' (probably sound card related? Or some other IRQ issue?) and the missing screens in 'The Psychotron'.
uematsufreak, have you double-checked those specific screens? They can be seen in my video above.

And have you tried 'Entity'? That game does not run for me at all in MPEG-version.
User avatar
Uka
Newbie
 
Posts: 47
Joined: 2019-4-09 @ 18:55
Location: Kiev

Re: Issues with ReelMagic EM7011 ISA card

Postby uematsufreak » 2019-7-07 @ 14:34

For me, the RTZ freeze was caused by a disc read error. (It could happen in multiple places, but that sign was SUPER common.) Try letting the computer sit for a minute or so while it's frozen and see if the screen flashes telling you there was an error reading drive D:. I tried my original disc, a burned copy of another disc image of the game, multiple CD-ROMs, multiple IDE cables, multiple power supplies, multiple ReelMagic cards (yes, I own two Maximas), multiple CD-ROM drivers, and all sorts of resource configurations. None fixed the issue, and that's why I bought another motherboard, assuming the problem was the IDE controller, and it fixed the issue for me. This is why I'm concerned about you having a similar freeze.

I just tried The Psychotron and those screens display fine without the pink keying issue you're having. (Edit: it's worth noting I'm playing the game on Win 3.1 and not a 9x OS.)

I've actually never heard of Entity and haven't seen it listed as a ReelMagic game at all. Of course, it's hard to find an actual list of these titles. Is there a page online about the game you can link me to or something? Google is only giving me results for a DOS sidescroller with no mentions anywhere of an MPEG version.
uematsufreak
Newbie
 
Posts: 22
Joined: 2018-11-09 @ 01:55

Re: Issues with ReelMagic EM7011 ISA card

Postby Uka » 2019-7-07 @ 14:39

Yes, that freeze looks very much like a disc read error. I have also tried both the original disc (it is new and very clear) and CD-RW copy...
I am not ready to buy a new motherboard yet, maybe will try to fiddle with some IDE options in BIOS.

Thanks for checking 'The Psychotron'. It seems that I will buy Maxima as well :)

As for 'Entity' - you can find it on our site Old-Games.ru (https://www.old-games.ru/game/2419.html), or on Abandonware France (https://www.abandonware-france.org/ltf_ ... php?id=383).
User avatar
Uka
Newbie
 
Posts: 47
Joined: 2019-4-09 @ 18:55
Location: Kiev

Re: Issues with ReelMagic EM7011 ISA card

Postby uematsufreak » 2019-7-07 @ 14:56

Thanks. I'll look into it when I get time. I'm beginning to wonder, though, if the Return to Zork issue has to do with them choosing solid black as their keying color alongside the fact that these cards are using a VGA passthrough instead of a VESA connector like the ReelMagic Lite boards did. Perhaps the issue is image degradation going over VGA causing confusion amongst the blacks when trying to key? If so, I'll have to hunt down the much rarer ReelMagic Lite board myself since the whole reason I'm going down this path *is* Return to Zork. I obsess over that game.
uematsufreak
Newbie
 
Posts: 22
Joined: 2018-11-09 @ 01:55

Re: Issues with ReelMagic EM7011 ISA card

Postby Uka » 2019-7-07 @ 15:00

I agree - 'Return to Zork' is the only game worth all those troubles (at least for now, until more RM-games are discovered).
I even wonder if it would be easier and quickier to wait until someone will add the support for its ReelMagic-version into ScummVM :)
User avatar
Uka
Newbie
 
Posts: 47
Joined: 2019-4-09 @ 18:55
Location: Kiev

Re: Issues with ReelMagic EM7011 ISA card

Postby uematsufreak » 2019-7-07 @ 18:06

I'm also wondering now if swapping video cards would help out. We both seem to be using different S3 cards for our primary graphics, and maybe going to something like a Trident would make this at least a bit better.
uematsufreak
Newbie
 
Posts: 22
Joined: 2018-11-09 @ 01:55

Re: Issues with ReelMagic EM7011 ISA card

Postby Uka » 2019-7-07 @ 18:19

No, that's not an S3-related issue. I have tried running the same RM-card and 'The Psychotron' on a 386 PC with Trident - it was awfully slow and freezing, but the bug with the missing screens was still there.
User avatar
Uka
Newbie
 
Posts: 47
Joined: 2019-4-09 @ 18:55
Location: Kiev

Re: Issues with ReelMagic EM7011 ISA card

Postby uematsufreak » 2019-7-07 @ 18:44

I'd really like to see actual gameplay footage of Return to Zork MPEG right now. Seems like basically anyone who's gotten this to work *at all* has only shown the intro video, which makes me wonder if they were experiencing similar issues and just didn't want to show it.
uematsufreak
Newbie
 
Posts: 22
Joined: 2018-11-09 @ 01:55

Re: Issues with ReelMagic EM7011 ISA card

Postby DonutKing » 2019-7-10 @ 02:13

I have completed the RealMagic version Return to Zork on my 386 and I didn't have any of the issues described here. You can see pics of my card here: viewtopic.php?t=37363&p=328920

Mine does use the VESA feature connector so perhaps the problems are related to VGA passthrough.
If you are squeamish, don't prod the beach rubble.
User avatar
DonutKing
Oldbie
 
Posts: 1811
Joined: 2008-1-03 @ 03:23
Location: Australia

Re: Issues with ReelMagic EM7011 ISA card

Postby uematsufreak » 2019-7-19 @ 01:18

With that in mind, DonutKing, I'm gonna try downgrading my video card from SVGA to a VGA card and see if maybe this helps with the Return to Zork chroma-key issues. Perhaps a Trident T8900D. If it doesn't, I'll probably have to track down a ReelMagic Lite card, which will likely be a huge pain as I haven't seen one pop up on eBay the for the last few years.
uematsufreak
Newbie
 
Posts: 22
Joined: 2018-11-09 @ 01:55

PreviousNext

Return to Video

Who is online

Users browsing this forum: No registered users and 4 guests