VOGONS


First post, by TeddyNoir

User metadata
Rank Newbie
Rank
Newbie

Hi everyone!

I've been trying to figure out how to make a modern 144Hz display work with my Windows XP machines. Recently, I've had two CRTs fail, so I decided to look for an LCD replacement that retains at least some of the desirable properties of a CRT. I went for an Asus VG279Q (27-inch, 144Hz, 1080p, 82dpi). A nice monitor, but I'm stuck with a number of issues.

I'm posting this here because I'm sure there are other, more technically knowledgable people that have encountered similar issues and made better progress than I have.

Generally, we're dealing with issues regarding detection of display capabilities, resolution timings, refresh rates and display scaling behavior.

I've got four Windows XP systems on hand, and I'll go through each one of them in detail. The VG279Q is connected to each of them via dual link DVI. The monitor itself provides scaling options for stretched 16:9 and 4:3 output, but sadly no option for 1:1 pixel mapping.

1. Core i5 3570K / Geforce GTX 670 / Win XP + Win 7 dual boot:
Under Win 7, everything works as it should: all available (including custom) resolutions can be used with all supported refresh rates (144, 120, 100, 85, 60 Hz). Moreover, with each display mode, centered timings (no scaling) work perfectly.
Under Win XP, however, the Geforce drivers treat the monitor as an HDTV. This locks away the usual display scaling options. Every non-native resolution is stretched to full size. Even worse, refresh rate options are severely limited: only 1080p can do all supported refresh rates. I've tried various driver releases, from 301.42 to 368.81, the result is always the same. I've also tried a suggestion I found online which involves adding a specific OverrideEdidFlags0 value to the registry (http://www.voetsjoeba.com/misc/edid/). This did not have the desired result and only messed up resolution options. I may have done something wrong, though, and should research into this further. 😒
Bottom line: I swapped the GTX 670 with a Radeon HD 7970 and everything works perfectly: arbitrary combinations of non-native resolutions and high refresh rates with centered output. (Catalyst version 14.4, using the gpu scaling option.)
One thing I've noticed: When a centered output of, say, 1280x960 @ 120Hz does work, the display OSD reports 1920x1080 @ 120Hz, i.e. native resolution. The display itself seems to offer 144-85Hz only @ 1920x1080. When creating a custom resolution, i.e. 1280x960, I've had varying results on diffrent configurations: you either get the monitor to display a fully stretched 1280x960 (reported by the osd as such), or a 1920x1080 with a centered 1280x960 of active pixels. You can probably tell that I'm getting out of my depth here.

2. Core 2 Duo E8600 / Radeon HD 4890 / Win XP only:
With the prior experience of the HD 7970, I expected this to be smooth sailing. Not even close. I've tried Catalyst ver. 11.9 and 13.4. GPU scaling behavior is apparently quite different here: centered timings work, but only at a 1920x1080 @ 60Hz. (As reported by the OSD, but also quite obvious perceptually.) Forcing e.g. 120Hz may fool Windows into reporting 120Hz, but it's always just 60Hz. That means that higher refresh rates are off the table for most non-native resolutions. I say 'most': When GPU scaling is disabled, my custom resolutions of 1440x1080 and 1728x1080 (4:3 and 16:10 respectively) are displayed as centered, i.e. mapped 1:1, with all higher refresh rates working. ... weird, but I'll take it. It would be nice to have resolutions with <1080 working @ >60Hz as well, though.

3. Athlon 64 X2 / Geforce 7900 GTX / Win XP only:
Initially, I had a 8800 GTX in this one. All the drivers I tried had the above mentioned HDTV (mis-)detection issue, so I swapped in a 7900 GTX and installed Forceware 93.71. Lo and behold: the 93.71 control panel still has the option 'Treat as HDTV', which I unticked. Why on earth did they get rid of that option in later versions? Anyway, while proper scaling options are now available, centered output only works with some resolutions and only at 60Hz (1920x1080 @ 60Hz as reported by the monitor OSD).
Now, the Forceware control panel allows for rather in-depth creation of custom resoltions. While I'm mostly out of my depth with the various timing options, I tried my luck using automatic settings, combined with the 'centered' setting and the the desired resolution values as front-end active pixels. This way, I got some resolutions working: the above mentioned 1440x1080 and 1728x1080, as well as 1280x1024, 1280x960 and 1152x864. Interestingly, all of these only work at 120Hz. Using 144Hz or 100Hz, the control panel reports a failure to set the respective resolution. I've tried manual settings based on the automatically determined values, always resulting in failure. One thing to note: with the working custom resolutions, back-end active pixels are always automatically determined as 1920x1080. If back-end active pixel values are below that, the output won't be centered, but fully stretched. Manually setting these values to 1920x1080 always failed, but this may be caused by other timing settings being incorrect.

4. Athlon 64 / Radeon X850XT AGP:
Using Catalyst 10.2. Neither centered output nor high refresh rates work, at all. Windows does not even pick up the higher refresh rates at native rasolution, only giving the option for 6Hz. The Catalyst control panel does pick up the refresh rates, but applying one of them, even at native resolution, results in a black screen. Scaling options are available in the control panel, but have no effect.
I've resorted to using my last working CRT with this system.

So, I've had some half-way success with all of this, but the current situation isn't exactly ideal. Even with the older video cards, I suspect that software - the display driver and the way it talks to the monitor -, rather than hardware is at the bottom of the issue. Maybe someone who knows the ins and outs of resolution timings, EDID and whatnot is willing to shed some light into to this mess.