VOGONS


First post, by skel2raw

User metadata
Rank Member
Rank
Member

Hi guys,

I am trying to get my Tropez Plus to properly work under Windows but somehow MIDI won't work in Windows. In does it is properly initialized and works perfectly in Games. However, in Windows the MIDI part won't initialized. Selecting sound blaster in games work. But selecting general midi is not working on any port. Also using the tropez control software for loading sound banks etc. is not working.

Any ideas about what might be wrong? I don't think it is a hardware issue since in dos it seems to work perfectly.

Thx for your help!

Reply 2 of 11, by skel2raw

User metadata
Rank Member
Rank
Member

Just realized I posted in the wrong forum section...
I tried it with Win95 and 98. After experimenting for a couple of hours I found out that during the driver installation windows installed every piece of the drivers correctly except for the midi device. For the midi device windows installed a generic midi driver. After changing the driver to the turtle beach one almost everything works now. I can load sound banks etc. and also play midi music.
However, one thing is still not working: Selecting General Midi does not provide any sound in a windows dos box. No matter which port I chose, there is no sound in a windows dos box. Any ideas how to resolve that issue?

Reply 3 of 11, by CHiLL72

User metadata
Rank Member
Rank
Member

Can't say that I know how to fix that.
Documentation says:

Compatibility
* Windows 95 Plug'n'Play
* SoundBlaster and SoundBlaster Pro compatible
* MPU-401 compatible MIDI interface (DOS and Windows)

That might just mean that you can use the Game/MIDI port as an MPU-401 in DOS (or possibly in a DOS box under Windows 95), not necessarily that the card will play MIDI music. I never tried it myself, but when I have some time I could give this a try.

Waveblaster MIDI boards: http://members.home.nl/c.kersten (site will go offline soon, looking for space elsewhere)

Reply 5 of 11, by Lennart

User metadata
Rank Newbie
Rank
Newbie

I just tried it out with my Tropez Plus running under Windows 98SE. I managed to get sound from the internal WaveFront synthesizer in both Windows applications and inside a DOS box within Windows. So it's definitely possible.

One thing to be aware of is that Windows may allocate very unconventional ports to the MPU-401 interface of the Tropez Plus (hooray for Plug-n-Play 🎉). In my case it was assigned port 250, which is often not selectable in DOS applications. Check the Windows device manager to see which port it is using. Perhaps you can override it to use port 330 and IRQ 2/9 there. Otherwise I would suggest to just boot to DOS for those applications, as you said that you got it working in pure DOS.

Hope this helps!

Reply 6 of 11, by skel2raw

User metadata
Rank Member
Rank
Member

Hm... for some reason I cannot select the port 330 for the MPU-401 in the device manager. The ports available are 350 and up. 300 to 330 are only available for the tropez wavetable midi synthesizer device. Any idea how I can fix that?

Edit: I think the tropez wavetable midi synthesizer device is the right onw with the port range 300 to 330. However, I just get no sound in a dos box within windows. The midi player is able to play midi files though...

Reply 7 of 11, by Lennart

User metadata
Rank Newbie
Rank
Newbie

You're right, the Tropez wavetable MIDI synthesizer device is the one that you need.

Which DOS software are you trying to get to work inside a DOS box in Windows? Perhaps you can try out some software that allows you to freely specify the MPU-401 port address. Then you don't have to manually override the settings in the device manager and just use whatever Windows automatically assigned to the device. I tried it with the Warcraft II setup program. I filled in the 250 port address that the device manager reported and it worked fine.

Oh, and obviously don't forget to init the WaveFront synth first by uploading the firmware and sound bank to the card. It doesn't do that automatically with my Windows setup. I have to open the Tropez Plus control panel first. You mentioned that you got it to work in Windows, so I'm assuming that you did this, but just in case 😀

Reply 11 of 11, by Stiletto

User metadata
Rank l33t
Rank
l33t
skel2raw wrote on 2020-09-13, 21:31:

Just realized I posted in the wrong forum section...

Moved. 😀

"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen

Stiletto