VOGONS


First post, by Chadti99

User metadata
Rank Member
Rank
Member

So the Matrox Mystique is locked at 640x400 for Mechwarrior 2. And at this specific resolution at 60hz my OSSC struggles with a horizontal pixel craw effect. I know the short answer is connecting a CRT 😉 but I don’t quite have enough room for that at the moment.

Anyone have any advice on any adjustments I can make on the OSSC to resolve? Here’s a pic of the issue. I’m using PowerStrip to force 60hz.

Attachments

Reply 1 of 9, by darry

User metadata
Rank l33t
Rank
l33t
Chadti99 wrote on 2021-03-31, 13:35:

So the Matrox Mystique is locked at 640x400 for Mechwarrior 2. And at this specific resolution at 60hz my OSSC struggles with a horizontal pixel craw effect. I know the short answer is connecting a CRT 😉 but I don’t quite have enough room for that at the moment.

Anyone have any advice on any adjustments I can make on the OSSC to resolve? Here’s a pic of the issue. I’m using PowerStrip to force 60hz.

I assume that you are using the Windows version of the game (possibly a Matrox accelerated version). Please confirm .

Why are you forcing 60Hz in Powerstrip and what does the game/Winfows default to at that resolution?

Can you describe in more detail what you mean by "horizontal pixel crawl" ?

Reply 2 of 9, by Chadti99

User metadata
Rank Member
Rank
Member

Yes the Windows version of the game, specifically the Matrox version in Windows 98 SE.

I'm forcing 60Hz because it wants to default to 85hz at that resolution, not sure why. My LCD Monitor, even though it appears to show the correct image says it's not supported and turns off within 30 seconds.

I can try to make a video later but it looks like static along vertical sections of the screen, you can kind of see it in the photo along window or Frame borders where the pixels aren't lined up straight.

Reply 3 of 9, by darry

User metadata
Rank l33t
Rank
l33t
Chadti99 wrote on 2021-03-31, 15:08:

Yes the Windows version of the game, specifically the Matrox version in Windows 98 SE.

I'm forcing 60Hz because it wants to default to 85hz at that resolution, not sure why. My LCD Monitor, even though it appears to show the correct image says it's not supported and turns off within 30 seconds.

I can try to make a video later but it looks like static along vertical sections of the screen, you can kind of see it in the photo along window or Frame borders where the pixels aren't lined up straight.

Thank you for the explanation and for pointing out the issue in the picture (I initially did not look at it closely enough to notice).

The issue is likely due to the timings ( Total lines, active lines, porches, sync width), specifically the horizontal ones, for the video mode, as seen in PowerStrip, not matching the sampling settings in the OSSC configuration.

EDIT: I could provide a few example screenshots on how to do this if you want, but it will have to wait a few days until I finish re-cabling my setup . In the meantime, I can try to answer any further questions .
Also, you likely already know this, but if you change any settings on the OSSC, you need to save to a profile, otherwise the settings will be lost after an OSSC power cycle .

Last edited by darry on 2021-03-31, 15:44. Edited 1 time in total.

Reply 5 of 9, by darry

User metadata
Rank l33t
Rank
l33t
maxtherabbit wrote on 2021-03-31, 15:44:

Specifically, the standard timing for the 640x400 graphics mode has a horizontal total of 800, not 832

Thank you for pointing that out. I have not had enough morning coffee, it would seem .

Instead of using PowerStrip and tweaking modes manually, using Matrox's PowerDesk utility should allow (AFAICR) setting max resolutions and refresh rates while possibly keeping timings standard, which would minimize any needed OSSC adjustments .

Reply 6 of 9, by Chadti99

User metadata
Rank Member
Rank
Member

Thanks guys, as soon as I adjusted the horizontal size to 800 it looks great now. I'll try out the Matrox Utility as well as I'm still struggling to force 60hz refresh using PowerStrip at certain resolutions.

Reply 8 of 9, by Chadti99

User metadata
Rank Member
Rank
Member

Would anyone have any recommendations on how to force 60Hz for all resolutions within Windows? I keep coming across 85Hhz with multiple graphics cards that trips up either the OSSC or the Monitor. I'm trying with power strip but It's just not working in all cases but maybe I'm missing something. Surely I can tweak something that says never go over 60hz on the display refresh?