VOGONS


First post, by Chadti99

User metadata
Rank Member
Rank
Member

Just got ahold of a Matrox M3D and as soon as I install the drivers and reboot Windows freezes at the startup logo.

I’ve tried a few versions of the driver from the PowerVR driver package located here.

Any ideas what to try next? I’ll probably test on another machine in a day or two but for now it’s in a socket 7 VX board with a K6-3 CPU. Windows 98 SE.

Attachments

Reply 1 of 8, by Warlord

User metadata
Rank Oldbie
Rank
Oldbie

yes check for irq sharing. also try moving it to different pci slots. try removing unnecessary cards, try disabling onboard devices in the bios that are unnecessary like serial and parallel ports. theres a chance its conflicting with another device in the system.

Reply 2 of 8, by Chadti99

User metadata
Rank Member
Rank
Member
Warlord wrote on 2021-04-06, 00:46:

yes check for irq sharing. also try moving it to different pci slots. try removing unnecessary cards, try disabling onboard devices in the bios that are unnecessary like serial and parallel ports. theres a chance its conflicting with another device in the system.

Great ideas, I’ll give it another shot here soon.

Reply 4 of 8, by Chadti99

User metadata
Rank Member
Rank
Member

Okay, even though Windows mentioned there were no IRQ conflicts I forced it to IRQ 9 from 10 using tweak Bios and now she’s booting into Windows!

Unfortunately the few things I’ve tried are horrible slideshows, gotta love this old tech 🤣.

Reply 5 of 8, by Chadti99

User metadata
Rank Member
Rank
Member

Alright swapped in a Matrox Mystique over the onboard ATI Rage II and things are rocking now! Would really like it to work with the Rage though so will probably revisit.

Attachments