VOGONS

Common searches


First post, by Erlend

User metadata
Rank Newbie
Rank
Newbie

Hi!

This is my first post here. I'm a huge fan of old adventure games, and I just rediscovered the Gabriel Knight games. Never got to play these gems back in the day...
However, during Gabriel Knight 2 I'm asked to insert CD#2. I have all the CDs as ISO-files. Even though I have mounted several or just one image at the time, the game doesn't recognize any new CD except for the first one.
I use mac (MacBook Pro 2.66ghz, latest OS X version) and Boxer 0.87 (dosbox 0.73). I've tried and tried, but I'm just not able to change CDs. I've looked at a couple of posts here on similar topics, but I'm not able to figure this out myself.
(I know basic PC stuff, but I'm no wiz..) I would love to play the rest of Gabriel Knight 2 now that I have my Christmas holiday away from work.
Can anyone please help?
Your help would mean *a lot*, if you have any good ideas or advices. Thanks for reading. 😀

Reply 1 of 11, by collector

User metadata
Rank l33t
Rank
l33t

Ctrl+F4 will refresh directory cache after you swap CD/images. If you have access to a PC, you can use this installer to install the entire game to avoid swapping discs during game play.

http://sierrahelp.com/Patches-Updates/NewSier … allers.html#GK2

If you copy it back to your Mac, the only thing that you would need to do is to change the mounting in the dosbox.conf to match where you put it on your Mac and start DOSBox with that dosbox.conf.

The Sierra Help Pages -- New Sierra Game Installers -- Sierra Game Patches -- New Non-Sierra Game Installers

Reply 4 of 11, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

An alternative would have been to copy your CDs to images (bin/cue prefered) and to use imgmount instead of mount (you can chain images with imgmount and cycle through them with ctrl-f4).
The problem is that on mac and linuy you don't have a fixed drive letter for all CDs but instead a CD is mounted to /volumes/cdname. This will of course not work for games with multiple CDs since they will all have a different CD name thus ctrl-f4 will not be able to do anything about it.
In this case you were lucky that there is a full installation possible. I'm just posting this lengthy reply so you are able to circumvent this problem in other cases 😉

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 5 of 11, by collector

User metadata
Rank l33t
Rank
l33t

I was forgetting that about the Mac OS, but all of the GK2 discs have the same volume label. Doesn't the OS assign the name based on the volume label or is it assigned by some other criteria?

The Sierra Help Pages -- New Sierra Game Installers -- Sierra Game Patches -- New Non-Sierra Game Installers

Reply 6 of 11, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

Hmm, I'd have thought it would assign the same name. Will need to check with same name images how that is done. I don't have any game with same label names ;(

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 7 of 11, by Erlend

User metadata
Rank Newbie
Rank
Newbie

I can only tell you that it didn't work. I tried to mount the CD in OSX and inside dosbox (imgmount), but neither worked. Fortunately I found a "DVD"-install for both Gabriel Knight 2 and Phantasmagoria 1, and they both run great now on my MacBookPro. These are the only DOS games I have that takes up several CDs...
Again, I just love these old games. In Gabriel Knight 2 the acting's kinda awkward and the videos are grainy, but I just find those "flaws" endearing. GK2 is one of my absolute favourites so far (old adventure games). Too bad there were not made more games in this style (real-life graphics/real actors). I know Phantasmagoria 2 is also in this style, but I've heard less than flattering things about that game...

Reply 8 of 11, by neothematrix

User metadata
Rank Newbie
Rank
Newbie

hi!
I've just registered to add my feedback as I faced the identical issue on a Mac and found this thread as one of the first google results.
I have all isos mounted together with "imgmount" and it really seemed the CTRL+F4 wasn't really working so, after some tries, I solved the issue without reinstalling or changing anything, but just following the hint on dosbox documentation, that is:

Note: If you're using a Mac and are having trouble with the function keys, you may need to set your F keys to function as function keys. You can do this by going to System Preferences > Keyboard, going to the Keyboard area, and checking the "Use all F1, F2, etc" box.

after doing that, CTRL+F4 worked flawlessly and I was able to progress with CD2!

I hope this would help!

Reply 9 of 11, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

It would also work without changing this setting by using the fn key -> fn+ctrl+f4.

And holy cow, ten years necrobump 😉
(But it added something so, it's ok)

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 10 of 11, by neothematrix

User metadata
Rank Newbie
Rank
Newbie

haha sorry about the necrobump! I thought adding my comment would've been useful to people ending up here from google....and also a nice 10 year anniversary gift 😀
Maybe the change in config is still the only solution if you use an external keyboard that doesn't have the "FN" key?

Reply 11 of 11, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

It is useful 😀 Back then I didn't think of the Mediakeys vs F-keys in OS X. And if you came to this thread by google maybe someone else will, too, and then be happy about a solution 😀

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox