Can't get The Settlers 2 MIDI Music to work on my GUS

Getting old DOS games working. (DOSBox topics belong in DOSBox areas below, not here).

Can't get The Settlers 2 MIDI Music to work on my GUS

Postby Eleanor1967 » 2017-11-02 @ 17:03

Hi folks,

I recently aquired a Primax Soundstorm Wave (this version/one) and the card works wonderfully for the most part. After some fiddeling and downclocking my FSB back to 33 MHz I get working MOD playback, MIDI playpack in a midiplayer and e.g. DOOM and Digital Audio Playback.
Problem is, for some reason I can't get any MIDI music out of the card in The Settlers 2. The game supports the card and it gets detected in the setsound programm just fine. Am I missing something ? Do I need to load some TSR before playing ? I have found this question on the internet a couple of times, but no answer anywhere.

Here are my configs:

AUTOEXEC:BAT
Code: Select all
@REM ===== GRAVIS INITIALIZATION (4.10) =====
@SET ULTRASND=240,1,1,11,3
@SET ULTRADIR=C:\ULTRASND
@REM SET BLASTER=A220 I5  D3 T4
@C:\ULTRASND\ULTRINIT.EXE -DJ
@REM ===== GRAVIS INITIALIZATION ENDS =====
LH /L:0;1,45968 /S C:\DOS\SMARTDRV.EXE /X
@ECHO OFF
PROMPT $P$G
SET PATH=C:\ULTRASND;C:\DOS
@REM CALL C:\ULTRASND\SBOS.BAT
SET BLASTER=A220 I5  D3 T4
SET TEMP=C:\DOS
C:\OPL3SA\SETUPSA.EXE /S
MODE CON CODEPAGE PREPARE=((850) C:\DOS\EGA.CPI)
MODE CON CODEPAGE SELECT=850
LH /L:1,17232 KEYB GR,,C:\DOS\KEYBOARD.SYS
LH /L:0;2,3328 /S C:\DRIVERS\CTMOUSE
LH /L:1,27952 C:\DOS\MSCDEX.EXE /D:MSCD001
LH C:\DOS\DOSKEY.COM -I



CONFIG.SYS
Code: Select all
device=C:\ULTRASND\ultrinit.sys ultrasnd=220,1,1,11,3
DEVICE=C:\DOS\HIMEM.SYS
DEVICE=C:\DOS\EMM386.EXE NOEMS
BUFFERS=15,0
FILES=30
DOS=UMB
LASTDRIVE=F
FCBS=4,0
DEVICEHIGH /L:2,12240 =C:\DOS\SETVER.EXE
DOS=HIGH
COUNTRY=049,850,C:\DOS\COUNTRY.SYS
DEVICEHIGH /L:1,15824 =C:\DOS\DISPLAY.SYS CON=(EGA,,1)
DEVICEHIGH /L:2,11360 =C:\DRIVERS\VIDECDD.SYS /D:MSCD001


system specs are:

AMD 5x86 @ 133 MHz
32 MB EDO in one stick
Matrox Mystic 220
QDI MP4-P4U885P3
some ISA controller card for floppy and COM
Yamaha Audician 32 plus
and ofc the GUS Clone

Any help would be appreciated,
Eleanor1967
Eleanor1967
Newbie
 
Posts: 85
Joined: 2016-9-18 @ 09:31
Location: Europe

Return to DOS

Who is online

Users browsing this forum: No registered users and 2 guests