VOGONS

Common searches


First post, by onixiya

User metadata
Rank Newbie
Rank
Newbie

I've asked about this somewhere else but was told to ask here as well so, here i am!

So, i've put freedos on one of my laptops i don't really use and i wanted to get more then 1mb of memory out of it for stuff like elder scrolls arena and maybe windows 3(the laptop has 2g of ram). I'm using jemmex and not using noems in fdconfig.sys just makes it crash. I've tried limiting it to using only 64mb but that still complains. I've also tried using something called emsmagic that does appear to work but then it hangs the computer when i try to run something that uses ems. I don't really know a lot of this stuff (more of a unix guy myself) so i thought of asking here. My fdconfig.sys is here and my autoexec.bat is here if you want to have a look at that

Reply 1 of 2, by Jo22

User metadata
Rank l33t
Rank
l33t

Hello! 😀 It looks to me like there's some sort of conflict in the UMA memory region (640KiB-1MiB).
Perhaps some on-board device (SCSI, LAN or USB controller) or the PC-BIOS is occupying memory space,
so that no EMS frame can be established safely.

If nothing helps, you could try to disable components you don't need in CMOS-Setup.
Alternatively, just use EMM286. It will always work, although not will all applications/games..

Anyway - Good luck!

And Merry Christmas! 😀

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//

Reply 2 of 2, by Baron von Riedesel

User metadata
Rank Newbie
Rank
Newbie

Hello,

looking at your fdconfig.sys:

DEVICE=C:\FDOS\BIN\JEMMEX.EXE X=TEST I=TEST NOVME NOINVLPG MAXEXT=65536

Neither X=TEST nor I=TEST are "good" options if you want to be safe, because they access memory in the UMA. And option MAXEXT=65536 is useless, since EMS memory is by default limited to 32 MB.

Jemm option /V (=verbose) may give a hint of what's the problem, but you're hardly be able to see the output of jemmex because there's so much stuff loaded in your config.sys and autoexec.bat. Just for testing purposes, you could disable the "device=...jemmex.exe" in fdconfig.sys and later, after the command prompt has appeared, try to load jemmex from the command line:

C:\> jemmex.exe load /V