First post, by johnnystarr

User metadata
Rank Newbie

Hi there all. Here's the specs of my recent build:

Socket A Mobo (ASUS A7PRO)
700 MHz Athlon
256M RAM

OS: Dos 6.22

I grabbed Phil's starter pack which I've used in the past on previous builds. The EMC portion of CONFIG.SYS is this:


The culprit appears to be "EMM386.EXE RAM".

Here's the odd part: I initially installed FreeDOS 1.3 on this machine while waiting on a floppy drive to come in the mail. I was able to
install it using the legacy CDROM boot etc. I'm assuming this was related to FreeDOS using 32-bit memory MGMT or something?

I'm wondering if there's a BIOS / Jumper setting I'm missing here?

FWIW, I based this build off of Phil's video: https://www.youtube.com/watch?v=K5vYD0JMD_A&t=2059s
Granted, he's using an 800MHz Duron and a different motherboard, I tried my best to follow the steps. I admit my understanding on
DOS memory is a bit lacking. Ideally, I was looking for a machine that didn't cost and arm and a leg to get up and running old DOS games. I picked
up the Cobra PCI card and have it in slot 1 even. I'm wondering if EMM386 uses a conflicting IRQ or something?

Anyway, if you guys have any idea of something obvious please let me know.


Reply 1 of 2, by darry

User metadata
Rank l33t

I would remove the testmem option from the himem.sys line and boot again (why disable the memory test, are there known issues with it ?).

If Himem.sys complains about memory, that could be a good hint .

Running memtest off of a bootable CD could be an option too .

If everything tests fine, it may just me EMM386.EXE trying to use memory addresses it does not realize are already in use . Have a look here for some suggestions :

Reply 2 of 2, by Jo22

User metadata
Rank l33t++

Hi! I think the same.

If the issue persists, you can also try QEMM 7 or 8.
It's more recent and aware of Pentium CPUs (VME etc) and PCI bus, too.

Another program like this was 386MAX, by the way.

Anyway, it's just an idea.
If you're doing things manually anyway,
you can also try using Himem.sys and emm386.exe from Win9x, PTS DOS or FreeDOS.
But be warned, they don't work with MemMaker.

Good luck! 🙂

Edit: Loading vide-cdd high/up never worked for me. 🙁

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//