Common searches

First post, by enira

User metadata
Rank Newbie

Hi, hope this is the right section,

So I am building a modern PC that can handle Windows 10 as well as MS-DOS 6.22. Pinnacle of the experiment would be to get Windows 3.x working.
Currently DOS SHELL works pretty well, and I can do everything I want to with it, but I've been itching for that Windows 3.11.

Hardware (hp dc5800 microtower):
- 5.25" floppy drive (connected through floppy cable)
- 3.5" floppy drive (connected internally to USB, detectable in BIOS and assigned B:, install drive for MS-DOS/Windows)
- SATA 40 GB Intel disk for MS-DOS
- SATA 200 GB Samsung disk for Windows 10
- CD/DVD reader/burner
- Soundblaster CT4810
- Using standard onboard display adaptor

- MS-DOS 6.22 (default installation)
- Tried Windows 3.11 WFWG as well as Windows 3.1 (default installation)

The issue I am experiencing is as follows: Installation works flawless of Windows 3.x but when it drops down to DOS and I want to boot it for the first time by pressing "win", it immediately crashes back to the DOS prompt. I tried win /b but no bootlog.txt seems to be made when starting with "win".

Anyone any idea where I can start troubleshooting this issue?

Reply 1 of 5, by Cyberdyne

User metadata
Rank Oldbie

Try WIN /S with Windows 3.1 it is standard mode, see if this works.
Usually memory and speed are not really an issue with Windows 3.1x but i have "only " run it with 512MB allocated Windows 98 HIMEM.SYS RAM and a 1.4 Tulatin. After that, I have no experience.
And the universal SVGA 256 color driver works just fine, just do not run DOS programs inside Windows. Usually garbled display, at least my Geforce cards do not like it.

dis you use standard VGA, Microsoft Mouse and Standard MS-DOS system in settings. Sometimes the detection mechanism gives you something else.

Try disconnecting the USB floppy.

I am aroused about any X86 motherboard that has full functional ISA slot. I think i have problem. Not really into that original (Turbo) XT,286,386 and CGA/EGA stuff. So just a DOS nut.

Reply 4 of 5, by schlomoe99

User metadata
Rank Newbie
enira wrote on 2021-02-12, 14:24:

Windows 3.11 (not for Workgroups) and running in standard mode solved everything. Thanks!

Is there a way to make this permanent? Or do I need to remain using win /S

Try creating a batch file, such as "win.bat" and place it in a directory listed under the "SET PATH=" variable in AUTOEXEC.BAT. Try this:


The batch file will be run instead of the windows executable, and the "/S" flag will be preserved.

Reply 5 of 5, by Jo22

User metadata
Rank l33t++

Hi, this reminds me of an older thread..
Problems installing Windows 3.1 on a Pentium 4

Maybe the Pentium processor in question is executing a certain group of instructions too fast (as in requires too few cycles) ?
- It's just a wild guess, not sure if it is related. 😅

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//