VOGONS

Common searches


First post, by Irishtiger77

User metadata
Rank Newbie
Rank
Newbie

So I was reading over the requirements for using NE2000 adapter in Dosbox-x. I use Linux Mint 20+. I see a message on https://flathub.org/apps/details/com.dosbox_x.DOSBox-X that says, "Network adapter emulation: NE2000 (not for Flatpak or Snap installs)."

Linux Mint has no obvious candidate for Dosbox-x without using snap or flatpak. So am I out of luck if I want to use Dosbox-x and my main need is NE2000?

Reply 1 of 3, by BloodyCactus

User metadata
Rank Oldbie
Rank
Oldbie

you can build it from source but good luck with that, the build process for DBX is a nightmare. I could not get it building on my linux box without it segfaulting all over the place even when I got it to build (they have their own forked sdl and all kinds of crap)

--/\-[ Stu : Bloody Cactus :: http://kråketær.com :: http://mega-tokyo.com ]-/\--

Reply 2 of 3, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Post an issue on the dosbox-x git site requesting a version of dosbox-x that isn't in a container, which shouldn't even be necessary since it should be the other way around.....

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline