VOGONS

Common searches


MDK help

Topic actions

First post, by munky

User metadata
Rank Newbie
Rank
Newbie

Hey there - could really appreciate some help with MDK on Windows 98SE. To give you some background, it's a Dell Dimension 4400 with SB0060 and GeForce 2 MX.

I'm trying to get MDK to work with my Microsoft Force Feedback Pro joystick. I have a legitimate, original MDK CD. I installed it but could only run MDK.exe (DOS) and MDK95.exe. MDK3D.exe (Direct3D) does not seem to work. I've applied the MDKD3DE.zip and MDKFF2.zip patches directly from Shiny's site. When I try to launch mdk95ff.exe I get the following error message: "MDK Executable Version Is Incompatible with MDK CD"

Frustrating! Again, the short of it is I want to get MDK to work with my FF Pro joystick. Anyone have any suggestions / ideas / comments?

Thanks in advance, vintage game gods.

Reply 1 of 4, by akula65

User metadata
Rank Oldbie
Rank
Oldbie

From the Shiny MDK Patches page:

When upgrading, here is the way to work out which MDK CD version you have. When you first installed the game from the CD, flags […]
Show full quote

When upgrading, here is the way to work out which MDK CD version you have. When you first installed the game from the CD, flags appeared on screen....

USA VERSION = 3 Flags
EUROPEAN VERSION = 6 Flags
GERMAN VERSION = 2 Flags
Patches are the same for the European and USA versions.

Final Patches:
Each file is a zip file, with an executable and a readme file.

From the Shiny MDK FAQ:

Q. When I downloaded a patch, I got a message that says it's "Incompatible" with my version of MDK. What does that mean?
A. There were two different executables, the censored and normal versions of the game. Thus, we have two different patches that do the same things. If the patch you downloaded doesn't work with your game, it's probably because you should have downloaded the other version. Getting the other version should fix the problem.
Note: The patches will not work with the demo version of MDK, or any version that came with a piece of hardware (i.e. ForceFeedback joystick, a video card, etc.)

Patch still available here:
http://www.falconfly.de/patches-mdk.htm

Reply 3 of 4, by munky

User metadata
Rank Newbie
Rank
Newbie

Thank you - one step closer!

Updated my DirectX to 9.0c. Tried the US patch version but kept getting the "MDK Executable Version Is Incompatible with MDK CD" error with MDK3DFF.exe. My version is US (3 flags during install). Decided to give the German patch a shot and sure enough, MDK95FF.exe works great!

Just curious - does anyone have a German copy of MDK3DFF.exe or know how I can get the Direct3D version running with FF?

Very close - thanks for the help thus far!

Reply 4 of 4, by Renaissance 2K

User metadata
Rank Newbie
Rank
Newbie

Resurrecting this long-forgotten thread since the OP and I have the same goal in mind: running MDK on Windows 98 SE with the Microsoft Force Feedback Pro.

I have the aforementioned joystick, a retail MDK CD, and a W98SE PC with a gameport provided via an Audigy 2 ZS. I found the FF patch that matches my CD, but when I start the game, I see - in the MDK gold text - InitForceFeedback Failed with a hex error code. Google literally reveals nothing about this error. Has anyone else seen it before?

Force Feedback works in the Sidewinder Control Panel, and in another game that I've tested (Rollcage).