VOGONS

Common searches


Episode 1 Racer - White Screen (LA FTP down)

Topic actions

Reply 42 of 69, by eadmaster

User metadata
Rank Newbie
Rank
Newbie
AxXxB wrote:
White/black screen can also be fixed by: 1. New dgVoodoo (versions from 2.4) than can emulate old versions of DirectX - http://d […]
Show full quote

White/black screen can also be fixed by:
1. New dgVoodoo (versions from 2.4) than can emulate old versions of DirectX - http://dege.freeweb.hu/ (DirectX 11 videocard needed)
2. Copying ReactOS wine libraries to game folder - http://www.old-games.ru/forum/attachment.php? … 12&d=1414853297 (contains *.cpl file for configuring, may require Offscreen: Backbuffer setting) - but there is no long-distance fog in the game with these libraries; works in Windows Vista/7/8/10 only (no 9x/2k/XP)
3. My "patch" that replaces game zbuffer - http://www.old-games.ru/forum/attachment.php? … 42&d=1396358079; doesn't work on NVidia; for English version only (you can make patch for any version by changing in hex-editor all occurencies of "DDRAW.DLL" to "PDRAW.DLL" in game exe).

BTW, the game can be installed by original installer with InstallShield Wrapper (InstallShield Wrapper).

PS. Looped sound in no-cd version can be fixed by copying Music folder from CD to the game folder.

I've tested these solutions in my Win7 64-bit installation:

  • Solution 2 did not work (crash on startup) (setup with the play-old-games installer).
  • DXWnd showed the black/white screen issue.
  • Solution 3 worked fine. (thank you for the patched exes!)

Btw with the no-cd version the intro videos are not be played (i've copied them in the "data\anims"). Can they be fixed?

Reply 43 of 69, by AxXxB

User metadata
Rank Newbie
Rank
Newbie
eadmaster wrote:

Solution 2 did not work (crash on startup)

Did you try to change some settings by .cpl?

Solution 3 worked fine. (thank you for the patched exes!)

You are welcome 😀 By the way, what videocard you tried it on?

Reply 44 of 69, by eadmaster

User metadata
Rank Newbie
Rank
Newbie
AxXxB wrote:
eadmaster wrote:

Solution 2 did not work (crash on startup)

Did you try to change some settings by .cpl?

No, i didn't try, but i prefer solution 3 at this point.

Solution 3 worked fine. (thank you for the patched exes!)

You are welcome 😀 By the way, what videocard you tried it on?

I am running it on a AMD Radeon HD 6530D (not a discrete GPU, it's an APU).

Last edited by eadmaster on 2015-06-22, 14:56. Edited 1 time in total.

Reply 45 of 69, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie

Tried getting this working nicely on a Win8/Nvidia setup and that just does not work.

WineD3D hangs by default, if I use the compatibility flag to disable 8 and 16 bit color modes then it will run, but fall backs to 640x480 resolution no matter what and fog is broken. Fog seems pretty important so even on Win7 where all resolutions should work it's not a good solution.

DxWnd and dgVoodoo2 both have depth issues on Nvidia cards and with Win8's software render.

Probably one of those scenarios where playing the Dreamcast version (emulated or on real hardware) is a much saner approach.

Reply 47 of 69, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie

Got that working, doesn't really matter though as it's still stuck at 640x480. Edit: got that working too. Was sure I waited 5 minutes earlier. Guess not. Maybe I should test more patience with some other titles that are problematic in WineD3D.

The main depth issues I was talking about are the sun and player numbers, and in Nvidia Inspector those things in specific are actually referred to in the builtin Nvidia profile. Applying it or making sure it doesn't apply doesn't change anything though.

It isn't a problem with WineD3D because WineD3D fails to render the sun and player numbers entirely.

Reply 48 of 69, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie

Tried with and old Intel Integrated just for fun and:

1: DxWnd: white screen
2: dgVoodoo2: white screen
3: WineD3D: instant crash
4: zbuffer patch earlier in this thread: missing sun/stars/lights and player numbers. Just like WineD3D, except fog works.

I'm not surprised people are struggling to get this game to work.

Reply 50 of 69, by teleguy

User metadata
Rank Member
Rank
Member
AxXxB wrote:

teleguy, I think if the game doesn't support it, you can't force it.

Figured it out. If you set "Offscreen rendering" to "Backbuffer" in the wine cpl you can force AA from the driver controlpanel, otherwise it has no effect.
(Tested on R9 290X, Windows 7)

Reply 51 of 69, by spacex

User metadata
Rank Newbie
Rank
Newbie

Hello Vogons, happy new year,
that's crazy,
thank you very much for this post!
I get it running now, without the white and black screen issue.
on a Win 7 Pro 64bit with the intel grafic card onboard.

Just one little question, on race there's no sound and no soundcard at the settings.
Is that possible to fix? can anyone help ne with that?
sorry if I'm wrong and it is just wrote somewhere and I didn't get it.
add: I'd try VDMSound.

Reply 52 of 69, by thepenguinboy

User metadata
Rank Newbie
Rank
Newbie
spacex wrote:
Just one little question, on race there's no sound and no soundcard at the settings. Is that possible to fix? can anyone help ne […]
Show full quote

Just one little question, on race there's no sound and no soundcard at the settings.
Is that possible to fix? can anyone help ne with that?
sorry if I'm wrong and it is just wrote somewhere and I didn't get it.
add: I'd try VDMSound.

Running the game as administrator resolved the issue for me.

Reply 53 of 69, by Sobek

User metadata
Rank Newbie
Rank
Newbie

Just wanted to register to say thanks - this thread really helped me get on the right track to getting this game working perfectly. It took me all night but I eventually did, been playing it very happily for the last few nights, 1080p, 60fps, not a single hitch. Running Win7 x64 here and a R9 280. Made a quick test video here - https://www.youtube.com/watch?v=u5BlUTD6xWM

I'd love to see if we could get the devmode to work for this game. It's referenced in the registry entries (but that resets itself to 0 automatically if you try and enable it there), and all of the cheats, debug menu and devmode stuff is right there mentioned in the EXE if you look into it with a hex editor. I've tried all sorts of command lines and combinations of things ingame to see if I could get lucky but so far no joy... Honestly, getting the debug menu on the PC version is like the holy grail to me!!

Will keep at it 😀

Reply 54 of 69, by Davros

User metadata
Rank l33t
Rank
l33t

sOBEK DO i KNOW YOU FROM SOMEWHERE
B3d or hardlight ?

ps: try this (no guarantee saw it on the net and i dont have the game installed)
enter tournament mode
go to 4th empty slot
enter RRTANGENTABACUS
pause during a race and you should see debug menu

EDIT: cheats could be n64 only

Guardian of the Sacred Five Terabyte's of Gaming Goodness

Reply 55 of 69, by Sobek

User metadata
Rank Newbie
Rank
Newbie

Davros! Haha yeah, both B3d and Hardlight! Though I never really posted much of anything on Hardlight hahaha. I kinda dropped off B3d sadly due to some bad health and business related things in the family... I do pop by from time to time just to see what's going on though 😀 I see the 'Just don't do it' thread in the PC section is still there, Richard made that in response to something I did that was misinterpreted haha. Ahh I miss the good old days, maybe I should get active on there again, life's a bit better now.

Sadly, those are N64 cheats yeah. I've actually taken the N64 cheats and tried a hundred variations and adaptations of them on the PC version just to see if by some quirk they left the 'rrdebug' or tangent / abacus stuff in and you can just type it freely with your keyboard or whatever, but no go. It's going to be some specific little thing that needs to be modified or done on a certain screen to activate it, just... gotta work out what. Maybe someone more adept at modifying the executable code or somesuch would have better luck than I. I can see the code exists there for all of the debug systems, but I have no idea how to determine HOW it's activated. Frustrating! I've tried adding some registry entries, running the shortcut with -devmode (and a thousand variations on that like -dev +devmode -console etc etc etc, tried it all). Hmmmm. I'm trying to go by the assumption though that the devs, while working on the pc version, would likely have a system in place for activating devmode / debug mode that is both quick and easy - because no one wants to go through some complicated process to turn on a no doubt frequently used mode for testing reasons during development??

Good to see you again man!

Reply 57 of 69, by Sobek

User metadata
Rank Newbie
Rank
Newbie

Yeah, sadly the only trainers out there for the game give infinite truguts or whatever (something I have already done before using Cheat Engine). I tried for hours to find the values that relate to health just to see if I could make my pod invincible but... no joy. I have no idea how the health value of the pod is stored. Grrr.

I have managed to get the 'Game Cheats' option to show up in the pause menu by editing some memory values on the fly, but the menu is not accessible yet. I just can't work out how to trigger it :\

Reply 58 of 69, by spacex

User metadata
Rank Newbie
Rank
Newbie
thepenguinboy wrote:
spacex wrote:
Just one little question, on race there's no sound and no soundcard at the settings. Is that possible to fix? can anyone help ne […]
Show full quote

Just one little question, on race there's no sound and no soundcard at the settings.
Is that possible to fix? can anyone help ne with that?
sorry if I'm wrong and it is just wrote somewhere and I didn't get it.
add: I'd try VDMSound. ADD: that didn't works, just sayn

Running the game as administrator resolved the issue for me.

ouh, thanks alot.
I don't know, how it happens that it works now how it seems, coz I always had to running it with admin BUT now suddently, I go into settings and can choose soundcard, that was impossible before!
No clue, why or how. (I only had changed today the cpu duo 2,4GHz to duo 2,8GHz maybe the reason)
So I immediately save own settings 😁 and quit game, to post, that sounds now working.

ADD: to make it short, just for information. figured out that it was running the game as admin, in deed.
THANKS! alot to thepenguinboy!

Last edited by spacex on 2016-02-03, 02:58. Edited 3 times in total.

Reply 59 of 69, by Davros

User metadata
Rank l33t
Rank
l33t

Sobek
This is what it says for the n64
EDIT #3: to enter the debug menu code, you have to hold down the Z button, and use the L button to input the code, and it's actually all at once: RRTANGENTABACUS, and if you mess up a letter, you have to go back out and re-enter the entire code,

Have you tried the pc equivalent of holding down the Z button and using the L button ?

Guardian of the Sacred Five Terabyte's of Gaming Goodness