Common searches

First post, by ProDigit

User metadata
Rank Newbie

Hi all,

I own a legal copy of MDK, bought it a long time ago.
However, it no longer works on Windows 10.
I got the DOS version to work on DOSBOX.

However, I tried it on an old netbook running Linux, and was able to run the Windows version of the game (the D3D version) on Wine in Lubuntu, but I'm having an issue with the mouse.
Whenever the mouse is used, it works fine for about 0.5 seconds or so, before the game starts seriously slowing down.
I believe the mouse input generates too much data to be processed.
Keyboard inputs alone work fine, and mouse clicks work fine.
But mouse movements cause this error.
I thought perhaps someone knew what to do about this?

PS: The first few tenths of a second, the mouse is very responsive, up until just under the 1 second mark, when the game starts freezing into powerpoint presentation framerates.
This attitude lasts for about <1second past releasing the mouse.

Reply 1 of 2, by dreamer_

User metadata
Rank Member

Not sure, what version of Wine are you using? Have you tried running the game via Proton?

Reports on ProtonDB (link) indicate the game works very well except fullscreen. Lutris lists the game as "garbage", but links to an outdated bug report and installers were prepared very long time ago.

| ← Ceci n'est pas une pipe