VOGONS

Common searches


First post, by Discrete_BOB_058

User metadata
Rank Member
Rank
Member

How is it possible to run Quake 3 on A3D 2.0 mode? I use A3D ALchemy and A3D Live for it but the game doesnt recognise the a3d dlls pasted in windows directory

YouTube Channel:
DEADHistory Walkthroughs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892

Reply 1 of 7, by Garrett W

User metadata
Rank Member
Rank
Member

What seems to be the issue? If the option to enable A3D isn't showing in the options menu, it's because you need an older version. Off the top of my head, I think the last version to keep it in there is 1.16n.

Reply 2 of 7, by Discrete_BOB_058

User metadata
Rank Member
Rank
Member
Garrett W wrote on 2020-05-08, 16:15:

What seems to be the issue? If the option to enable A3D isn't showing in the options menu, it's because you need an older version. Off the top of my head, I think the last version to keep it in there is 1.16n.

I am using version 1.0. And the game menu even doesnt have the option to turn it off or on.

YouTube Channel:
DEADHistory Walkthroughs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892

Reply 3 of 7, by Srandista

User metadata
Rank Oldbie
Rank
Oldbie

You have to enable it with console command "s_enable_a3d".

Socket 775 - ASRock 4CoreDual-VSTA, Pentium E6500K, 4GB RAM, Radeon X800 XT, ESS Solo-1, Win 98/XP
Socket A - ASRock K7S41GX, AMD Sempron 2200+, 512MB RAM, GeForce4 Ti4200, SB Live!, Win 98

Reply 4 of 7, by leileilol

User metadata
Rank l33t++
Rank
l33t++

Only older versions of Quake3 (1.16n and before) have A3D support. It can be turned on in the menus there.

A3D support was ripped out by v1.27g supposedly due to a payment dispute, though there's other sound code changes in that version as well (uninterrupting sounds causing new sound overflows that can be obnoxious with pain noises and performance loss, support for 4-bit adpcm compression intended for lowering Team Arena voices' memory usage, etc)

There is no 1.0. Earliest Q3 final is 1.11. If you've bought it digitally or in a bundle, it's likely 1.32.

by the way, DOSBox is not for running Windows 9x

Reply 5 of 7, by Discrete_BOB_058

User metadata
Rank Member
Rank
Member
leileilol wrote on 2020-05-09, 02:42:

Only older versions of Quake3 (1.16n and before) have A3D support. It can be turned on in the menus there.

A3D support was ripped out by v1.27g supposedly due to a payment dispute, though there's other sound code changes in that version as well (uninterrupting sounds causing new sound overflows that can be obnoxious with pain noises and performance loss, support for 4-bit adpcm compression intended for lowering Team Arena voices' memory usage, etc)

There is no 1.0. Earliest Q3 final is 1.11. If you've bought it digitally or in a bundle, it's likely 1.32.

SO I discoverd my retail copy is frok 2001 and uses v1.30. Is there any way to revert back to old version

YouTube Channel:
DEADHistory Walkthroughs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892

Reply 6 of 7, by leileilol

User metadata
Rank l33t++
Rank
l33t++

Yes1 Find one of the older point release patches from early 2000 (like Q3PointRelease_116n.exe), delete your PAK#.pk3s except for PAK0.PK3 to assure no version conflicts, and install it. Be aware of the older Q3s prior to 1.27 having a CD check though and i'm not sure if that CD check will acknowledge your late retail disc.

by the way, DOSBox is not for running Windows 9x

Reply 7 of 7, by Discrete_BOB_058

User metadata
Rank Member
Rank
Member
leileilol wrote on 2020-05-10, 00:13:

Yes1 Find one of the older point release patches from early 2000 (like Q3PointRelease_116n.exe), delete your PAK#.pk3s except for PAK0.PK3 to assure no version conflicts, and install it. Be aware of the older Q3s prior to 1.27 having a CD check though and i'm not sure if that CD check will acknowledge your late retail disc.

Well I just got the old files from a different CD and A3D works.

YouTube Channel:
DEADHistory Walkthroughs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892