VOGONS

Common searches


Reply 20 of 32, by Discrete_BOB_058

User metadata
Rank Oldbie
Rank
Oldbie
Dee-Dee wrote on 2020-08-20, 14:50:
UCyborg wrote on 2020-08-19, 20:08:

There is another bug that exists in all OS from 10 down to XP, possibly on older systems as well. If you pause CD playback via MCI then query its status, you'll get back "stopped" instead of "paused".

DxWnd emulates the bug by default, but has an option to enable proper behavior - "Emulate CD pause capability".

It has worked that way since Win9x so if it is a bug it is a really old one. In any case it seems to have no practical effect since after MCI_PAUSE the music can be resumed from where it left with the following MCI_PLAY command. The fact that the mode says "stopped" instead of really being "paused" may indeed be an oversight but the logic seems to work otherwise.

This problem exists in Grim Fandango and Interstate 76. The music actually stops there, instead of pausing. For Grim Fandango, setting options for MCI Audio in DxWnd doesn't help. It sometimes hold the music then it stops playing anymore.
Another thing I noticed is that some games don't play the next music after 1 is over.

YouTube Channel:
Sapta Debuggs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892

Reply 21 of 32, by Dee-Dee

User metadata
Rank Newbie
Rank
Newbie
Discrete_BOB_058 wrote on 2020-09-24, 08:20:

For Grim Fandango, setting options for MCI Audio in DxWnd doesn't help. It sometimes hold the music then it stops playing anymore.

The two CD box set I have of Grim Fandango does not have cd music tracks. The music is instead played digitally from files as far as I can tell.

Reply 22 of 32, by Discrete_BOB_058

User metadata
Rank Oldbie
Rank
Oldbie
Dee-Dee wrote on 2020-09-24, 12:51:
Discrete_BOB_058 wrote on 2020-09-24, 08:20:

For Grim Fandango, setting options for MCI Audio in DxWnd doesn't help. It sometimes hold the music then it stops playing anymore.

The two CD box set I have of Grim Fandango does not have cd music tracks. The music is instead played digitally from files as far as I can tell.

Strange, the music stops at menu. I decided to turn on the emulate cd pause capability and some other related options in DxWnd. Suprisingly it holds the music but not when you go one further step in menu. The music sometimes glitches and buffers. Not sure why but that MCI setting has effects.

YouTube Channel:
Sapta Debuggs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892

Reply 23 of 32, by Dee-Dee

User metadata
Rank Newbie
Rank
Newbie
Discrete_BOB_058 wrote on 2020-09-25, 04:31:

Strange, the music stops at menu. I decided to turn on the emulate cd pause capability and some other related options in DxWnd. Suprisingly it holds the music but not when you go one further step in menu. The music sometimes glitches and buffers. Not sure why but that MCI setting has effects.

I tested Grim Fandango and the issue is not related in any way to cdaudio or MCI_PAUSE capability. The game mutes all sounds if you access the main menu (F1) key.

You can fix it by patching the game to v1.1. The patch is available at the ResidualVM web site under "Extras downloads":
https://www.residualvm.org/downloads/

It's basically a timing issue. Running in single core affinity may also help...

Reply 24 of 32, by Discrete_BOB_058

User metadata
Rank Oldbie
Rank
Oldbie
Dee-Dee wrote on 2020-09-25, 21:44:
I tested Grim Fandango and the issue is not related in any way to cdaudio or MCI_PAUSE capability. The game mutes all sounds if […]
Show full quote
Discrete_BOB_058 wrote on 2020-09-25, 04:31:

Strange, the music stops at menu. I decided to turn on the emulate cd pause capability and some other related options in DxWnd. Suprisingly it holds the music but not when you go one further step in menu. The music sometimes glitches and buffers. Not sure why but that MCI setting has effects.

I tested Grim Fandango and the issue is not related in any way to cdaudio or MCI_PAUSE capability. The game mutes all sounds if you access the main menu (F1) key.

You can fix it by patching the game to v1.1. The patch is available at the ResidualVM web site under "Extras downloads":
https://www.residualvm.org/downloads/

It's basically a timing issue. Running in single core affinity may also help...

I fixed it, thanks.

Btw I found Midtown Madness and MM2 using CD Audio and MM sound pauses in Pause Menu. MM2 music doesn't work at all but Audio is playable on WMP. I think it has that issue seeing similar MCI_PLAY problem for MM

YouTube Channel:
Sapta Debuggs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892

Reply 25 of 32, by Dee-Dee

User metadata
Rank Newbie
Rank
Newbie

For those of you who still use real genuine physical CD's to play old games on modern operating systems the cdaudio-wimm project might also be of interest. It aims to restore track repeat on Windows Vista - Windows 10 for games that use music tracks on the CD.

https://github.com/dippy-dipper/cdaudio-winmm

The main benefit here is that you do not need to rip the music from the CD.

Reply 26 of 32, by FulValBot

User metadata
Rank Member
Rank
Member

I post a feedback today about this bug, but i think that Microsoft will never see it...

I want to use hexen II with CD Audio feature (is GOG version) and i don't want to use Source Port to "fix" it...

Reply 27 of 32, by Dee-Dee

User metadata
Rank Newbie
Rank
Newbie
FulValBot wrote on 2021-03-02, 09:43:

I post a feedback today about this bug, but i think that Microsoft will never see it...

I want to use hexen II with CD Audio feature (is GOG version) and i don't want to use Source Port to "fix" it...

It is important to distinguish between issues caused by Microsoft's mcicda driver bugs and issues caused by modern re-packgaging of old games into digital distributions.

The original game playing from an original physical disc will have the mcicda bug which causes the music tracks to not repeat.

Digital redistributions from GOG, etc. do not of course have cdaudio tracks but instead use some kind of wrapper to play the music from digital files on the hard drive. For example .mp3 or .ogg files. These wrappers may not be compatible with Windows 10 (this was an issues affecting many older GOG releases) or might be affected by installed audio codecs, etc.

For example the GOG releases may use a plethora of different solutions for cdaudio music emulation. They may use the old _inmm program which modifies the game executables and makes the changes difficult to reverse. They might use a custom winmm wrapper that is renamed to sound.dll. They might even use a heavily modified game executable that implements the music playback in some custom way.

In some cases you may be able to replace the winmm wrapper provided by a GOG release with some other build that may work better. In most cases when dealing with a modern re-release of an old game you are better of using a source port.

Finally I have received reports that the winmm wrapper is not loading on some systems. This is a peculiar thing which I have not been able to reproduce. In theory Windows may be configured to reject local dll files and use system files instead and therefore bypassing any wrappers.

Reply 29 of 32, by FulValBot

User metadata
Rank Member
Rank
Member
ZellSF wrote on 2021-03-06, 12:41:

GOG's Hexen II release is also one of their most recent releases and shouldn't really have any issues (certainly doesn't here).

Hexen II HAS this problem... this happen when CD is selected in options

They have released a fix, but it doesn't work here... music still doesn't loop with CD selected; this patch has installed _inmm.dll in Hexen II folder but it doesn't work properly here; i don't know why they have included inmm and not winmm

this problem happen with both CD & GOG releases (steam version has only MIDI musics included)

edit: for some reason i see in details section "GOG.com winmm wrapper" but this is _inmm.dll not winmm.dll

Reply 30 of 32, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie

GOG's Hexen II release does not have this problem. I have tested this. It must be something wrong with your setup. Are you sure it's playing music through GOG's wrapper (there should be no Hexen II CD in your drive and no winmm.dll file in your Hexen II folder).

Reply 31 of 32, by FulValBot

User metadata
Rank Member
Rank
Member

_inmm.dll was included with patch "1.11 music fix" released by gog some day's ago

and when i say CD it means that in game options there are MIDI music and CD music, and when you select CD that uses .ogg files that are included in Hexen II folder (i don't have a CD version of game) music will not loop

old 1.11 version has not _inmm.dll included

Last edited by FulValBot on 2021-03-31, 08:23. Edited 2 times in total.