VOGONS

Common searches


First post, by Discrete_BOB_058

User metadata
Rank Member
Rank
Member

I got this error while launching Pitfall The Mayan Adventure. I looked up in Google, it said to install Indeo codec. I installed the latest version but the same problem still exists. I am using a 64 bit OS. Is there any setting I should change?

YouTube Channel:
DEADHistory Walkthroughs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892

Reply 1 of 8, by darry

User metadata
Rank l33t
Rank
l33t
Discrete_BOB_058 wrote on 2020-12-29, 06:21:

I got this error while launching Pitfall The Mayan Adventure. I looked up in Google, it said to install Indeo codec. I installed the latest version but the same problem still exists. I am using a 64 bit OS. Is there any setting I should change?

Have a look at this https://thisoldrecliner.neocities.org/pitfall.html

EDIT: and this, which the first link refers to --> Game will ONLY work with CD in drive

If you intend to make a disk image from your CD and play off of that, do note that the only free application that I knew of that supported mounting mixed mode CDs with CD audio support was Magicdisc, but that no longer works in recent versions of Windows 10 . The only non free application that I know of that supports mounting mixed mode CDs with CD audio support is Daemon Tools and it works in recent versions of Windows 10 (the lite version may have non desired components that some consider malware, be careful) .

Reply 3 of 8, by xcomcmdr

User metadata
Rank Member
Rank
Member

It's blocked since Windows 8.

Run this in an admin command prompt to re-enable it:

cd %WINDIR%\SysWOW64
regsvr32 ir50_32.dll /s

But that's for Intel Indeo v5.

IV32 means Intel Indeo v3. It's a totally different codec. Old Windows versions such as Windows 98SE have it installed already, but not Windows 8.
Since I can never find a 32 bit package of this codec than can be installed on Windows 8/10, I usually convert the videofile to Cinepak. Cinepak is still recognized by modern Windows versions.
You can do it with ffmpeg :
https://www.gyan.dev/ffmpeg/builds/

ffmpeg -i "INPUT_FILE.AVI" -c:a copy -c:v cinepak "OUTPUT_FILE.AVI"

It's very slow, but it usually works. Rarely, it's not recognized, and VirtualDub must be used (as VirtualDub will use the official Cinepak VfW codec, not the one built from scratch from the ffmpeg team) on an ancient system (such as Windows XP or 98SE) that can still decode Intel Indeo v3.

Anyway, once the file is converted, rename the output file and input file so the game uses it.

Reply 4 of 8, by Dee-Dee

User metadata
Rank Newbie
Rank
Newbie

I don't remember if Windows 10 still haves the files but for Windows 8.1 all the indeo video codecs come with the system they are just disabled.

You can re-enable them with a registry edit:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\ir32_32original.dll"="Intel Indeo(R) Video R3.2"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv32"="C:\\Windows\\system32\\ir32_32original.dll"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\ir41_32original.dll"="Intel Indeo® Video 4.5"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv41"="C:\\Windows\\system32\\ir41_32original.dll"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\ir50_32original.dll"="Indeo®-video 5.10"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv50"="C:\\Windows\\system32\\ir50_32original.dll"

Indeo audio codecs are also disabled and can be enabled:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\iac25_32.ax"="Indeo® audio software"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"msacm.iac2"="C:\\Windows\\system32\\iac25_32.ax"

Of course you are doing this with your own risk since Microsoft has delibarately disabled these codecs due to security concerns.

Reply 5 of 8, by Dee-Dee

User metadata
Rank Newbie
Rank
Newbie

To uninstall the abowe registry edits and disable the indeo codecs again:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\ir32_32original.dll"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv32"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\ir41_32original.dll"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv41"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\ir50_32original.dll"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv50"=-
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\iac25_32.ax"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"msacm.iac2"=-

Reply 7 of 8, by darry

User metadata
Rank l33t
Rank
l33t

AFAIK, the splash/intro video is the only thing you need indeo for, and that video is not particularly interesting and can be skipped.

Additionally, you can watch it using Media Player HomeCinema, which has a built-in Indeo decoder, so no need to jump through hoops to install a potentially unsafe Indeo codec . The video file is an AVI file in the assets folder on the CD .

Reply 8 of 8, by Discrete_BOB_058

User metadata
Rank Member
Rank
Member
Dee-Dee wrote on 2020-12-29, 14:14:
I don't remember if Windows 10 still haves the files but for Windows 8.1 all the indeo video codecs come with the system they ar […]
Show full quote

I don't remember if Windows 10 still haves the files but for Windows 8.1 all the indeo video codecs come with the system they are just disabled.

You can re-enable them with a registry edit:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\ir32_32original.dll"="Intel Indeo(R) Video R3.2"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv32"="C:\\Windows\\system32\\ir32_32original.dll"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\ir41_32original.dll"="Intel Indeo® Video 4.5"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv41"="C:\\Windows\\system32\\ir41_32original.dll"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\ir50_32original.dll"="Indeo®-video 5.10"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv50"="C:\\Windows\\system32\\ir50_32original.dll"

Indeo audio codecs are also disabled and can be enabled:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
"C:\\Windows\\system32\\iac25_32.ax"="Indeo® audio software"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]
"msacm.iac2"="C:\\Windows\\system32\\iac25_32.ax"

Of course you are doing this with your own risk since Microsoft has delibarately disabled these codecs due to security concerns.

Than you very much 😀.

xcomcmdr wrote on 2020-12-29, 12:58:
It's blocked since Windows 8. […]
Show full quote

It's blocked since Windows 8.

Run this in an admin command prompt to re-enable it:

cd %WINDIR%\SysWOW64
regsvr32 ir50_32.dll /s

But that's for Intel Indeo v5.

IV32 means Intel Indeo v3. It's a totally different codec. Old Windows versions such as Windows 98SE have it installed already, but not Windows 8.
Since I can never find a 32 bit package of this codec than can be installed on Windows 8/10, I usually convert the videofile to Cinepak. Cinepak is still recognized by modern Windows versions.
You can do it with ffmpeg :
https://www.gyan.dev/ffmpeg/builds/

ffmpeg -i "INPUT_FILE.AVI" -c:a copy -c:v cinepak "OUTPUT_FILE.AVI"

It's very slow, but it usually works. Rarely, it's not recognized, and VirtualDub must be used (as VirtualDub will use the official Cinepak VfW codec, not the one built from scratch from the ffmpeg team) on an ancient system (such as Windows XP or 98SE) that can still decode Intel Indeo v3.

Anyway, once the file is converted, rename the output file and input file so the game uses it.

Currently DeeDee's solution seems easier so I will give this one a try in the future.

darry wrote on 2020-12-29, 16:02:

AFAIK, the splash/intro video is the only thing you need indeo for, and that video is not particularly interesting and can be skipped.

Additionally, you can watch it using Media Player HomeCinema, which has a built-in Indeo decoder, so no need to jump through hoops to install a potentially unsafe Indeo codec . The video file is an AVI file in the assets folder on the CD .

Just wanted to make sure everything is compatible or not, things are breaking with newer versions of Windows.

YouTube Channel:
DEADHistory Walkthroughs

PC SPECS:-
CPU: AMD Ryzen 5 1600
GPU: ZOTAC NVIDIA GeForce GTX 1050Ti OC Edition
RAM: 8GB*2 Corsair Vengeance LPX DDR4 2400MHz
Motherboard: Gigabyte Aorus B450M
PSU: Corsair VX550
Sound Card: Realtek ALC892