VOGONS

Common searches


Trade empires

Topic actions

First post, by ladderman

User metadata
Rank Newbie
Rank
Newbie

Hi

I have been trying to get this game to work properly for a while now.The problem i have is that there are no buildings where they have been placed,there's an outline of where the building should be but nothing else.See attached image.

I have tried the DGvoodoo approach,but that didn't work.

Does anyone have any ideas how to solve my invisible buiding bug?.

Thanks in advance.

Colin

Attachments

  • Clipboard01.jpg
    Filename
    Clipboard01.jpg
    File size
    160.81 KiB
    Views
    563 views
    File license
    Public domain

Reply 1 of 17, by ZellSF

User metadata
Rank l33t
Rank
l33t
Trade Empires_2022_01_18_11_18_37_706.jpg
Filename
Trade Empires_2022_01_18_11_18_37_706.jpg
File size
139.23 KiB
Views
527 views
File license
Fair use/fair dealing exception

Works fine here. Seems to be a "you" problem.

If it has the same issue without dgVoodoo, I would assume a bad copy of the game. But as said above, it's a "you" problem, you need to eliminate a lot of variables yourself, and if you want us to help, provide a lot of information.

Reply 2 of 17, by ladderman

User metadata
Rank Newbie
Rank
Newbie

Hi ZellSF

Okay i have reinstalled my copy of Trade empires patched it to 1.1,and i'm now getting the error message when try to launch the game"Unable to load/locate data file: unit.{}"

I've googled this error but nothing comes up.

MySystem specs

Windows 10 Home 64 Bit
Gigabyte Z370 AORUS Ultra Gaming: ATX, LG1151, USB 3.1, SATA 6GBs
Intel Core i7 Six Core Processor i7-8700k (3.7GHz) 12MB Cache
Super Quiet Titan DragonFly Heatpipe Intel CPU Cooler
1TB SEAGATE FIRECUDA 3.5" SSHD
6TB WD BLACK 3.5" WD6001FZWX, SATA 6 Gb/s, 128MB CACHE (7200rpm)
CORSAIR 650W TXm SERIES SEMI-MODULAR 80 PLUS GOLD, ULTRA QUIET
8GB AMD RADEON™ RX 580 - HDMI, 3 x DP - DX 12
8GB AMD RADEON™ RX 580 - HDMI, 3 x DP - DX 12
Creative Sound Blaster Zx 5.1 PCI-E Soundcard
TP-Link Archer T3U AC1300 Mini USB Wi-Fi Adapter
32GB Corsair VENGEANCE DDR4 3000MHz (2 x 16GB)
24x DUAL LAYER DVD WRITER ±R/±RW/RAM
AOC G2770PF LCD 27 inch Monitor

Attachments

  • Filename
    My DxDiag.txt
    File size
    109.12 KiB
    Downloads
    8 downloads
    File license
    Public domain

Reply 4 of 17, by ladderman

User metadata
Rank Newbie
Rank
Newbie

So here is a screenshot of the game folder,and another showing the properties of the game folder.

Attachments

  • Clipboard01.jpg
    Filename
    Clipboard01.jpg
    File size
    33.89 KiB
    Views
    489 views
    File license
    Public domain
  • Clipboard02.jpg
    Filename
    Clipboard02.jpg
    File size
    74.63 KiB
    Views
    489 views
    File license
    Public domain

Reply 5 of 17, by ZellSF

User metadata
Rank l33t
Rank
l33t

Not missing files then.

So a few minutes of experimentation later reveals that
SoftwareDevice=1
in TradeEmpires.ini makes the game look as your screenshot. It's not a default option, so I have no idea why you would have it set, but change it back to 0.

Reply 6 of 17, by ladderman

User metadata
Rank Newbie
Rank
Newbie

Okay now this is curious.I have just checked my TradeEmpires.ini,and it says that SoftwareDevice value is set at 0 not 1?!.This is from a fresh install of the game.

Is there anyhting else i can try?.

Reply 10 of 17, by ladderman

User metadata
Rank Newbie
Rank
Newbie

So i managed to get my graphics problem fixed with this game.But now i can only play for abut 2-3 minutes before the game Crashes To Desktop.Any ideas on how i can stop the game Crashing To Desktop?.

Reply 11 of 17, by ZellSF

User metadata
Rank l33t
Rank
l33t

Not any specific things, but some things to try:

1) Make sure you're using dgVoodoo (check if the watermark shows), I've seen native ddraw cause crashes in other games.

2) Run in compatibility mode for Windows 98 (or if you know how to use compatibility administrator, enable just the EmulateHeap fix).

3) Run with single core affility (open task manager, right click the process, set affinity to just one core).

Does it crash when it's supposed to play a sound effect, or change the background music?

Reply 12 of 17, by ladderman

User metadata
Rank Newbie
Rank
Newbie

1. Yes i was using dgVoodoo,the watermark showed okay.

2. Ran Trade Empires in compatibility mode for Windows 98 still the same problem.EmulateHeap,not too sure what that is.Google didn't seem too sure either...

3. Tried single core affility,all i was getting was funky colors on the menu screen(reduced resolution,and unable to click on options.)

Reply 14 of 17, by ladderman

User metadata
Rank Newbie
Rank
Newbie

This is the event viewer error report for the last time i ran Trade empires

Fault bucket 827054072, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: Trade Empires.exe
P2: 1.10.2.1
P3: 3bba8176
P4: Trade Empires.exe
P5: 1.10.2.1
P6: 3bba8176
P7: c0000094
P8: 0000c298
P9:
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERDDE0.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERDE6D.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERDE7E.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERDE7C.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERDE9C.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Trade Empires.ex_da447da2e818efe643dd2acc5aac697236b19ed_166b359a_37a77322-4b76-4c10-950b-a5dcb6a90836

Analysis symbol:
Rechecking for solution: 0
Report Id: 440965f1-bbc1-45bf-9e08-bbf9b06e002c
Report Status: 268435456
Hashed bucket: d32348ff7fdaa282f7852cc2322000bc
Cab Guid: 0

Reply 15 of 17, by BEEN_Nath_58

User metadata
Rank Oldbie
Rank
Oldbie

A basic thing to try is to install it on a non system drive (usually other than C:\) if you have other drives. If you don't have that, have a try at DxWnd with it's Handle Exceptions flag and hope that the game doesn't crash. It also has 4 different options for heap, some different from the ACT ones too. The SoftwareDevice=1 had issues with me too and I also couldn't get the game to crash.

previously known as Discrete_BOB_058

Reply 17 of 17, by BEEN_Nath_58

User metadata
Rank Oldbie
Rank
Oldbie
ladderman wrote on 2022-01-22, 18:34:

I have Trade Empires installed on a non system drive but i'm still geting the same error.You'll have to forgive me because i'm stll getting use to all the many edit\modify settings on DXwnd!.

Add this .dxw profile to DxWnd by dragging and dropping. Then modify the game executable location in "Path:". Let's hope it does the trick, but maybe it won't.

Attachments

previously known as Discrete_BOB_058