DgVoodoo 1 Discussion Thread

General information and assistance with dgVoodoo.

DgVoodoo 1 Discussion Thread

Postby Vigilante58 » 2004-8-21 @ 13:03

Ok let us continue in here :happy:

First let me thank Dege once more for his great glide wrapper...

Right now, are there any games that haven't been tested yet?

I haven't tested carmageddon with the latets version and drivers, but will do so very soon.

Also, does anyone know where to get the game x-car?? I have a demo somewhere but I don't think that one supports 3dfx. Would like to test if it works with dgVoodoo.
Vigilante58
Newbie
 
Posts: 23
Joined: 2004-7-04 @ 15:48
Location: Netherlands

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Vigilante58 » 2004-8-21 @ 13:32

Just tried ATI Catalyst 4.8 drivers on dgVoodoo and the pc still shuts down and reboots when I try to launch it. I had the same problem with the 4.7 drivers, though everything worked fine with 4.6.

This seems to be a serious issue. I was hoping that the cause of the problem can be found, so I won't be forced to use old drivers if I want to use dgVoodoo :depressed:
Vigilante58
Newbie
 
Posts: 23
Joined: 2004-7-04 @ 15:48
Location: Netherlands

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Dege » 2004-8-21 @ 14:03

What happens when you try to run it in server mode?

BTW, it reboots at once, or the blue screen pops up? If it pops up, in what module does the error occure? (just to make sure it is indeed in a display component)
And, other ATI users, does it work for you with 4.7 or 4.8?
Dege
Oldbie
 
Posts: 865
Joined: 2003-9-04 @ 11:06

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Vigilante58 » 2004-8-21 @ 15:30

From an older post:

I've only tried it with Carmageddon. When I enable the VDD mode, the pc reboots when it tries to load the vdd dll when starting the game. When I disable VDD in the dgVoodoo setup, it just closes.


Tried without VDD again with the logger version and it gave this output in the .log file:

Entering InitDosNT()
NT mode: Server
Leaving InitDosNT() successfully
Error: DGCLIENT_BEGINGLIDE has failed: cannot open shared memory
Error: DGCLIENT_BEGINGLIDE has failed: cannot create a view on shared mem object


When I launch it with VDD enabled, as soon as the game starts and the dgVoodoo overlay window can be soon along with the dos box, it reboots completely without any blue screen or any other thing.

Hope this helps ya ;)
Vigilante58
Newbie
 
Posts: 23
Joined: 2004-7-04 @ 15:48
Location: Netherlands

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby VirtuaIceMan » 2004-8-21 @ 21:33

Just to add to Dege's question, do the following to actually see blue screen errors in WinXP rather than auto-reboots (assuming you're using WinXP):

Right-click "My Computer" -> click Advanced tab -> click Startup and Recovery Settings button -> uncheck the box under System failure that says Automatically restart.

Ice
User avatar
VirtuaIceMan
Oldbie
 
Posts: 829
Joined: 2003-12-22 @ 00:57

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Vigilante58 » 2004-8-21 @ 22:13

This is feeling like a rewind of the discussion in the 'part uno' thread :lol: . I believe I said before that disabling that setting does not change anything. Also, when VDD mode is enabled, nothing gets written to the log file prior to the reboot (so nothing at all when VDD mode is enabled).

I switched back to Catalyst 4.6 once again and everything's working fine, meaning it's 100% certain that a change in the driver code during the 4.6 > 4.7 transition is the cause of the reboot problem.

Dege, I remember you saying you don't have an ATI card? also, do I seem to be the only person in here who's having this problem?

I have a 9700 pro card... maybe you could examine the changelog of the 4.7 drivers to see if there's anything that could cause the problem?
Vigilante58
Newbie
 
Posts: 23
Joined: 2004-7-04 @ 15:48
Location: Netherlands

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Vigilante58 » 2004-8-21 @ 22:34

Ok I can verify now that I get a solid blue screen without any error messages when disabling that option.

If you want me to make a kernel dump or memory dump of the errors, just let me know :s-face:
Vigilante58
Newbie
 
Posts: 23
Joined: 2004-7-04 @ 15:48
Location: Netherlands

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby VirtuaIceMan » 2004-8-22 @ 00:44

Incidentally I'm running an Asus 9800XT with Catalyst 4.8 and am having no problems at all. Admittedly this information is as useful as a chocolate teapot for Vigilante58 :wink:

Vigilante58, try modifying the fast write and/or AGP speed in the Catalyst SMARTGART tab to see if that does anything (I had to play with that to make Doom3 work without "snow" on Catalyst 4.7 but it's fine on 4.8 so maybe it's worth a look). Also try stock "normal" slider settings in the ATI setup panels.

Also, what options do you set in dgVoodooSetup? I doubt this is the root of the problem but it's worth comparing to see if I can replicate crashes on my ATI card.

Incidentally I run dgVoodoo by putting the necessary dgVoodoo files inside the games folder as I use Zeckensack's wrapper system-wide currently and only use dgVoodoo currently for the "problem" games like Boss Rally, Screamer2/Rally, Test Drive Off-Road and NFS2:SE that Zeck's wrapper doesn't run, so I don't use Server mode ever*.

* note that when I get around to testing all my games again this might change!

Ice
User avatar
VirtuaIceMan
Oldbie
 
Posts: 829
Joined: 2003-12-22 @ 00:57

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Vigilante58 » 2004-8-22 @ 08:57

Hi, ok here are some points of interest (or not :blush:)

- Tried Carmageddon 2 with dgVoodoo and it works without crashing.
- I run dgVoodoo by putting it in the game folder.

As for the settings, these are the default settings, adjusted to 32bit Hardware T&L with forced bilinear filtering.

This might be a Carmageddon 1-only error. Perhaps you could download (or whatever) the game with the 3dfx patch and see if you get the same problem.

Small question, are you referring to Test Drive Offroad 1? Because I didn't know that game can run on 3dfx :surprised:

One more thing, there seems to be a universal problem with glide wrappers that hits the game Carmageddon. In a couple of races, the game craches back to desktop on random events. This problem has already been confirmed at the Glidos webpage. The first level I'm having the problem with is 'Fridge Racer'.

I still have an old Voodoo 2 card laying here somewhere, so I might try running Carmageddon on that one and see if it's in fact a bug in the 3dfx version instead of some glide wrapper issue that triggers the crashes.
Vigilante58
Newbie
 
Posts: 23
Joined: 2004-7-04 @ 15:48
Location: Netherlands

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Dege » 2004-8-22 @ 09:26

It's strange that, when you try it in server mode, it cannot open the shared memory (according the log you included in the quote). I'm really curious about why it happens (supposed that server starts without any error message). I thought it can only occure in an exaggerated case. I'm going to put the current test version on dege.fw.hu today, which will also log the error codes, I hope this will get me closer to the solution.

I will send a new message when the test version is available.
Dege
Oldbie
 
Posts: 865
Joined: 2003-9-04 @ 11:06

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby barev » 2004-8-22 @ 09:43

HI!
I was going to post some feedback for dgVooDoo v1.30+ running on my machine with the various glide games I have but it seems that the latest versions are not compatible with win98se. I have a dual boot setup with win2k (for work and everyday use) and win98se (for games and older applications) and all versions of dgVooDoo seemed to work fine with both OS. But after dgVooDoo 1.30 I was not able to run any game in win98se using dgVooDoo. In win2k everything runs fine. But as everybody knows running old DOS games on win2k with sound is impossible. As my PC isn't really fast enough emulation is not a good option. That is why I am still using win98se. First I thought it was the stupid windows that is causing the problem but after reinstalling it for the 5th time I realized that is not the case. I have all versions of dgVooDoo since 1.20 and all work fine with win98se except for 1.30 and later. I really appreciate Dege's effort to make more games running fine with dgVooDoo (I am a great Carmageddon fan and the latest version runs it almost perfectly except some fog issues, but I am not sure if they are not a problem with the game itself and not dgVooDoo, nevertheless the game is fully playable and really rocks:) and I would like to ask if anyone knows what is the problem with win98se. I also tried using the log version in order to put some light on what exactly the problem is but it seems that the games crash even before control is passed to dgVooDoo as if I haven't started the server process and invalid references in the dos glide library are reported. I wonder if Dege was able to test the latest versions in win98se or maybe support for win98 is discontinued? Any kind of help would be appreaciated
barev
Newbie
 
Posts: 8
Joined: 2004-4-20 @ 17:57

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Dege » 2004-8-22 @ 09:57

No, no, support for Win9x/Me isn't discontunied. The truth is, 1.30 and the first release of 1.30b won't work under Win98. The reason is I simply forgot to ship it with the updated vxd component. :blush: That's why I removed 1.30 from my "website" at once and relased 1.30b again. However, 1.30c should work properly. Are you using this version?

If so, what symptoms do you experience (reboot, etc)?
I will test it again under w98 however, just to make sure it really works. :happy:
Dege
Oldbie
 
Posts: 865
Joined: 2003-9-04 @ 11:06

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby CraigG » 2004-8-22 @ 13:06

Well, I can report that dgvoodoo 1.30c runs fine on my PC. No crashes or strange stuff.
Carmageddon 1 AND 2, both work great, and so far I've not had a crash or anything.
Only Ignition still has a rainbow effect going on with the graphics.

Athlon XP Barton 2.5
Radeon 9700 Pro - Catalyst 4.8, Radlinker, Rage3D Tweak
WinXP Pro SP1, no other updates
1 Gb RAM

Dege, just as a favour, I don't suppose you could omit the screenshots from the zip ? Or even upload a smaller zip or rar file without them ?

Dege, I've also found a few glide 1 games, like Pandemonium. If you want, I can rar up Pandemonium and post it on my webspace. That would give you a starting block if you attempt to do some Glide to Glide2 routing. It's 11Mb.
Athlon 64 3000+ stock
MSI NForce 4 K8N Neo Platinum
2Gb RAM
nVidia Geforce 6800GT stock clocks
SBLive! Platinum + Audigy ZS2 Drivers
WinXP Pro SP2
User avatar
CraigG
Member
 
Posts: 207
Joined: 2002-9-01 @ 16:13

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Dege » 2004-8-22 @ 13:14

Vigilante, I've put a test version on fw: http://dege.fw.hu/dgvoodoo_test.zip

Try this in server mode, and plz public the log file.
I've also tested it under W98, it should work.

Dege, I remember you saying you don't have an ATI card?

Yes, I have a GeForce FX 5700Ultra.
also, do I seem to be the only person in here who's having this problem?

Frankly, not. SYS (he is from Hungary too, and already wrote some posts here on VOGONS) has an ATI card too. He has also serious problems with dgv under XP. He also gets reboot or corrupted rendering. :sad: I don't know why.

EDIT: reply to Craig

Hi Craig!
I'm glad it works properly for you! :happy: However Ignition is strange: I've downloaded it from underdogs (where Ice suggested) and it indeed produced rainbow coloured polygons with 1.23 but not with 1.30! (I didn't try to discover what the problem was, I thought problem was fixed when I rewrote a lot of parts in dgv). Why do you still get rainbows? :confused:

Zips without screenshots is a good idea, because it seems it's a big pain to download dgv from freeweb. I will eithter put screenshots in the html itself or will create a smaller version too. :happy:

And Pandemonium, it would be very cool for me if I could get it for testing! :cool:
Dege
Oldbie
 
Posts: 865
Joined: 2003-9-04 @ 11:06

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Vigilante58 » 2004-8-22 @ 13:56

Entering InitDosNT()
NT mode: Server
Leaving InitDosNT() successfully
Error: DGCLIENT_BEGINGLIDE has failed: cannot open shared memory, error code: 02
Error: DGCLIENT_BEGINGLIDE has failed: cannot create a view on shared mem object, error code: 0b7


Anything else you want me to do? ;)
Vigilante58
Newbie
 
Posts: 23
Joined: 2004-7-04 @ 15:48
Location: Netherlands

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby CraigG » 2004-8-22 @ 14:48

I thought problem was fixed when I rewrote a lot of parts in dgv). Why do you still get rainbows?


It's now working, Dege. It was me, not you, lol.
I had an older dgvoodoo in the ignition directory, so I deleted it. It now uses the main Windows\system32 directory which has the latest one in.

I'm uploading Pandemonium as I type this.
I'll email you the link, when it's done.
Athlon 64 3000+ stock
MSI NForce 4 K8N Neo Platinum
2Gb RAM
nVidia Geforce 6800GT stock clocks
SBLive! Platinum + Audigy ZS2 Drivers
WinXP Pro SP2
User avatar
CraigG
Member
 
Posts: 207
Joined: 2002-9-01 @ 16:13

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Dege » 2004-8-23 @ 10:21

Entering InitDosNT()
NT mode: Server
Leaving InitDosNT() successfully
Error: DGCLIENT_BEGINGLIDE has failed: cannot open shared memory, error code: 02
Error: DGCLIENT_BEGINGLIDE has failed: cannot create a view on shared mem object, error code: 0b7

Hm, so serverproc starts with no error and you get this when try to start a dos prog? It seems as if serverproc didn't start at all. I simply can't understand it. :confused:
And this version still reboots in VDD mode?
Dege
Oldbie
 
Posts: 865
Joined: 2003-9-04 @ 11:06

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby Vigilante58 » 2004-8-23 @ 12:22

yup... Blue screen / forced reboot when VDD mode enabled, closing window when Server mode. No .log file with VDD mode, the above .log with Server mode.

Are you sure dgVoodoo doesn't have any memory calls that are obsolete now due to a driver change and now crashing the pc or something? :s-face:
Vigilante58
Newbie
 
Posts: 23
Joined: 2004-7-04 @ 15:48
Location: Netherlands

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby CraigG » 2004-8-23 @ 12:42

Are you sure dgVoodoo doesn't have any memory calls that are obsolete now due to a driver change and now crashing the pc or something?


But wouldn't that affect us all ?
I'm more inclined to believe it's your PC doing something not nice.

Have you tried removing the ATI drivers via the control panel, rebooting to safe mode, running Driver Cleaner

http://www.majorgeeks.com/download3214.html

And select all the ATI options.
Then run Regedit, and do a search for ati2mtag, and delete all finds, including some where you have to give permission rights.
Reboot, and install Catalyst 4.8, then perhaps install DX9.0c, just to be sure.
Athlon 64 3000+ stock
MSI NForce 4 K8N Neo Platinum
2Gb RAM
nVidia Geforce 6800GT stock clocks
SBLive! Platinum + Audigy ZS2 Drivers
WinXP Pro SP2
User avatar
CraigG
Member
 
Posts: 207
Joined: 2002-9-01 @ 16:13

Re: A glide wrapper for DOS programs - part deux (dgVoodoo)

Postby ableeker » 2004-8-23 @ 13:01

I came across this thread because I wanted to check if anybody else had any problems running dgVoodoo with an ATI video card. Yes, I have the same problem as Vigilante58, I get a blank BSOD when I try to run Tombraider 1, and have to reset the computer.

ATI 9600 Pro with Catalyst 4.8 (4.7 reboots as well), AMD Athlon 1.33 GHz, 512 MB RAM. Running XP SP2, but the reboot also occurred under SP1.

Weird thing is, if I switch to another XP SP2 partition on this very same computer, dgVoodoo runs just fine. I don't recall what version of Catalyst that's running. It might be 4.6, but I doubt that, it's probably 4.7. I'll have to check that, as Vigilante58 mentions that 4.6 seems to work.

Hope this helps.
User avatar
ableeker
Newbie
 
Posts: 64
Joined: 2003-7-12 @ 22:15
Location: Amsterdam

Next

Return to dgVoodoo General

Who is online

Users browsing this forum: Dagar, daniel_u and 3 guests