List of Web Browsers For All Operating Systems

Schedules and announcements about program releases.

List of Web Browsers For All Operating Systems

Postby eL_PuSHeR » 2006-5-10 @ 08:06

Browser downloads:
https://browsers.evolt.org/
https://retrosystemsrevival.blogspot.com/


RECOMMENDED BROWSERS

OS COMPATIBILITY (Latest Browsers)
DOS: Links 2.16
Linux (Latest): Any
MacOS (Latest): Any
Windows 3.x: Opera 3.62 16bit (Likely unusable on modern web without a proxy)
Windows 95 (which version?): RetroZilla
Windows 98-ME: Need to test New Moon w/ Kernelex
Windows NT 3.5x: ? Need to test Retrozilla
Windows NT4: RetroZilla
Windows 2000: New Moon w/ BlackwingCat Extended Kernel
Windows XP/2003: New Moon
Windows Vista/2008: New Moon
Windows 7/2008R2+: Any

BATTERY LIFE
Linux: Firefox
MacOS: Safari
Windows: Edge

SECURITY (Update frequency and hacks):
Linux: Chrome
MacOS: Chrome
Windows: Chrome

PRIVACY:
Linux: FireFox (with addons)
MacOS: Firefox (with addons)
Windows: Firefox (with addons)

ANONYMITY
Linux: Tor
MacOS: Tor
Windows: Tor

LEAST RESOURCES/BANDWIDTH
Linux: Lynx
MacOS: Lynx
Windows: Lynx

ALL BROWSERS

Advanced Chrome
OS Supported: Windows XP,Vista+

Download

XP
use v54

Cyberfox 52.9.1
OS Supported: Windows 7+, Linux

Download

Dooble 2.1.9.3
OS Supported: Windows XP+, Linux, OSX

Download

Windows 2000
Download
? Need to try later than v1.26.1. Supposedly v1.4 works.
v1.26.1 Verified

Edge
OS Supported: Windows 10/2016

Falkon 3.0.1
OS Supported: Windows 7+, Linux

Download

Google Chrome 67
OS Supported: Windows 7+, Linux, Mac

Download

Download Google Chrome for Enterprise (Installs in C:\Program Files)

System Requirements

Chrome Canary

SRWare Iron (version of Google Chrome for privacy)

Windows Vista
?

Windows XP

OFFICIAL
Use Chrome 49

UNOFFICIAL
?

Windows 2000

Google Chrome does not work on Windows 2000 to get it to work you have to use the wrappers provided by Blackwingcat.

He has simplified the process so that all you need to do is download his chrome wrapper. Execute the Chrome Wrapper to apply the fix and then reboot.

http://blog.livedoor.jp/blackwingcat/ar ... 60097.html

Tested SRWare Iron v16.0.950.0 on 1-17-2011 on Windows 2000 Pro SP4

MacOS

32bit
Chrome 38

Internet Explorer

Windows 10/2016
Internet Explorer 11

Windows 8.1/2012R2
Internet Explorer 11

Windows 7/2008R2
Internet Explorer 11

K-Meleon 77
OS Supported: Windows XP+

Download


Windows 2000
https://github.com/roytam1/kmeleon/releases

Use K-Meleon 74 (works with vanilla 2000)

OLD
K-Meleon 1.6.0 Beta 2

Windows 95\NT4
?
Use K-Meleon v1.5.4

Windows 98\ME
?

OFFICIAL
Use K-Meleon v1.5.4

UNOFFICIAL
Use K-Meleon v1.7 with KernelEX v4.5.2 (Run in Windows 2000 compatibility mode) (VERIFIED) (May also need Visual C++ 2005 runtime installed)
Use K-Meleon 74 with KernelEX https://retrosystemsrevival.blogspot.co ... ition.html (UNVERIFIED)

Lunascape 6.15.2
OS Supported: Windows XP+

Download

Windows 98\ME
Use Lunascape 6.2. Only works with IE rendering engine.

Windows 2000

OFFICIAL
v6.2.0 with IE rendering engine

UNOFFICIAL
?

v6.5.6

To use WebKit and Gecko Engines:

1. Go here C:\Program Files\Lunascape\Lunascape6\plugins
2. Find the Gecko and Trident executables.
3. Extract the contents of each with 7-zip.
4. Run the extracted executable.
5. The executable will extract the content. Move the content to the root of the folder.
EX: (9BDD5313-xxxxxxx).

Lynx 2.8.8
OS Supported: DOS, Windows, Linux

Download

?
Need to check Windows ver compatibility

Maxthon v5.x
OS Supported: Windows XP+, Linux

Download

2000?

Midori v0.5.11
OS Supported: Windows XP+, Linux

Download

Windows 2000
Use v0.4.0
Requires KDW Wrapper. (Use ws2_32.dll from KDW Wrapper)
Also requires GDI+ http://www.microsoft.com/download/en/de ... n&id=18909

Mozilla Firefox 62.0
OS Supported: Windows 7+, Linux, MacOS

Release Notes

Download

System Requirements

Tips

Firefox 7+

Enable\Disable "http" in address bar:

Change "browser.urlbar.trimURLs" in about:config to True\False

Windows Vista
?
Use 52.9.0 ESR

Windows XP
SSE1: Use v45 ESR
SSE2: Use v52.9.0 ESR

64bit
Use Waterfox 46

Windows 2000

OFFICIAL
Firefox 12.0 is the latest version that will work on Windows 2000.

UNOFFICIAL
SSE1: Use v45 ESR w/ blackwingcat extended kernel (unverified)
SSE2: Use v52.9.0 ESR w/ blackwingcat extended kernel (unverified)


Windows 95

OFFICIAL
FireFox v1.5.0.12 is the latest version that will work on Windows 95.
Tested with Windows 95C on 6-22-2011

UNOFFICIAL
Firefox v2.0.0.20
Tested with Windows 95C

Download and install the following Updates:

Platform SDK Comctl32 Redistributables 5.80.2614.3600
KB
DOWNLOAD


Platform SDK Redistributable: DCOM95 Redistributables
KB
DOWNLOAD


Microsoft Libraries Update
DOWNLOAD

Windows Sockets 2.0 for Windows 95
KB
DOWNLOAD

REBOOT AFTER INSTALLING THE ABOVE UPDATES


Install Firefox.
Select Custom Install and unselect:
"DOM Inspector" and "Quality Feedback Agent".
(Otherwise will crash).

Go to C:\Program Files\Mozilla Firefox\Components.
Delete "nsSearchService.js" and "nsSafebrowsingApplication.js" (Otherwise
Firefox will not load).

Links:
SOURCE


Windows 98\ME

OFFICIAL
Firefox v2.0.0.20 (works with JAVA)

UNOFFICIAL

NO JAVA SUPPORT

Firefox 8 works with KernelEX v4.5.2
Firefox 9 with KernelEX (unverified)
You may Unofficial Visual C++ 2008 Redist to run Firefox 8.
Do not use Firefox 10. Issues with freezing.

JAVA SUPPORT

Use Firefox v3.5.19 (Requires KernelEX) with Java 6 Update 29 (DISABLE NEXT GENERATION PLUGIN IN JAVA CONTROL PANEL)

You may have issues with some Java testing websites with Java 6 Update 29 due to them wanting an older version of Java.

Windows NT 3.51/4.0

UNOFFICIAL
Firefox v2.0.0.20 is the latest that will work.

Tested with NT4 SP6 on 6-22-2011

MyPal 28.0.1
OS Supported: Windows XP

Download

Windows 2000
Need to try with Kernelex

Opera 53
OS Supported: Windows 7+, Linux, MacOS

Download

Opera Beta

FTP Download

Windows Changelog

Windows Vista
?
Use v36.0.2130.80

Windows XP
?
Use v36.0.2130.80

Windows 2000

OFFICIAL
?
Opera 12.50 snapshot build 1513. (UNVERFIED)
Opera 12.02 build 1578 (VERIFIED)

UNOFFICIAL
?

Windows 3.x

Opera 3.62 16bit

Tested with Windows 3.11 for Workgroups on 8-5-2011

Windows 95

OFFICIAL
Use Opera v10.10 (Verified)

UNOFFICIAL
http://danika.jukor.net/opera1063win95.html

Install Opera 10.63 using the classic installer
Download UPX in order to uncompress opera.dll
Extract opera.dll using UPX
Open opera.exe in a hex editor (such as XVI32), change references to "DuplicateTokenEx" to "DuplicateToken"
Open opera.dll in a hex editor, change references to "InterlockedCompareExchange" to "InterlockedExchange" and "GlobalMemoryStatusEx" to "GlobalMemoryStatus"
Note: add null characters in order to terminate the string and maintain its original length
Optional: Recompress opera.dll using UPX (not required, but recommended)

Windows 98\ME

OFFICIAL
Opera 10.10 (for JAVA support)
Opera 10.63 (NO JAVA support)

UNOFFICIAL

NO JAVA SUPPORT
?
Use Opera 11.64 with KernelEx
Use Opera v12.12 with KernelEX http://sourceforge.net/projects/kernelex/
May need to run setup in Windows 2000 Compatibility Mode

JAVA SUPPORT

Use Java 6 Update 29 (not supported but works DISABLE NEXT GENERATION PLUGIN IN JAVA CONTROL PANEL) with Opera 10.10


Windows NT 3.51

Opera 5.12

Windows NT 4.0

Opera v10.63 is the latest that will work. (Use the Classic Installer)

Tested with NT4 SP6 on 6-22-2011

Otter Browser
OS Supported: Windows XP+, Linux, MacOS

Download

Windows 2000
Use Blackwingcat Extended Kernel (Unverified)

Palemoon v28.1.0
OS Supported: Windows 7+, Linux

Download

XP-Vista
Use v27.9.4

2000
Use BlackWingcat extended Kernel for 2000
https://msfn.org/board/topic/177125-my- ... on-for-xp/
https://o.rthost.cf/palemoon/?sort=date&order=desc
https://github.com/roytam1

Palemoon 26.5 possibly works in vanilla 2000 (unverified)

Retrozilla
OS Supported: Windows 95,NT3.51,NT4

Download

Safari 11.1.1
OS Supported: MacOS

Download from the App Store

Seamonkey 2.49.4
OS Supported: Windows XP+, Linux, OSX

Download

Windows 2000
?
Seamonkey 2.9 (SSE)
Seamomkey 2.4 (NO SSE)

Windows 95\3.51\NT4
Use SeaMonkey v1.1.19

Windows 98\ME

OFFICIAL
Use SeaMonkey v1.1.19

UNOFFICIAL
Use SeaMonkey v2.5 Beta 4 with KernelEX v4.5.2 (Run in Windows 2000 compatibility mode)

Vivaldi 1.15
OS Supported: Windows 7+, Linux

Download

UNOFFICIAL




-----------------------------------------------------------------------------------------------------------------------------------------------------------------------
NOT ACTIVE

Arachne
OS Supported: DOS, Linux

Download

Cello v1.01a
OS Supported: Windows 3.x, NT 3.5, OS/2

Download

Classilla 9.3.3
OS Supported: Mac OS 8.6/9

Download

Dillo 3.0.5
OS Supported: Linux, OSX

Homepage

DOS
Dillo for DOS

Internet Explorer

Windows 8/2012
Internet Explorer 10

Windows Vista/2008
Internet Explorer 9

Windows XP/2003
Internet Explorer 8

Windows 98/ME/NT4/2000
Internet Explorer 6 SP1

For Java Update 29 on Windows 98/ME make sure you disable the "Next Generation Plugin" in the Java Control Panel.

Windows 95
Internet Explorer 5.5 SP2

Windows 3.1-3.11/NT 3.51
Internet Explorer 5.01

Tested with Windows 3.11 for Workgroups on 8-5-2011

Netscape Browser

Windows 3.x
Netscape Communicator v4.08

Tested with Windows 3.11 for Workgroups on 8-5-2011

Windows 95
Netscape 7.2

Windows 98+
Netscape Navigator 9.0.0.6

Windows NT 3.51
Netscape 4.8

Windows NT 4.0
Netscape 7.1

Notes
Netscape 9.0.0.6 crashes on 95C and NT4. Tested 9-20-2011
Based on Firefox 2.0.0.12 so no sense in using anyway.

Off by One v3.5.d
OS Supported: Windows 95+

Download

QtWeb 3.8.5
OS Supported: Windows 2000+, Linux, OSX

Download

Windows 98/ME
QtWeb 3.7.3
Works with KernelEx with QtWeb Portable v3.7.3

NT4
https://code.google.com/archive/p/qtweb/issues/182#c2

Qupzilla 2.2.6
OS Supported: Windows 7+, OS/2,Linux, OSX

Homepage

Windows Vista
?

Windows XP
?

Windows 2000
Use v1.1.5

Windows 98/ME
Untested

Safari v5.1.7
OS Supported: Windows XP+

Windows XP+
Use v5.1.7

Windows 2000
?

Vivaldi

Download

OFFICIAL
Windows XP/Vista
Use v1.0

------------------------------------------------------------------------------------------------------------------------------------------------
UPDATES

Windows 2000

POST INSTALL
1. SP4
2. SP4 Security Rollup
3. UURollup
4. Install Blackwingcat Extended Kernel and Extended Core

PRE INSTALL

1. Download HFSLIP Package http://windowsarchives.com/
2. Use HFSLIP to integrate package with ISO
3. Install Windows 2000
4. Install Blackwingcat Extended Kernel and Extended Core



-----------------------------------------------------------------------------------------------------------------------------------------------


PLUGINS

FLASH
Archive http://kb2.adobe.com/cps/142/tn_14266.html

Windows 95
Use Flash v7

NT 3.51\NT 4
Use Flash v7

Windows 2000
http://w2k.flxsrv.org/wlu/wlu.htm

Windows XP
Adobe Flash Player 31.0.0.101 SSE2
Adobe Flash Player 29.0.0.171 SSE1

JAVA

Windows XP
Java 8U152
Installer is broken on newer versions of Java, may be able to extract .gz of newer Java version, delete files in currently installed Java and move contents of gz to java folder (untested)

Windows Vista
Java 8U181


TOOLS

Proxy
https://mitmproxy.org/

Web Rendering Proxy - Allows to use legacy browsers on modern web
https://github.com/tenox7/wrp
Last edited by eL_PuSHeR on 2013-6-26 @ 07:40, edited 83 times in total.
User avatar
eL_PuSHeR
Moderator
 
Posts: 6494
Joined: 2003-6-20 @ 16:39

List of Web Browsers For All Operating Systems

Postby DosFreak » 2011-9-19 @ 18:25

TODO

CHROME

-Chrome 28 can be used on Windows 2000 if you obtain the chrome tool! According to sources Chrome 30 (Is or isn't?) the last version that supports pentium 3 processors and so on...the last version of Maxthon browser capable of running on Windows 2000 with Ullrollup updates is based off Chrome 30 as well. I'm not sure if Chrome 30 will work or not.
Note: The latest versions of Firefox will not properly work with Blackwingcat's kernel32! Version 26dg??? seems to be the last version that properly works with the last version of firefox!
Note: UllRollup updates seem to be only good with about Firefox 44 before giving the message requires Windows XP SP2 or later!

Last ver to support XP
Last ver to support Vista
Last ver to support OSX 10.6-10.8 (v50?)
Last ver to support 32bit Linux (v50?)


OPERA

Opera 12 Build 1372+
Plugins broken on Windows 2000?
http://www.msfn.org/board/topic/152471- ... e__st__120

Opera beyond v12 is not Presto based; the final Presto update was released a few months ago as 12.17: http://www.opera.com/download/guide/?ver=12.17

FireFox 10 on Windows 9x
http://www.msfn.org/board/topic/152471- ... _p__989096

SSE2 and FireFox
https://support.mozilla.org/en-US/questions/995280

Firefox Portable 28.0 and 24.8.1esr (Note: UNOFFICIAL VERSION OF FIREFOX) according to here https://support.mozilla.org/en-US/questions/1052888 (Probably the best version of Firefox without installing unofficial patches and updates!)

Mozilla Firefox 52 drops support for NPAPI plugins (dated back from 1995). No more silverlight, Java, but Flash is still allowed

64bit ver and XP
64bit ver and Vista
Firefox 48 and OSX 10.6-10.8
FireFox 52 XP and Vista

Firefox 13+ on Windows 2000
http://forums.mozillazine.org/viewtopic ... &t=2482475


SEAMONKEY

SeaMonkey on Windows 98
http://www.msfn.org/board/topic/130936- ... __st__1320

Possible issue with Seamonkey 2.0 and rendering in 9x.

QUPZILLA
-Versions of Qupzilla that use Qt4 web kit (Qupzilla 1.43, versions before 1.6.6 untested). It will require you to download Qupzilla 1.1.5 and copy its Qtwebkit4.dll, you also might need to copy Phonon4, Mscvr90, and Msvcp90 if the newer browser doesn't have them(Version 1.6.6 and later doesn't work not sure which is the last version to work on Windows 98/ME, thanks jumper from MSFN!!!)

JAVA
Java 6 Update 31 on Windows 9x
http://www.msfn.org/board/topic/152471- ... _p__990303

FLASH
Flash 7 for Windows 95/NT3.51/NT4
Flash 10.3 for IE in Windows 98/ME?
Flash 11 for Other Browsers in Windows 98/ME?
Flash 10 for IE in Windows 2000
Flash 11 for Other Browsers in Windows 2000
Flash 11 for IE and Other Browsers in XP+

SSE2 information for Flash and Windows 2000
http://oldcigaret.info/win2k/phpBB3/vie ... ?f=4&t=885

Flash 11 on Windows 2000
http://oldcigaret.info/win2k/phpBB3/vie ... ?f=4&t=885

http://oldcigaret.info/win2k/phpBB3/vie ... ?f=4&t=885
http://www.ortwinpinke.de/en/2012/03/13 ... dows-2000/

UNSORTED
http://toastytech.com/guis/miscb2.html
http://toastytech.com/files/95browsing.html
http://toastytech.com/guis/misc4.html
http://forums.mozillazine.org/viewtopic ... aa2b428b2b



Add release dates for older browsers?

Java for other browsers

NT 3.1\3.5\3.51 browser support
K-Meleon on 3.51?

NT 3.1 and Netscape 3.04, Netscape 4.08 and Opera 3.62?
http://www.betaarchive.com/forum/viewtopic.php?t=23034

I tested various Seamonkey versions:

2.1b2 - 2.7 - bookmarks doesn't work
2.1b1 - black window without text (in all compat modes)
2.1a1 - 2.1a3 - OK

I upgraed from 2.0.14 to 2.1 alpha 3


I'd tested SeaMonkey 2.4.1(Engine:Gecko/20110928 Firefox/7.0.1) in November (KernelEX Wiki). System: Win ME; KernelEX 4.5.2. It works, but not recently visited addresses, history and bookmarks. There's the same problem with Firefox 4 and higher. For Firefox it's possible to install an add-on like HyperBK. I believe there isn't such add-on for SeaMonkey.


I can't honestly remember the last time I even used a bookmark. heh

IIRC blackwingcat has the VC++ 2010 working in 2000 so this shouldn't be an issue


Rumored that FireFox 13 is not compatible with 2000:

Requires Kernelex for Windows 2000 by blackwingcat:
http://www.msfn.org/board/topic/149233- ... ge__st__40

or Wildbill http://bristols.zxq.net/windows2000/updates/#kb2393802


http://arstechnica.com/web/news/2011/10 ... -1990s.ars


According to this post http://www.msfn.org/board/topic/155384- ... ge__st__20
Firefox 13 requires the unofficial kernel update by WildBill

FireFox 13 in Windows 2000
http://forums.mozillazine.org/viewtopic ... 22fe0279bd

http://www.betaarchive.com/forum/viewtopic.php?t=30611

Firefox\Chrome
http://www.msfn.org/board/topic/172255-chrome-win2k/
http://www.msfn.org/board/topic/172089- ... dows-2000/

http://www.vogons.org/viewtopic.php?f=61&t=53420

QtWeb 3.4.8 for NT4/2000+
Requires SSE

https://code.google.com/p/qtweb/issues/detail?id=182#c2
http://www.betaarchive.com/forum/viewto ... =5&t=28587

TLS 1.2 on XP with IE8 using a proxy
http://www.msfn.org/board/topic/176344- ... ls/?page=3

NetSurf
http://www.netsurf-browser.org/

Tenfourfox
http://www.floodgap.com/software/tenfourfox/

http://www.grossgang.com/tts
PW Webspeak32

IBM Home Page Reader
https://web.archive.org/web/20030604122 ... prdoc.html

AirMosaic
Mosaic

TOOLS

Make apps compiled for VC++2005/2008/2010 work on Windows
http://blog.livedoor.jp/blackwingcat/ar ... 52362.html

KDW Wrapper for Windows 2000
https://msfn.org/board/topic/120936-kdw-fcwin2k/

https://www.howtogeek.com/335712/update ... -basilisk/



Firefox on XP
To support TLS 1.3 in Firefox go to about:config and change security.tls.version.max setting from "3" to "4" for Firefox ESR for XP

Basilisk
Windows 7+
https://forum.palemoon.org/viewtopic.ph ... ta+support

Basilisk 52/55
Windows X

Comodo Dragon Windows 7+
Comodo Dragon 46 Windows XP
Comodo IceDragon Windows XP+

From MSFN

Chrome 45+ PPAPI
https://fpdownload.macromedia.com/pub/l ... _ppapi.exe

Chrome < 44 and FireFox NPAPI
https://fpdownload.macromedia.com/pub/l ... player.exe

https://web.archive.org/web/20180413184 ... y&start=49

I have made some progress browsing HTTPS websites using Netscape Navigator 3.04. Can be useful for other old browsers too. I found out that by using a HTTP web-proxy browsing many HTTPS websites is possible, even with acces to their search-functions (of cause all javascript-functionality fails in NN3.04). Even visiting YouTube is possible, although Netscape didn't deliver a HTML5-plugin smiley. But pictures are shown (most of them).

Finding good web-proxies compatible with NN3.04 was a difficult task. I have tested more than hundred web-proxies I found on public lists. Many of them didn't like the browser signature, gave only a blank page, or didn't load other websites (well). With most of the EIGHT remaining web-proxies its possible to use HTTPS-only search-machines, visit reddit, wikipedia, microsoft, github, msdn and even msfn. The Wayback-machine is partly usable: searching for phrases is working, searching archived websites not (javascript!). Also websites crashing NN3.04 is less often.

I did some simple speedtests, loading by web-proxy a smaller website, a larger website and some http-downloading:

A. https://en.wikipedia.org/wiki/River
B. https://en.wikipedia.org/wiki/Talk:List ... idge_spans
C. http://speedstest.tele2.net/100MB.zip

Loadtime in seconds, downloadspeed in KB/sec."*" means "didn't finish loading".

My list of web-proxies in historical order (speed A./B./C.):
1) http://proxycrime.com 24/104/33
2) http://fastusaproxy.com 35/XX*/22
3) http://trubadix.myds.me/ppp/ 15/82/75
4) http://usafastproxy.info 42/223/25
5) http://prositeproxi.com 10/55/105
6) http://frenchproxy.info 4/21/300*
7) http://ghostme.tech 5/20/270*
8) http://freshwebproxy.tech 11/79/350


Firefox addons
https://github.com/JustOff/ca-archive/


Updated
https://github.com/roytam1


Browsers

Epic
Brave
Tor
Dragon
Ice Dragon
Freenet
Waterfox
Srware Iron


Browsh
https://www.hanselman.com/blog/LynxIsDe ... wsing.aspx

Browser upload to vogonsdrivers?

Need to organize by engine.

Please note that with the release of Adobe Flash Player 30, SSE1 only processors are no longer supported.

Adobe Flash Player 29 (29.0.0.171) is the final version for SSE1 processors. I have moved the final SSE installers here:

http://sdfox7.com/2000/Important_EOL_Up ... 9.0.0.171/

From MSFN

Beta channel for Adobe Flash Player was updated to 30.0.0.142 on July 19, and is confirmed working on Windows 2000.

https://labs.adobe.com/downloads/flashplayer.html

Mozilla Firefox (NPAPI):

https://fpdownload.macromedia.com/pub/l ... player.exe

Internet Explorer:

https://fpdownload.macromedia.com/pub/l ... yer_ax.exe

Uninstaller:

https://fpdownload.macromedia.com/pub/l ... player.exe

https://forums.adobe.com/thread/2500620

Check highest Netscape Communicator version on NT 3.1
http://www.win3x.org/win3board/viewtopi ... 79&t=15907

Chromium
https://chromium.woolyss.com/

7+
Chromium 50+

XP-Vista
Chromium 49
Chromium 34.0.1847 SSE1


FLASH

Internet Explorer
https://fpdownload.macromedia.com/pub/f ... yer_ax.exe

Other
https://fpdownload.macromedia.com/pub/f ... player.exe

WIndows 2000 (and mabye earlier) ws2_32 getaddrinfo

http://martin.brenner.de/files/?C=M;O=D



TOOLS
SSL Windows 2000
http://wp.xin.at/archives/4462
Last edited by DosFreak on 2012-4-04 @ 17:15, edited 55 times in total.
User avatar
DosFreak
l33t++
 
Posts: 9783
Joined: 2002-6-30 @ 16:35
Location: Your Head

Re: Web Browsers - Chrome/Firefox/Opera/SeaMonkey, etc

Postby DosFreak » 2011-11-16 @ 16:06

Qemu 14 - Windows 98-ME-NT4
(Requires modification of qemu .exe files to use Qemu v14 on the above listed operating systems)

Tested System Rescue CD v2.0.1 on 98-ME-NT4 using Firefox v3 on 11-16-2011

Also tested with Tiny Core Linux v4.0.2 using Chrome on 11-16-2011

Any Linux OS that works in Qemu should work but keep in mind memory limitations of the host and host processor speed.

http://en.wikipedia.org/wiki/Lightweigh ... stribution


Latest Qemu doesn't support KQemu. Check older versions of qemu and/or vmware and vpc.


Qemu Manager v7.0 works on 98-ME-NT4 (with KQEMU for hardware acceleration)
(Need to hexedit qemu.exe and replace "freeaddrinfo". "getaddrinfo", and "getnameinfo" with "gethostname". (May be able to use KernelEX for 98/ME instead of doing this)
Also may need to change in the VM options to change "Main Display" to "Qemu Window".

Tested with Tiny Core Linux v4.0.2 using Chrome on 11-16-2011.


Either Dual-boot with Linux, or use a LiveCD. Using Qemu on 9x\NT4 on older machines is not ideal due to older processors and memory.
Last edited by DosFreak on 2012-1-19 @ 20:46, edited 2 times in total.
User avatar
DosFreak
l33t++
 
Posts: 9783
Joined: 2002-6-30 @ 16:35
Location: Your Head


Re: List of Web Browsers For All Operating Systems

Postby JiaoTongNan » 2018-8-08 @ 00:33

A few quick comments aimed at first post:
An unofficial Firefox 2 port exists for Windows 95 http://toastytech.com/files/95browsing.html

Last version of Qupzilla to (unofficially) work on Windows XP is 2.0.1 or 2.0 (?) in my experience, 1.8.9 is the final one which works on Vista.
Firefox Portable 28.0 and 24.8.1esr don't appear to work on Windows 2000 SP4 oddly...I would recommend using the UllRollup or blackwingcat's kernel32 to use the latest 52 ESR version.
User avatar
JiaoTongNan
Newbie
 
Posts: 84
Joined: 2016-4-03 @ 21:06

Re: List of Web Browsers For All Operating Systems

Postby DosFreak » 2018-8-26 @ 13:42

Thanks feipoa!

Going to do some thread cleanup

Advanced Chrome 54 possible issue with disconnecting wireless when searching.

To mask SSE support in vmware:
Add this line to the .vmx file: cpuid.1.edx=----:-00-:----:----:----:----:----:----
https://communities.vmware.com/thread/488599?db=5
https://kb.vmware.com/s/article/1993

viewtopic.php?f=61&t=61823


XP POS security updates > August 2018 require a CPU with SSE2
https://msfn.org/board/topic/171814-pos ... p-sp3-enu/

Windows 7 with SSE processor latest update FEB 2018

http://matejhorvat.si/en/unfiled/nosse2.htm

ffmpeg
https://ffmpeg.zeranoe.com/forum/viewto ... =80#p14102

XP root cert
https://msfn.org/board/topic/175170-roo ... p/?page=16
User avatar
DosFreak
l33t++
 
Posts: 9783
Joined: 2002-6-30 @ 16:35
Location: Your Head


Re: List of Web Browsers For All Operating Systems

Postby jxalex » 2018-9-22 @ 13:50

the best way to keep the old browsers usable is to keep the website running which should be compatible with those browsers. At least to begin with this website.
THis way we can all have more enjoyment about the retro computing if all the information atleast in THIS site can be read and posted with retro computer too... :)

so, to read with any viewer. and the challenge questions should be made non-standard and all is good.

today atleast I was able to read with lynx the forum, also to have a good use with opera 9.61 and 10.62 versions for this, but should be compatible with even older versions.
Current project: DOS ISA soundcard with 24bit/96Khz digital I/O, SB16 compatible switchable.
viewtopic.php?f=62&t=62475
jxalex
Newbie
 
Posts: 31
Joined: 2017-8-27 @ 17:05
Location: Estonia / Sweden / Finland


Return to Release Announcements

Who is online

Users browsing this forum: No registered users and 3 guests