Common searches

DOSBox Game Launcher (DOSBox Frontend)

Topic actions

Reply 1564 of 1572, by rcblanke

User metadata
Rank Oldbie

Hi all,

Starting off with the 0.93 beta round:
* Fixed a problem opening links to files with spaces in its path;
* Fixed exporting mapper files
* Keep track of latest export type (profile or game) and auto-suggest export filename based on export title;
* Implemented a more accurate export progress indicator

All the latest files To upgrade, just fetch dbgl.jar as usual.


Reply 1565 of 1572, by rotaxt

User metadata
Rank Newbie

hi! i just want to ask everyone here which fork of dosbox you are using together with dbgl? any recommendations? for my personal taste pixelshader- & soundfont / mt32-functions are mandatory. the dosbox-daum fork still works but is pretty outdated meanwhile. as far as i am concerned there are two alternatives with similar options:


currently my job is quite stressful so i had no time to test and find out if / how the compability of both forks together with dbgl is. any experiences from your side? did you maybe test one these forks or are you using a different fork with dbgl?

i think there is no official compability list for dbgl & different dosbox-forks, it would be nice to have something like this in future to know what is compatible and what's not.

best regards

Last edited by rotaxt on 2020-08-06, 17:22. Edited 1 time in total.

Reply 1567 of 1572, by Green200

User metadata
Rank Newbie

So there is a Bug with DBGL? any Cure for a missing mouse and Possible Keyboard Issue. the mouse is there but you have to use your own mouse to grab and click things in DBGL. this New Reversion needs a massive fix. I even reverted to older version except .82 and beyond, those downloads are non existent atm. the last few no longer work for MAC.

The Older versions Need A JRE just like the new ver. but the Java Run time must be too new and thus DBGL is unable to recognize a JRE Package is installed. that is my best guess.

and DosBox seems to mount it self quite well - all the time. with no problems.

I so far have looked for help every where and It took like Three months to find this Fourm to post this issue. and yes I did send an Email to the Creator.

Reply 1568 of 1572, by billy043

User metadata
Rank Newbie

Hey there, I´m having a crash when trying to add a new Profile or Template. This is on a completely clean run of DBGL 0.92 on stock Ubuntu 20.04. Also tried 0.93 beta 1 with the same result.

Java version is openjdk 11.0.8 2020-07-14

Crash happens every time - so I cannot add a profile or a template.

Do you have any suggestions on what I could try to get this working? Let me know if you want me to provide any further details of the issue.

Full terminal output is as follows:

Launching DBGL using 64-Bit VM 11.0.8 on Linux v5.4.0-45-genericamd64, HSQL Database Engine 2.5.0, SWT v4934gtk
Sep 06, 2020 11:14:00 AM org.hsqldb.persist.Logger logInfoEvent
INFO: dataFileCache open start

(SWT:12568): Gtk-WARNING **: 11:14:00.632: Negative content width -9 (allocation 4, extents 6x7) while allocating gadget (node separator, owner GtkSeparatorToolItem)

(SWT:12568): Gtk-WARNING **: 11:14:00.635: Negative content width -9 (allocation 4, extents 6x7) while allocating gadget (node separator, owner GtkSeparatorToolItem)
Exception in thread "main" java.lang.RuntimeException: invalid DaControl definition
at org.dbgl.gui.controls.DaControl.setControlByConf(DaControl.java:87)
at org.dbgl.gui.abstractdialog.EditConfigurableDialog.lambda$updateControlsByConfigurable$1(EditConfigurableDialog.java:136)
at java.base/java.util.ArrayList.forEach(ArrayList.java:1541)
at org.dbgl.gui.abstractdialog.EditConfigurableDialog.updateControlsByConfigurable(EditConfigurableDialog.java:136)
at org.dbgl.gui.dialog.EditTemplateDialog.updateControlsByTemplate(EditTemplateDialog.java:86)
at org.dbgl.gui.dialog.EditTemplateDialog.onShellCreated(EditTemplateDialog.java:130)
at org.dbgl.gui.abstractdialog.BaseDialog.open(BaseDialog.java:103)
at org.dbgl.gui.dialog.MainWindow.doAddTemplate(MainWindow.java:1496)
at org.dbgl.gui.dialog.MainWindow.access$7500(MainWindow.java:133)
at org.dbgl.gui.dialog.MainWindow$58.widgetSelected(MainWindow.java:1182)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:252)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:5685)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1423)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4953)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4446)
at org.dbgl.gui.abstractdialog.BaseDialog.open(BaseDialog.java:111)
at org.dbgl.gui.Launcher.main(Launcher.java:52)

Reply 1570 of 1572, by billy043

User metadata
Rank Newbie
rcblanke wrote on 2020-09-07, 16:26:

Are you using a custom DOSBox build, billy043? Maybe DBGL is choking on the contents of your dosbox.conf, somehow.

Many thanks for the reply. Yes, I was using Dosbox ECE r4358. I have just installed standard dosbox and set that as default. That has resolved the issue.

I can still use Doosbox ECE with no issues if I switch the profile to use it.

Many thanks for your help.

Reply 1572 of 1572, by billy043

User metadata
Rank Newbie

Here is my dosbox-ECE.conf

Happy to provide any further information if it helps.

Sorry for the late reply - got lots going on at the moment.


  • Filename
    File size
    22.34 KiB
    File license
    Public domain