Sound Blaster 16 Clones

Discussion about old sound cards, MIDI devices and sound related accessories.

Re: Sound Blaster 16 Clones

Postby appiah4 » 2018-9-07 @ 07:35

The Serpent Rider wrote:Am i missing something or ALS100+ actually can't properly emulate SB16? 16-bit mixing has DMA range from 0 to 3, but Duke3D, ROTT and others allow only DMA 5 of higher.


I have in the past manually edited the config file for Duke3D to set high DMA as 3 and it just worked with cards that don't support high DMA.
1989:A500|1M|ACA500+|C1084S
1992:HIPPO-VL+|U5SX-33|8M|GD5428|CT2290|S2
1995:P5I430VX|P133|32M|Trio64|V1|CT3980/32M
1998:S1573S|K6-2/400|64M|RagePro|V2/SLI|CT4500/32M
2001:GA-6OXT|PIII-1200|512M|GF3Ti200|MX300
2004:K8V-D|3700+|2G|X1950P|SB0350
User avatar
appiah4
l33t
 
Posts: 2847
Joined: 2017-2-19 @ 07:36

Re: Sound Blaster 16 Clones

Postby oohms » 2018-9-10 @ 11:49

The Serpent Rider wrote:Am i missing something or ALS100+ actually can't properly emulate SB16? 16-bit mixing has DMA range from 0 to 3, but Duke3D, ROTT and others allow only DMA 5 of higher.


It seems that high DMA support vanished with the plus version
DOS/w3.11/w98 | K6-III+ 400ATZ @ 550 | FIC PA2013 | 128mb SDram | Voodoo 3 3000 | Avancelogic ALS100 | Roland SC-55ST
DOS/w98/XP | Core 2 Duo E4600 | Asus P5PE-VM | 512mb DDR400 | Ti4800SE | ForteMedia FM801
oohms
Newbie
 
Posts: 90
Joined: 2018-5-30 @ 08:27
Location: Australia

Re: Sound Blaster 16 Clones

Postby mjr4077au » 2018-10-03 @ 09:38

PARUS wrote:gerwin, I can't initialize AV310 in DOS on my motherboard. CMINIT.EXE doesn't see the card in pure DOS (but in Windows it works great). My motherboard is Itox G7S620-N-G, chipset i865G.
At the same time, for example, the card works perfectly on motherboards with chipsets i440ZX and i845E. It works excellent in Windows and in pure DOS with CMINIT.EXE on these motherboards.

Can you help, tell me about it? What can I do with this situation on motherboard i865?

Thank you. Sorry for my English.


PARUS, I hope you see this :). Just wondering if you ever got the AV310 to initalise in DOS? I have an IMB200 motherboard (i865, same chipset) but am facing the same initialisation issues. I do have i845 motherboards but would be reluctant to downgrade...

Cheers!
mjr4077au
Newbie
 
Posts: 3
Joined: 2018-10-03 @ 08:13

Re: Sound Blaster 16 Clones

Postby PARUS » 2018-10-09 @ 21:40

mjr4077au, I tried it on IMB200 with the same result :) AV310 won't work on Axiomtek IMB200 motherboard. But I'm sure it is possible to change ISA initialization procedure in BIOS and AV310 will work. I'm sure because it's done already on my Itox G7S620-N. I have asked about it my friend (he knows BIOSes architecture and assembler very well) and he made it for me. Now AV310 works in DOS on my i865 motherboard with Core 2 Duo CPU! (CPU mod also made by him.)
User avatar
PARUS
Member
 
Posts: 380
Joined: 2013-4-14 @ 04:03

Re: Sound Blaster 16 Clones

Postby mjr4077au » 2018-10-13 @ 02:32

PARUS wrote:mjr4077au, I tried it on IMB200 with the same result :) AV310 won't work on Axiomtek IMB200 motherboard. But I'm sure it is possible to change ISA initialization procedure in BIOS and AV310 will work. I'm sure because it's done already on my Itox G7S620-N. I have asked about it my friend (he knows BIOSes architecture and assembler very well) and he made it for me. Now AV310 works in DOS on my i865 motherboard with Core 2 Duo CPU! (CPU mod also made by him.)


Thank you so much for getting back to me! Do you think I could send you the latest BIOS I received from Axiomtek for the IMB200 and your friend could modify? Happy to send a little something both your way if you help me? :happy:
mjr4077au
Newbie
 
Posts: 3
Joined: 2018-10-03 @ 08:13

Re: Sound Blaster 16 Clones

Postby PARUS » 2018-10-14 @ 21:12

mjr4077au, his nickname is LLC. You can find him on overclockers.ru, modlabs.net, just register and pm him. He knows IMB200 board. Of course I don't know if he agrees or not to solve this problem again on another board.
User avatar
PARUS
Member
 
Posts: 380
Joined: 2013-4-14 @ 04:03

Re: Sound Blaster 16 Clones

Postby mjr4077au » 2018-10-14 @ 22:20

PARUS, thank you so much I'll mesage him now! :happy:
mjr4077au
Newbie
 
Posts: 3
Joined: 2018-10-03 @ 08:13

Re: Sound Blaster 16 Clones

Postby Thomas_GER » 2019-1-27 @ 20:27

Hi there.
I'm planning in purchasing another Avance Logic soundcard (my third) to use it as an "every day card" because my Aztech's are too valuable to me.
First two ALS's were just great in regards of audio quality. More important (to me) they played digitized sound in "Lost Files Of Sherlock Holmes" flawlessly. Only my ALS and my Aztech's do so. Opti931 and Vibra 16XV don't. CMI8330 Soundpro (on board) does neither. The prob is, first ALS got wrecked as part donator and second lost some resistors, caps and one opamp due to the lack of soldering skills. It's phone jack was damaged but I realised it too late. So, both cards were outstanding to me. Nice compatibility, good audio and genuine OPL3 Sound (Fake ls262 of course). So my question is now:
What are the Main differences between ALS007 and ALS100 chips? Note I mean the NON+ version at the latter. I can't find the datasheets anymore.
Please, facts if possible, no speculations.
Gtz,
Thomas.
User avatar
Thomas_GER
Newbie
 
Posts: 14
Joined: 2018-12-24 @ 12:33
Location: Near Limburg/Lahn, Hessen Germany

Re: Sound Blaster 16 Clones

Postby gerwin » 2019-1-27 @ 23:29

Thomas_GER wrote:What are the Main differences between ALS007 and ALS100 chips? Note I mean the NON+ version at the latter. I can't find the datasheets anymore.
Please, facts if possible, no speculations.

I hate it when that happens. What I had stored has just been uploaded to this place:
Avance Logic Sound IC - Datasheets + Manuals (v2)
But it is without a file for the ALS007...

Also I found this:
https://www.kernel.org/doc/Documentation/sound/oss/ALS
Note that the ALS-007 does not have a 16 bit DMA channel and that the MPU401 interface on this card uses a different interrupt to the audio section.
Last edited by gerwin on 2019-2-10 @ 19:42, edited 1 time in total.
User avatar
gerwin
l33t
 
Posts: 2628
Joined: 2004-5-07 @ 19:21
Location: NL

Re: Sound Blaster 16 Clones

Postby Thomas_GER » 2019-1-28 @ 00:27

Thanks alot, Gerwin. But ALS100s Datasheet is missing also. There is just a spec sheet. With the original datasheet with the pinout and pindescreption i probably could fix my damaged ALS100 card.
But thanks anyway.
User avatar
Thomas_GER
Newbie
 
Posts: 14
Joined: 2018-12-24 @ 12:33
Location: Near Limburg/Lahn, Hessen Germany

Re: Sound Blaster 16 Clones

Postby Stiletto » 2019-1-30 @ 18:38

Thomas_GER, I don't know what's in gerwin's collection because VOGONSDrivers is down, but look in s100dm2.zip for some pinouts and more info. We need to convert this to PDF (which I've done partially) but I haven't managed to insert the pages the way the README.TXT suggests yet.
Attachments
S100UG1.pdf
(424.97 KiB) Downloaded 8 times
S100DM2.pdf
(1.45 MiB) Downloaded 9 times
readme.txt
(5.71 KiB) Downloaded 7 times
s100ug1.zip
(469.21 KiB) Downloaded 5 times
s100dm2.zip
(1.71 MiB) Downloaded 5 times
"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen

Stiletto
User avatar
Stiletto
l33t
 
Posts: 4174
Joined: 2002-7-01 @ 21:57

Re: Sound Blaster 16 Clones

Postby Thomas_GER » 2019-1-31 @ 05:41

Thanks alot, Stiletto.
You just saved my day. I have been looking for those files all over the web without success. Maybe now I can repair my damaged ALS card.

Thomas.
User avatar
Thomas_GER
Newbie
 
Posts: 14
Joined: 2018-12-24 @ 12:33
Location: Near Limburg/Lahn, Hessen Germany

Re: Sound Blaster 16 Clones

Postby appiah4 » 2019-1-31 @ 06:41

Stiletto wrote:Thomas_GER, I don't know what's in gerwin's collection because VOGONSDrivers is down, but look in s100dm2.zip for some pinouts and more info. We need to convert this to PDF (which I've done partially) but I haven't managed to insert the pages the way the README.TXT suggests yet.


Awesome! Do you happen to have these for the ALS100+ as well by chance?
1989:A500|1M|ACA500+|C1084S
1992:HIPPO-VL+|U5SX-33|8M|GD5428|CT2290|S2
1995:P5I430VX|P133|32M|Trio64|V1|CT3980/32M
1998:S1573S|K6-2/400|64M|RagePro|V2/SLI|CT4500/32M
2001:GA-6OXT|PIII-1200|512M|GF3Ti200|MX300
2004:K8V-D|3700+|2G|X1950P|SB0350
User avatar
appiah4
l33t
 
Posts: 2847
Joined: 2017-2-19 @ 07:36

Re: Sound Blaster 16 Clones

Postby Thomas_GER » 2019-1-31 @ 08:06

Hi appiah4. I have a datasheet of the ALS100+ / 200 but it's not very detailed. Just three gif files but it contains the pinout of the chip and a reference design.
Attachments
as9706-3.gif
as9706-2.gif
as9706-1.gif
User avatar
Thomas_GER
Newbie
 
Posts: 14
Joined: 2018-12-24 @ 12:33
Location: Near Limburg/Lahn, Hessen Germany

Re: Sound Blaster 16 Clones

Postby Stiletto » 2019-1-31 @ 20:02

appiah4 wrote:
Stiletto wrote:Thomas_GER, I don't know what's in gerwin's collection because VOGONSDrivers is down, but look in s100dm2.zip for some pinouts and more info. We need to convert this to PDF (which I've done partially) but I haven't managed to insert the pages the way the README.TXT suggests yet.


Awesome! Do you happen to have these for the ALS100+ as well by chance?


Sorry buddy! That's all I have of Avance Logic chipset stuff. Once VOGONSDrivers came back up, I confirmed that gerwin had everything else I had and a few more besides.
"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen

Stiletto
User avatar
Stiletto
l33t
 
Posts: 4174
Joined: 2002-7-01 @ 21:57

Re: Sound Blaster 16 Clones

Postby gerwin » 2019-1-31 @ 21:00

Nice going. I will soon update the package on vogonsdrivers with the additions from Stiletto+Thomas_GER.
User avatar
gerwin
l33t
 
Posts: 2628
Joined: 2004-5-07 @ 19:21
Location: NL

Re: Sound Blaster 16 Clones

Postby Thomas_GER » 2019-1-31 @ 22:08

Yeah, awesome. By the way, you can just call me Thomas. The GER suffix is just because Thomas is allready in use.
User avatar
Thomas_GER
Newbie
 
Posts: 14
Joined: 2018-12-24 @ 12:33
Location: Near Limburg/Lahn, Hessen Germany

Re: Sound Blaster 16 Clones

Postby gerwin » 2019-2-10 @ 19:45

The Avance Logic package at VogonsDrivers was updated to include everything from Stiletto and Thomas.
Link in my post from 28-1-2019 is updated.

(There are three versions at VogonsDrivers now, two of which are flagged for deletion. v2 is the latest)
User avatar
gerwin
l33t
 
Posts: 2628
Joined: 2004-5-07 @ 19:21
Location: NL

Re: Sound Blaster 16 Clones

Postby dnewhous » 2019-2-14 @ 00:14

What's the difference between the Soundblaster 16 ASP and the Soundblaster 16? Note: I recall that a "vibra" version means available through Dell and not exactly like the retail version so that driver updates are through Dell.
Daniel L Newhouse
User avatar
dnewhous
Member
 
Posts: 258
Joined: 2002-7-22 @ 02:53
Location: Niceville, FL

Re: Sound Blaster 16 Clones

Postby gerwin » 2019-2-14 @ 01:46

Please start a new topic for that question. Leave this one for clones.
User avatar
gerwin
l33t
 
Posts: 2628
Joined: 2004-5-07 @ 19:21
Location: NL

Previous

Return to Sound

Who is online

Users browsing this forum: No registered users and 2 guests