VOGONS


DOSBox ECE (for Windows & Linux)

Topic actions

Reply 720 of 1005, by Ant_222

User metadata
Rank Oldbie
Rank
Oldbie

I think that a minimal English page with a list of features/patches and a download URL would be very good. If you have a constant link to the latest version of the patch, I can host such a page myself and also link to it from the title post of the Pixel-Perfect thread.

Reply 722 of 1005, by Yesterplay80

User metadata
Rank Member
Rank
Member

Alright, I created a single page in english, including the downloads, so please update your bookmarks:

https://dosboxece.yesterplay.net/en/

My full-featured DOSBox SVN builds (without debugger) for Windows: Vanilla DOSBox and DOSBox ECE (Enhanced Community Edition)

Reply 723 of 1005, by quartzdoll

User metadata
Rank Newbie
Rank
Newbie

DOSBox ECE r4254 playing dos games perfectly on my Ryzen pc with vega graphics. For a full screen stretch display on 24 inch monitor i had to change output to opengl in settings. All other outputs are unable to stretch full screen.

Reply 724 of 1005, by legluondunet

User metadata
Rank Newbie
Rank
Newbie

Hello, I'm on Linux, I bought Screamer 2 on Gog and I would like to play this game fullscreen with 3dfx quality. Is it possible with Dosbox-ECE?
The Screamer 2 Gog Edition install has a Windows Dosbox with Nglide and some dll like glide2x.ovl or glide2x.dll.
If I launch directly S2_3dfx.exe with Dosbox ECE Linux, I obtain this error message:

glidedll: cannot determine glide port, are you sure Glide is supported?
3dfx chips not found!

Please help!

Last edited by legluondunet on 2019-09-06, 10:40. Edited 2 times in total.

Config: Ubuntu 19.10 64 bits - NVIDIA GeForce GTX 770 - Nvidia drivers 435.21 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 16 Go RAM

Reply 726 of 1005, by legluondunet

User metadata
Rank Newbie
Rank
Newbie

I added this lines in my config file, but that changes nothing:

[pci]
# voodoo: Enable VOODOO support.
# Possible values: false, software, opengl, auto.
# voodoomem: Specify VOODOO card memory size.
# 'standard' 4MB card (2MB front buffer + 1x2MB texture unit)
# 'max' 12MB card (4MB front buffer + 2x4MB texture units)
# Possible values: standard, max.

voodoo=auto
voodoomem=standard

[glide]

glide=emu
grport=600
lfb=write
splash=false

Config: Ubuntu 19.10 64 bits - NVIDIA GeForce GTX 770 - Nvidia drivers 435.21 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 16 Go RAM

Reply 727 of 1005, by Yesterplay80

User metadata
Rank Member
Rank
Member

Those [glide] parameters serve no purpose in ECE. 😀

I attached the orginal glide2x.ovl file from my original Screamer 2 installation (from CD), give that one a try, maybe it fixes things for you. It's much bigger (341 KByte) than the one provided with the GOG install (31 Kbyte), so there must be a difference there. Just rename it back to GLIDE2X.OVL, the forum software doesn't allow the upload of ovl files.

Filename
GLIDE2X.OVL.txt
File size
340.62 KiB
Downloads
20 downloads
File license
Fair use/fair dealing exception

My full-featured DOSBox SVN builds (without debugger) for Windows: Vanilla DOSBox and DOSBox ECE (Enhanced Community Edition)

Reply 728 of 1005, by legluondunet

User metadata
Rank Newbie
Rank
Newbie

Hello YP, I replaced glide2x.ovl from Gog by yours and now the game launches, thank you.
But...
--> even if dosbox is in fullscreen, the game is 640x480 on the middle of the screen
--> I can not alt+enter to go windows mode/fullscreen
I joined you my config files, perhaps a bad option?

Attachments

  • Filename
    dosbox_screamer2.zip
    File size
    3.56 KiB
    Downloads
    11 downloads
    File license
    Fair use/fair dealing exception

Config: Ubuntu 19.10 64 bits - NVIDIA GeForce GTX 770 - Nvidia drivers 435.21 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 16 Go RAM

Reply 729 of 1005, by Yesterplay80

User metadata
Rank Member
Rank
Member

The emulated 3Dfx actually outputs 640x480 ONLY, regardless of the output resolution settings. If you look at the DOSBox status window you should find this line:

VOODOO: OpenGL: mode set, resolution 640:480 (fullscreen)

I presume you have deactivated any scaling in your video drivers, so the image is just that: An image in the original resolution of the 3Dfx chip, running in the center of your screen. And yes, you can't change display modes with 3Dfx emulation running, if you start the game in windowed mode (fullscreen=false) and try to switch to fullscreen, you should see the following message in the status window:

GFX LF: fullscreen switching not supported

My full-featured DOSBox SVN builds (without debugger) for Windows: Vanilla DOSBox and DOSBox ECE (Enhanced Community Edition)

Reply 730 of 1005, by legluondunet

User metadata
Rank Newbie
Rank
Newbie

"I presume you have deactivated any scaling in your video drivers, so the image is just that: An image in the original resolution of the 3Dfx chip, running in the center of your screen."
Please could you explain me how to enable scaling so I can play this game fullscreen.

Config: Ubuntu 19.10 64 bits - NVIDIA GeForce GTX 770 - Nvidia drivers 435.21 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 16 Go RAM

Reply 731 of 1005, by realnc

User metadata
Rank Member
Rank
Member
legluondunet wrote:

"I presume you have deactivated any scaling in your video drivers, so the image is just that: An image in the original resolution of the 3Dfx chip, running in the center of your screen."
Please could you explain me how to enable scaling so I can play this game fullscreen.

Open the nvidia control panel, go to the "adjust desktop size and position" section, choose "aspect ratio" as the scaling option, choose "GPU" in the "perform scaling on" list, and finally check the "override scaling mode" checkbox.

Reply 732 of 1005, by legluondunet

User metadata
Rank Newbie
Rank
Newbie

Thank you Realnc but I'm using Linux and I didn't find this option in Nvidia panel.

Config: Ubuntu 19.10 64 bits - NVIDIA GeForce GTX 770 - Nvidia drivers 435.21 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 16 Go RAM

Reply 733 of 1005, by realnc

User metadata
Rank Member
Rank
Member
legluondunet wrote:

Thank you Realnc but I'm using Linux and I didn't find this option in Nvidia panel.

I think it uses display scaling on Linux for resolutions that are not marked with "(scaled)". Try finding the scaling options in the OSD of your display.

Reply 734 of 1005, by legluondunet

User metadata
Rank Newbie
Rank
Newbie

I think scaling is already active on my computer, I already could play a lot of DOS games in fullscreen with Dosbox on Linux.

Config: Ubuntu 19.10 64 bits - NVIDIA GeForce GTX 770 - Nvidia drivers 435.21 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 16 Go RAM

Reply 735 of 1005, by Yesterplay80

User metadata
Rank Member
Rank
Member
legluondunet wrote:

I think scaling is already active on my computer, I already could play a lot of DOS games in fullscreen with Dosbox on Linux.

You probably could play them fullscreen because DOSBox did the scaling. But in case of 3Dfx emulation it doesn't do that, so you have to make sure the driver of your graphics card does the scaling instead.

My full-featured DOSBox SVN builds (without debugger) for Windows: Vanilla DOSBox and DOSBox ECE (Enhanced Community Edition)

Reply 736 of 1005, by legluondunet

User metadata
Rank Newbie
Rank
Newbie

Another question about Dosbox-CE:

when I launch a dos game with Dosbox-CE, after the Dosbox-CE splash, I have a black window that stay approximatively 8 seconds.
On the terminal I can see this lines:

Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
fluidsynth: error: Failed to connect to Jack server.

How can I ask Dosbox-CE to disable or bypass this steps and don't have to wait 8 seconds the game to launch?

Config: Ubuntu 19.10 64 bits - NVIDIA GeForce GTX 770 - Nvidia drivers 435.21 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 16 Go RAM

Reply 738 of 1005, by ReignerDeustcher

User metadata
Rank Newbie
Rank
Newbie

i'm just trying dosbox ece but this thing puts the conf file in appdata, how can i do to have it in the same folder than dosbox?

because i like to have all my games in different folders with different dosbox configurations

Reply 739 of 1005, by zirkoni

User metadata
Rank Member
Rank
Member
ReignerDeustcher wrote:

i'm just trying dosbox ece but this thing puts the conf file in appdata, how can i do to have it in the same folder than dosbox?

Rename the conf to dosbox.conf and dosbox will automatically use it when it's in the same folder with the exe.

ReignerDeustcher wrote:

because i like to have all my games in different folders with different dosbox configurations

You only need 1 dosbox.exe for that, just use the command line parameters to use different conf-files.
e.g. "C:\Program Files (x86)\DOSBox-0.74-3\DOSBox.exe" -userconf -conf "D:\DOS_C\QUAKE\dosbox-quake.conf"

https://www.youtube.com/user/zirkoni88