ATI Radeon 9250 256mb Has Bad Issues on MSI KM4M-L Mobo

Discussion about old graphics cards, monitors and video related things.

ATI Radeon 9250 256mb Has Bad Issues on MSI KM4M-L Mobo

Postby thepirategamerboy12 » 2018-5-16 @ 21:45

Hi, I got this AGP 8x card recently to upgrade my new Athlon XP 2400+ Win98 PC using an MSI KM4M-L mobo. Every time insert the card into my AGP slot, I get this really bad graphical corruption:
IMG_5770.JPG

IMG_5772.JPG

IMG_5774.JPG


In the bios, AGP is automatically set to 8x mode when the card is inserted (this option normally isn't visible with no card inserted), so it's not like the mobo doesn't support 8x or anything. Attempting to install the drivers didn't work, either. So, any ideas? I really want to get this working so I don't have to use the pretty bad S3 Unichrome integrated graphics anymore. Hope the card isn't simply dead. Thanks.
Last edited by thepirategamerboy12 on 2018-5-27 @ 04:59, edited 4 times in total.
User avatar
thepirategamerboy12
Member
 
Posts: 128
Joined: 2015-3-20 @ 14:53

Re: ATI Radeon 9250 256mb Has Bad Issues on MSI KM4M-L Mobo

Postby gdjacobs » 2018-5-18 @ 01:16

Disable 8x mode? Sometimes it's buggy.
User avatar
gdjacobs
l33t++
 
Posts: 5342
Joined: 2015-11-03 @ 05:51
Location: The Great White North

Re: ATI Radeon 9250 256mb Has Bad Issues on MSI KM4M-L Mobo

Postby thepirategamerboy12 » 2018-5-18 @ 03:20

gdjacobs wrote:Disable 8x mode? Sometimes it's buggy.

I tried that already and it sadly didn't work.
User avatar
thepirategamerboy12
Member
 
Posts: 128
Joined: 2015-3-20 @ 14:53

Re: ATI Radeon 9250 256mb Has Bad Issues on MSI KM4M-L Mobo

Postby F2bnp » 2018-5-18 @ 08:42

This is probably a bad card unfortunately. Are you sure the card is functioning properly on other systems?
User avatar
F2bnp
l33t
 
Posts: 3453
Joined: 2007-9-23 @ 10:19

Re: ATI Radeon 9250 256mb Has Bad Issues on MSI KM4M-L Mobo

Postby thepirategamerboy12 » 2018-5-18 @ 09:23

F2bnp wrote:This is probably a bad card unfortunately. Are you sure the card is functioning properly on other systems?

I don't have any other AGP systems to test it on at the moment, but at this point you may be right about it just being a bad card. I've tried everything I could think of and nothing's helped.
User avatar
thepirategamerboy12
Member
 
Posts: 128
Joined: 2015-3-20 @ 14:53


Return to Video

Who is online

Users browsing this forum: Jo22, RichB93, Thermalwrong and 3 guests