Win98SE Loading Unusually Slow

Getting old software/games running on older hardware.

Win98SE Loading Unusually Slow

Postby PKFreeZZy » 2018-8-09 @ 21:06

Just recently, my retro PC started loading really slowly. Normally it'd spend 10 seconds on the cloudy "Windows 98" loading screen then 3 seconds in the DOS prompt before the desktop appears. All of a sudden it's taking over 30 seconds after a fresh install and have no idea what's happening. I even fiddled with my BIOS to see if I could fix it, no luck. Any help?
My Windows 98 PC: Slot 1 Pentium III 600EB|384MB PC133 SDRAM|32MB Leadtek GeForce2 Pro 5.5ns|Creative SB16 CT2230|COMPAQ Intel PRO 10/100Mbps|20GB Seagate Barracuda ATA IV|Linkworld LPD6-350W|Tekram P6Bx-A(n) Rev. 1.06
PKFreeZZy
Newbie
 
Posts: 71
Joined: 2017-12-08 @ 20:45

Re: Win98SE Loading Unusually Slow

Postby oeuvre » 2018-8-10 @ 13:20

Could it be the hard drive failing or getting bad sectors?
Dell Optiplex 745 Q6600, 8GB, AMD FirePro V3900, SSD + HD, 2000/XP/7
i7 9700K, 32GB, MSI GTX1060, NVMe SSD + HD, Windows 10
Image
User avatar
oeuvre
Oldbie
 
Posts: 1985
Joined: 2015-3-31 @ 13:31
Location: USA

Re: Win98SE Loading Unusually Slow

Postby mrau » 2018-8-10 @ 18:21

check DMA and disk health?
mrau
Oldbie
 
Posts: 1027
Joined: 2015-11-28 @ 12:43

Re: Win98SE Loading Unusually Slow

Postby derSammler » 2018-8-10 @ 18:30

Do you have an Ethernet card installed and no cable connected? That's the most common reason for slow booting of Win95/98, as it waits quite a bit for a DHCP server to answer, not knowing that no cable is attached to the Ethernet card.
derSammler
Oldbie
 
Posts: 1779
Joined: 2017-4-14 @ 11:30
Location: Germany

Re: Win98SE Loading Unusually Slow

Postby PKFreeZZy » 2018-8-12 @ 05:36

derSammler wrote:Do you have an Ethernet card installed and no cable connected? That's the most common reason for slow booting of Win95/98, as it waits quite a bit for a DHCP server to answer, not knowing that no cable is attached to the Ethernet card.


Could've been that, as my ethernet cable is pretty loose, though even after properly connecting it, things didn't change. It seems it was a BIOS problem in the end as reverting to the defaults and then reconfiguring it made it go away.
My Windows 98 PC: Slot 1 Pentium III 600EB|384MB PC133 SDRAM|32MB Leadtek GeForce2 Pro 5.5ns|Creative SB16 CT2230|COMPAQ Intel PRO 10/100Mbps|20GB Seagate Barracuda ATA IV|Linkworld LPD6-350W|Tekram P6Bx-A(n) Rev. 1.06
PKFreeZZy
Newbie
 
Posts: 71
Joined: 2017-12-08 @ 20:45

Re: Win98SE Loading Unusually Slow

Postby Roman78 » 2018-8-16 @ 09:02

derSammler wrote:Do you have an Ethernet card installed and no cable connected? That's the most common reason for slow booting of Win95/98, as it waits quite a bit for a DHCP server to answer, not knowing that no cable is attached to the Ethernet card.


In this case W98 is querying the DHCP server and waiting. Could be speed up when set to Static IP instead of DHCP. In this case, even when the cable is lose, the PC boots fast.
Roman78
Member
 
Posts: 225
Joined: 2015-1-05 @ 08:58


Return to Software

Who is online

Users browsing this forum: No registered users and 0 guests