VOGONS


Fasttracker 2.10 & 2.11 for MS-DOS

Topic actions

Reply 41 of 73, by 8bitbubsy

User metadata
Rank Newbie
Rank
Newbie

It doesn't crash here during a quick test. I loaded an xm, turned the loop of the first sample into pingpong, marked some data around the first loop point and used xfade, works fine. Also works on 16-bit samples. How did you use it?

Reply 45 of 73, by 8bitbubsy

User metadata
Rank Newbie
Rank
Newbie

I still can't trigger any crash, not even on a Pentium 233 laptop using the latest version of FT2.11. I try to load a rather big 16-bit sample, I set a pingpong loop, I mark some data on the left loop pin and press xfade. Works every time. Do you use a GUS sound card, by any chance? Are you also using the latest version? When you quit the program, it should say "released 3rd of April 2020".

Reply 46 of 73, by traffkin

User metadata
Rank Newbie
Rank
Newbie

i'm using 2.11 with no midi prg change, you built it for me some weeks ago. sound blaster awe 64 inside p233 mmx with 128mb ram. another pc is ibm thinkpad 600e with on-board sound. i can film short video of the issue if that helps. not sure how to upload it though...

8bitbubsy wrote on 2020-05-17, 15:17:

I still can't trigger any crash, not even on a Pentium 233 laptop using the latest version of FT2.11. I try to load a rather big 16-bit sample, I set a pingpong loop, I mark some data on the left loop pin and press xfade. Works every time. Do you use a GUS sound card, by any chance? Are you also using the latest version? When you quit the program, it should say "released 3rd of April 2020".

Reply 54 of 73, by 8bitbubsy

User metadata
Rank Newbie
Rank
Newbie
traffkin wrote on 2020-05-21, 05:06:

here's the video of what happens
https://drive.google.com/open?id=1rNkMJTZU8iN … wziVMJdYmGbrYmn
hope this will help somehow

I tried loading a 16-bit stereo sample like you did, selecting the left part, making a similar pingpong loop, select about as much as you did and press xfade. No crash...

EDIT: Oh, the GUI actually locks up, so I guess I'm hitting the same bug as you, just without a crash to DOS. Will try to look into the pingpong 16-bit part of the xfade code today, but I can't promise that I figure it out.

Reply 57 of 73, by 8bitbubsy

User metadata
Rank Newbie
Rank
Newbie

Bug fixed.

Changes in v2.11:

  • ...
  • XFade didn't work correctly on 16-bit pingpong samples and could crash the program
  • ...

https://16-bits.org/etc/FT211.ZIP
"No MIDI-out program change" version for traffkin: https://www.dropbox.com/s/b624qekij49get9/FT2 … DI_PRG.ZIP?dl=1

Reply 59 of 73, by SaxxonPike

User metadata
Rank Member
Rank
Member

Thank you so much for updating FastTracker II! This was a very unexpected project. I recall learning how to use trackers in the late 90s with version 2.04. It was my introduction to music altogether. To see any updates since 2.09 is like a dream come true. I can't wait to return home and try this out.

Sound device guides:
Sound Blaster
Aztech
OPL3-SA