Creative Labs CR-563-B not ejecting with the button

Discussion about old PC hardware.

Creative Labs CR-563-B not ejecting with the button

Postby bjwil1991 » 2018-11-10 @ 05:56

I received a Sound Card & CD-ROM bundle from eBay and the CD-ROM gets detected in both MS-DOS and Windows 95C without issues. However, I hit a snag: the eject mechanism isn't working well. When I push the eject button, the laser head moves, but the tray won't get out unless I use a paperclip. It reads CDs without issues.
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 370, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2B-3B+, Custom FX-6300
User avatar
bjwil1991
Oldbie
 
Posts: 1868
Joined: 2013-8-14 @ 03:10
Location: SE, MI USA

Re: Creative Labs CR-563-B not ejecting with the button

Postby Shagittarius » 2018-11-10 @ 06:09

Sounds like you need a new drive belt.
User avatar
Shagittarius
Member
 
Posts: 464
Joined: 2007-12-20 @ 06:49
Location: California, USA

Re: Creative Labs CR-563-B not ejecting with the button

Postby bjwil1991 » 2018-11-10 @ 15:59

On another note, it does eject sometimes and the belt looks like it has a small spot that has bulged out a little. Fortunately, I have an old CD drive that has failed and I can take the belt out of that and see what happens.
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 370, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2B-3B+, Custom FX-6300
User avatar
bjwil1991
Oldbie
 
Posts: 1868
Joined: 2013-8-14 @ 03:10
Location: SE, MI USA

Re: Creative Labs CR-563-B not ejecting with the button

Postby 0kool » 2018-11-10 @ 17:03

It's quite possible that you just need to grease the mechanism a little (it might be ever so slightly deformed due to age - even new one, or the old grease dried out and became a problem). Theoretically could be done without disassembly, look at them teeth on the backside of the tray. Just move it some both ways after the procedure (without engaging the lock). I've successfully cured a few ODDs with similar symptoms this way.

mjfctower.jpg
0kool
Member
 
Posts: 104
Joined: 2018-5-13 @ 14:16

Re: Creative Labs CR-563-B not ejecting with the button

Postby jesolo » 2018-11-10 @ 18:00

What type of "grease" do you recommend?
User avatar
jesolo
Oldbie
 
Posts: 1482
Joined: 2014-6-24 @ 19:04
Location: South Africa

Re: Creative Labs CR-563-B not ejecting with the button

Postby 0kool » 2018-11-10 @ 18:20

I've found some plain looking lubricant in a syringe at the local hardware store. So far it's working miracles on the moving parts of floppies/optical drives. But make sure the substance is thick enough and not overdo it. If possible - stay away from oil.
0kool
Member
 
Posts: 104
Joined: 2018-5-13 @ 14:16

Re: Creative Labs CR-563-B not ejecting with the button

Postby bjwil1991 » 2018-11-10 @ 23:42

Did some diagnostics on the drive itself a while ago. The CD-ROM ejects with a CD in the drive, but, without a disk in the drive, it won't eject. Closer to getting the drive to function. Would it be a dying motor for the eject mechanism that's causing the drive to not open without the CD? The belt condition is still pretty good and not deteriorated. I also discovered that the CD-ROM tray takes a while for it to open, is that normal behavior?
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 370, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2B-3B+, Custom FX-6300
User avatar
bjwil1991
Oldbie
 
Posts: 1868
Joined: 2013-8-14 @ 03:10
Location: SE, MI USA

Re: Creative Labs CR-563-B not ejecting with the button

Postby Vaudane » 2018-11-10 @ 23:52

jesolo wrote:What type of "grease" do you recommend?


In all my old systems - I use Finish Line Ceramic Grease. Discovered the stuff when looking for the "best" grease for N64 thumbstucks - and it's pretty darn good. Not the cheapest but never fully dries out. from what I understand the teflon particles in it over time coat the gear and improve wear and tear rate.

https://www.performancebike.com/shop/fi ... se-40-4971
User avatar
Vaudane
Newbie
 
Posts: 49
Joined: 2018-7-30 @ 14:47
Location: UK

Re: Creative Labs CR-563-B not ejecting with the button

Postby bjwil1991 » 2018-11-11 @ 00:54

I noticed the belt is stretched and some of the broken CD drives I have don't have a belt in them (just gears), but, another drive I have does have the belt, yet, it's tight (that's normal, right?).

Edit: replaced the motor for the eject mechanism from a busted CD drive and it works. I'll test it again and report back. Thank you all for helping me out.
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 370, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2B-3B+, Custom FX-6300
User avatar
bjwil1991
Oldbie
 
Posts: 1868
Joined: 2013-8-14 @ 03:10
Location: SE, MI USA

Re: Creative Labs CR-563-B not ejecting with the button

Postby bjwil1991 » 2018-11-15 @ 20:20

Happy to report (few days later) the CD-ROM drive is 100% fully functional. I'm planning on taking pictures of the "new" motor and the old corroded motor, and do a short video about the drive over the weekend.
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 370, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2B-3B+, Custom FX-6300
User avatar
bjwil1991
Oldbie
 
Posts: 1868
Joined: 2013-8-14 @ 03:10
Location: SE, MI USA


Return to General Old Hardware

Who is online

Users browsing this forum: candle_86, Google [Bot], OldCat, root42, Vegge and 12 guests