VOGONS

Common searches


screen size

Topic actions

First post, by JessicaJones

User metadata
Rank Newbie
Rank
Newbie

Hi

I have a big 32" screen. Playing games using dosbox is a bit a problem because of the size of the screen:

- fullscreen: the game area is much too big and the pixels are enlarged to a big size. So this I don't like. I think it's better to use window mode

- window mode: the game area is too small compared to my desktop. So the game screen is very small.

I'm a beginner and don't know what to change in dosbox.conf to make either fullscreen or window mode better.

Please tell me what to try and what line to change to what value.

MS-DOS music addict - DOSBox/AdPlug enthusiast

Reply 1 of 7, by dreamer_

User metadata
Rank Member
Rank
Member

Hi, what solution would be ok for you? Having an option of fullscreen with black border around maybe? Have you tried using specific scalers, to make it more agreeable? Here's the documentation: https://www.dosbox.com/wiki/Scaler - using e.g. scaler tv2x might make the large pixels much less noticeable.

That page does not describe option "forced" for scaler (use it when your game uses resolution 640x400 or higher, otherwise scalers won't work).

| ← Ceci n'est pas une pipe
dosbox-staging

Reply 2 of 7, by God Of Gaming

User metadata
Rank Member
Rank
Member

Try to make a custom 4:3 resolution in your nvidia/amd control panel, if the monitor is 1920x1080, make 1440x1080, if its 2560x1440, make 1920x1440, or if its 3840x2160, make 2880x2160. And enable gpu scaling with preserve aspect ratio on.

Then set in the dosbox.conf:

fullscreen=true
fullresolution=1440x1080 (or 1920x1440 or 2880x2160)
output=openglnb

All 3 of these are near the top of the config file. Probably not the ideal solution, but its what I use, and is certainly better than default

1999 Dream PC project | 2001 Dream PC project | 2003 Dream PC project

Reply 3 of 7, by JessicaJones

User metadata
Rank Newbie
Rank
Newbie
dreamer_ wrote:

Having an option of fullscreen with black border around maybe?

I would like that! Because window mode is not so fun because the desktop distracts me from the game.

How can I get a fullscreen with black border?

MS-DOS music addict - DOSBox/AdPlug enthusiast

Reply 4 of 7, by dreamer_

User metadata
Rank Member
Rank
Member
JessicaJones wrote:
dreamer_ wrote:

Having an option of fullscreen with black border around maybe?

I would like that! Because window mode is not so fun because the desktop distracts me from the game.

How can I get a fullscreen with black border?

Here you go 😀

[sdl]
fullscreen=true
output=surface

[render]
scaler=normal2x

Tested on Linux using DOSBox 0.74-3 and latest dosbox-staging. If size of the game is too small, then use scaler normal3x.

However, your performance may suffer, as a result of using surface instead of opengl.

| ← Ceci n'est pas une pipe
dosbox-staging

Reply 6 of 7, by dreamer_

User metadata
Rank Member
Rank
Member
JessicaJones wrote:

You can only get full screen with black border by using surface? It doesn't work with any other one?

AFAIK, only surface 🙁 If you care about such usecase, you can make a feature request.

edit by Qbix:
This is something that is requested for dosbox. Please stay on the right project.

| ← Ceci n'est pas une pipe
dosbox-staging

Reply 7 of 7, by junglemontana

User metadata
Rank Newbie
Rank
Newbie
dreamer_ wrote:

Hi, what solution would be ok for you? Having an option of fullscreen with black border around maybe? Have you tried using specific scalers, to make it more agreeable? Here's the documentation: https://www.dosbox.com/wiki/Scaler - using e.g. scaler tv2x might make the large pixels much less noticeable.

That page does not describe option "forced" for scaler (use it when your game uses resolution 640x400 or higher, otherwise scalers won't work).

Note that there are also hard-coded limits for scalers - if the original resolution of the game is high enough, even the "forced" option doesn't activate the scaler. These limits can only be bypassed by patching Dosbox.