VOGONS


First post, by Leirele

User metadata

Poll: are you using a joystick in Mech2?

  • No votes No votes
  • 1 vote (100%) 1 vote (100%)

Hey again... still haven't recieved an activation email.. so using this name till I do. :\

... joysticks... in Mechwarrior 2... I'm beginning to get a bit desperate, so I'll ask this now, and possibly save me a TON of trouble later..

has ANYONE ever gotten a joystick to work in Mechwarrior 2 or Mercenaries... using VDMSound (and/or DOSBox).

and, if so.. what kind of setup are you using? (that is, if you wouldn't mind telling me)... and did you have any problems getting it to work?

I can at the most get 1 and a half of the axises to work with these games... whereas getting them to work in other games is a breeze.

thank you,

- Eleriel | Leirele.

Reply 1 of 6, by laxdragon

User metadata
Rank Member
Rank
Member

I don't know about the DOS version of Mech 2, but I have 3 versions of the Windows Mechwarrior 2. You don't need to use VDMsound any of these versions. The one bundled with my 3dfx VooDoo card is my personal favorite. Anyway, from what I remember I used to use my SideWinder 3D Pro, and my SideWinder Force Feedback (both use gameport) with no major issues.

Otherwise, if you are using the DOS version, it only supports gameport, so if you have a USB joystick you may be SOL. I don't think there is a util like VDMsound that puts a USB joystick out for gameport use for old DOS games. I could be wrong there.

Reply 2 of 6, by Leirele

User metadata

... I have the DOS version of the game.
and I'm using an USB Joystick (MS Siderwinder Forcefeedback 2, and don't tell me I can't use FFB in mech2, I'm aware)

the game recongizes the joystick half-by-half... for every movement of the joystick when calibrating it in-game, I get several responces by the program... all correct in their own right, but put them together and I think the game doesn't know WHERE to go.

see the picture I've attached... that's when calibrating the throttle. you're supposed to get only *one* line when doing that... but when I move the throttle, I get four lines. same thing when calibrating the X, Y and R axises. (except a small different, all the lines are on the same plane, not next to eachother, but IN eachother (so you wouldn't be able to tell from a screenshot).
also.. this pic was taken in dosbox, becuase VDMSound wont let me take screenshots... but, the effect is the same in there. exactly the same.
I've tried using all my joysticks (CH Flightstick PRO, CH Combatstick, Logitech Wingman Extreme, even plugged in the CH Throttle all on it's lonesome, no dice)... all with the exact same result.

other games let's the joysticks work just fine, regardless of which one I use... (well, aside from not using the POV, but I've got joy2key for that).

- Eleriel | Leirele.

Attachments

  • namnlös.JPG
    Filename
    namnlös.JPG
    File size
    14.81 KiB
    Views
    1359 views
    File comment
    nameless ... screenshot taken from DOSBox ... Mech2 In-game throttle calibration. same thing happens in VDMS.
    File license
    Fair use/fair dealing exception

Reply 3 of 6, by laxdragon

User metadata
Rank Member
Rank
Member

Seems odd the game can even see the USB joystick at all. Since the game is looking for the gameport which does not exist when using a USB device. So something is putting the USB joystick on the gameport address. Sorry, I'm not the VDMsound expert here, so it could be doing that.

I did a quick google, and found there is a Mech2 patch out there. You may try that as well. The info says it fixes some input devices. So maybe that will help you out.
http://www.fileshack.com/file.x?fid=425

Reply 5 of 6, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Don't have my computer in front of me so cannot test Mech 2 but have you gone through all of VDMSounds joystick options? Even VDMsounds joystick mapping capability?

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 6 of 6, by Guest

User metadata

yeah... I thouroughly investigated VDMSounds Joystick options... no dice there either...

I've put it away and am now playing with mouse & Keyboard... funnily enough, I was FINALLY able to complete all of the training missions now, something I've never been able to do with a joystick... (yeah, the gauntlet... eight targets to the right, eight to the left.. timed. using a mouse to take out the targets was EASY... )

now if only I could increase the in-game DMA Buffer... I'd be in heaven. (sparkling sound issue.. lower CPU Usage helped ... but didn't eliminate it).