VOGONS


My first retro project

Topic actions

Reply 20 of 22, by bZbZbZ

User metadata
Rank Newbie
Rank
Newbie

1) Is there a setting in your BIOS to set your SATA ports to compatibility mode (disable AHCI)? I've had success using SATA hard drives straight up connected to the motherboard's SATA ports in Windows 98. You might not need to use the adapter at all.
sata-mode3.jpg

2) If your peripherals work fine in the BIOS but not in Windows 98, then the driver you're using within W98 is the problem. IMO you're better off with a slow connection than no connection...

Reply 21 of 22, by DeadnightWarrior

User metadata
Rank Newbie
Rank
Newbie
bZbZbZ wrote on 2021-05-02, 17:00:
1) Is there a setting in your BIOS to set your SATA ports to compatibility mode (disable AHCI)? I've had success using SATA ha […]
Show full quote

1) Is there a setting in your BIOS to set your SATA ports to compatibility mode (disable AHCI)? I've had success using SATA hard drives straight up connected to the motherboard's SATA ports in Windows 98. You might not need to use the adapter at all.
sata-mode3.jpg

2) If your peripherals work fine in the BIOS but not in Windows 98, then the driver you're using within W98 is the problem. IMO you're better off with a slow connection than no connection...

1) I did try to use a direct SATA connection: there are two separate settings ("compatible" and "legacy") and the ability to keep one of the IDE channels and the SATA ports active. But no matter what combination I chose, I could never have both the SSD and the optical drive detected. Most of the time the SSD would never show up. That's why I chose to use the adapter but it was too unstable to bear.
I am now trying a real 80Gb IDE hard drive, let's hope it works.

2) Yeah I guess I'll have to keep all USB ports to 1.1 speed. What puzzles me is that the driver is the only one available for this particular motherboard and it's specifically for Windows 9x...