VOGONS


New 486 EISA + VLB build.

Topic actions

Reply 20 of 23, by simon_e_hall

User metadata
Rank Newbie
Rank
Newbie

Build is all in its new case, rather cramped in there, thinking I will need an additional fan, will get photographs soon.

But what I was expecting to be a pain in the arse was the EISA setup, which worked fairly easy. The DPT PM2022 worked almost straight away for basic functions like floppy drive. However, once the EISA config had it install as expected failed to boot properly due to using a Level IRQ (as expected), but in it's EISA config is an option to use Edge IRQ, and sure enough once Edge IRQ was selected it booted correctly, so no changing the file.

The 3C597-TX 3Com 10/100 Fast Ethernet on the other hand is causing a few issues, so straight away changed the config file IRQ from Level to Edge, system boots, lights activate on the card, set up MS network client in DOS to start getting my files from the NAS to the system. MS network client sees the card and starts, but refuses to get an IP address from the DHCP server or if I set it manually still cannot seem to get on the network, lights all normal on the back of the network card, so not sure what is going on there. So have a bit of trouble shooting to do there.

What I feared the most was the GD5429 card dying as the graphic glitches got worse, which it did. So in my collection is a Diamond Viper SE (with the IBM 525 RAMDAC), didn't want to use this card, but willing to give it a go already got 4mb of RAM on it though.

One cool thing, despite checking the RAM on the motherboard being seated correctly before starting it the first time (see previous pictures showing 64MB), during a clean of the modules contacts discovered they are 16mb modules that came with the board, and after putting them back in, I had a full 128mb or RAM, nice!

Oh, another issue is MS Network Client and/ or DOS is not a fan of using the upper memory on this system, so might have to do some trouble shooting there, maybe that could be causing my network connection issues.

Things still to do, install a CD Drive, trouble shooting a few things, photographs and of course benchmarks!

Reply 21 of 23, by simon_e_hall

User metadata
Rank Newbie
Rank
Newbie

Well, after a night of testing I found the initial network card issue, was being caused by a dry joint of the SB16 card, which even though the jumper was in place, electronically was open so was configured as IRQ 10 (not 5) and obviously 10 is what I use for networking.

The next issue highlights the issue with the chipset, it hates any 3Com EISA Network card I put in, even if I tweak the CFG file, so currently have a 3Com ISA card installed, with exactly the same setting as I have for the EISA, but that works!

Every SCSI adapter I try has to be on IRQ Edge mode, and none want to use the full capacity of the drive, the most I can get is an 8gb partition for an entire disk, on an Adaptec EISA card and the DPT will not go above 2gb, but will allow me to create multiple 2gb partitions, so is stuck in a DOS compatible mode, regardless of what Operating System I use.

So at the moment I have set it up for Windows 95, Adaptec SCSI and ISA Networking, to try and play C&C over the LAN with the children! More testing to follow, I must admit though Windows 95 works like a charm on this.

Attachments

  • 20211105_221748.jpg
    Filename
    20211105_221748.jpg
    File size
    1.07 MiB
    Views
    76 views
    File license
    Fair use/fair dealing exception

Reply 22 of 23, by simon_e_hall

User metadata
Rank Newbie
Rank
Newbie

Not been working on this as much as I would like, been busy on other tasks. So a quick update, another little quirk I have noticed is, despite the BIOS reporting 128MB or RAM, Windows 95 only sees 64MB. From previous experiments a typical ISA board maxed out at 32MB (EISA board with standard ISA BIOS in), which led me to the EISA .CFG file, it only has the option to go up to 64MB, so I had a tweak of that file and made my own, including an option for 128MB. Long and short, it sort of works, the Operating System sees 128MB, but it fails on the memory test, so I have to tweak the settings I have made in the .CFG file a little more to make it compatible with the start and end of the memory range.

This got me thinking, as this .CFG file can tweak BIOS settings seperate to the on board BIOS maybe I make a .CFG file to tweak other settings? i.e. timings etc, a sort of poor mans MR-BIOS.

Reply 23 of 23, by NJRoadfan

User metadata
Rank Oldbie
Rank
Oldbie

Sounds like some weird chipset limitation or the BIOS isn't properly updating the e820 memory tables. I know the SiS EISA chipset and AMIBIOS has no problems with RAM above 64MB.