VOGONS


First post, by Nathonion

User metadata
Rank Newbie
Rank
Newbie

When I run the installer for munt, at the end I get this popup:

Capture.PNG
Filename
Capture.PNG
File size
4.37 KiB
Views
453 views
File license
Public domain

But I'm still able to get it up and running. I start the mt32emu-qt application, and attach the necessary roms. According to this tutorial: https://www.youtube.com/watch?v=j_5RWxHHVvE&a … hilsComputerLab, that's all I need to get the emulator working. But when I try to run the "mixer /listmidi" command in dosbox, it doesn't show up as an option. I suspect it has something to do with the error I was getting, possibly missing drivers. But then when I look at the device manager, it is shown as an option.

tldr; I have no idea what the problem is, and I need professional guidance. I appreciate any support!

Reply 1 of 7, by sergm

User metadata
Rank Oldbie
Rank
Oldbie

That's a rare problem, I'd say. This error message is shown when the 64-bit MIDI driver DLL (mt32emu.dll) cannot be copied to the Windows System32 directory for any reason. See if your user has permissions to write there (perhaps, some AV stuff blocking access?), or maybe an older version of the driver already exists in Windows/System32 and the update function fails to register a pending deletion on reboot.

Reply 2 of 7, by Nathonion

User metadata
Rank Newbie
Rank
Newbie

If it's supposed to be at the top of the system32 folder, and not deeper in, then it doesn't look like I have it there. Is there a way to download that file individually and manually copy it there? I don't think I have any issues with permissions, although I'm not quite sure what you mean by AV stuff. Thanks for the reply!

Reply 3 of 7, by sergm

User metadata
Rank Oldbie
Rank
Oldbie

Is there a way to download that file individually and manually copy it there?

Sure, you can download a dedicated package with the driver only from here. Moreover, the driver DLLs must be installed with the package into Program Files/munt//mt32emu_win32drv where you should be able to copy it from. Note, the 64-bit DLL is to be renamed mt32emu_x64.dll -> mt32emu.dll

Hope this helps.

Reply 4 of 7, by Nathonion

User metadata
Rank Newbie
Rank
Newbie

I copied the mt32emu.dll to the system32 folder, and the mt32emu_x64.dll to the syswow64 folder, renaming it to mt32emu.dll like you said, and then restarted my computer for good measure. But dosbox still doesn't find it with mixer /listmidi. Did I do this right? If so, any other ideas?

Reply 5 of 7, by sergm

User metadata
Rank Oldbie
Rank
Oldbie

I copied the mt32emu.dll to the system32 folder, and the mt32emu_x64.dll to the syswow64 folder, renaming it to mt32emu.dll like you said, and then restarted my computer for good measure.

Sadly, this is not what I said. Thanks to Microsoft, System32 contains 64-bit files and syswow64 in contrast - 32-bit files. So you've copied driver to wrong place 😀

Still, the setup tool is intended to do that for you automatically, no idea what's wrong. You can also try running "infinstall_x64.exe install" from the driver directory. As this alternative tool uses a different installer technology, it might do a better job, who knows.

Reply 6 of 7, by Nathonion

User metadata
Rank Newbie
Rank
Newbie

Infinstall_x64.exe install didn't work, it gave me this error: Cannot install MT32Emu MIDI Driver; Error: e0000247. Luckily, I tried switching the .dll files around to their correct (yet agreeably aggravating) folders, and that actually worked! Dosbox shows "MT-32 Synth Emulator" as an option when using mixer /listmidi. Problem solved! Although, I wish I knew why my computer just refused to install those files correctly. Oh well 😜 Thanks for all your help, you've been wonderful!

Reply 7 of 7, by sergm

User metadata
Rank Oldbie
Rank
Oldbie

Infinstall_x64.exe install didn't work, it gave me this error: Cannot install MT32Emu MIDI Driver; Error: e0000247.

Argh, right... It needs a signed driver first time you install it, so the correct spell was "infinstall_x64.exe install -sign" actually. Sorry about that (although that's all written down in the readme 😉 ).