Mount CD in Linux

General information and assistance with DOSBox.

Mount CD in Linux

Postby caltrop » 2018-7-11 @ 22:02

The example in the documentation does NOT work!

Code: Select all
Linux Mint - Ubuntu based
/media/cdrom
   does not exist
/dev/cdrom
   does not work
/media/user
   accesses the mount point, then 'cd <cd name>'
   but this confuses programs expecting stuff in the root directory of the CD
/media/user/<cd-name>
   CD's are mounted in Ubuntu/Mint by CD name, not device
   so everytime a CD is used it has to be mounted by name, NOT device
   if CD name has spaces it has to be quoted

Because each CD has to be mounted individually by name this makes DOSBox a bit cumbersome.
Some of those CD names can be quite long: 1998-06-27-GamesRUs-whatever
requiring: mount d /media/user/1998-06-27-GamesRUs-whatever -t cdrom
then restart DOSBox or mount -u d
caltrop
Newbie
 
Posts: 15
Joined: 2017-8-16 @ 16:50

Re: Mount CD in Linux

Postby DosFreak » 2018-7-11 @ 22:19

1. We don't care about "abandonware"
2. Real DOS CD labels didn't have long names
3. Use bin/cue images.
User avatar
DosFreak
l33t++
 
Posts: 9783
Joined: 2002-6-30 @ 16:35
Location: Your Head

Re: Mount CD in Linux

Postby catchaserguns » 2018-7-12 @ 00:42

Go find the game on Amazon and buy it then come back to the forum.
User avatar
catchaserguns
Member
 
Posts: 216
Joined: 2006-8-19 @ 12:06

Re: Mount CD in Linux

Postby gdjacobs » 2018-7-12 @ 17:07

Why mount the drive first first? Dosbox handles the raw images just fine be they iso files or bin/cue images. Image the disk and load it using IMGMOUNT.

Of course, if you're getting dodgy game images from sketchy websites, all bets are off.
User avatar
gdjacobs
l33t++
 
Posts: 5487
Joined: 2015-11-03 @ 05:51
Location: The Great White North

Mount CD in Linux - FIXED!

Postby caltrop » 2018-8-07 @ 15:19

FIXED CD MOUNT ISSUE!

use gnome-disks or whatever you use
turn OFF disk auto-mount
you select the disk label here as well

now the CD is fixed & not variable
the DOSBox configuration command in [autoexec] now works for ALL CD's
mount d /mnt/[disk label] -t cdrom

instead of a CD showing as /media/[user]/[disk name] for every CD inerted
now it is /mnt/[disk label] for every CD

I also did this for Win10 directory since it was not mounting at startup
only mounted when first accessed
not that I use Win10 much :lol:

Hope this helps.

As usual forums are little help, you end up figuring it out yourself.
And people need to be a bit nicer & not so condescending.
Newbies are TERRIFIED of Linux and being mean doesn't help.
We're fighting for a Free Operating System.

I'll be a Linux Expert soon... :blush:
caltrop
Newbie
 
Posts: 15
Joined: 2017-8-16 @ 16:50


Return to DOSBox General

Who is online

Users browsing this forum: No registered users and 1 guest