VOGONS


DOSBox ECE (for Windows & Linux)

Topic actions

Reply 1400 of 1446, by villeneuve

User metadata
Rank Newbie
Rank
Newbie
Yesterplay80 wrote on 2021-11-02, 10:12:
Yesterplay80 wrote on 2021-09-24, 09:50:

I'm hosting my website on my NAS at home and since the latest update, it became basically unusable. 🙁 So, until I or Synology doesn't resolve this problem, please get the latest version of ECE from my Google Drive here:

https://drive.google.com/drive/folders/0BxEUS … 7mweueRbc7T4M8g

Sorry about the inconvenience!

I finally replaced my NAS with a new one and the ECE homepage should be reachable much better again!

There seems to be an issue though currently.

Reply 1401 of 1446, by Yesterplay80

User metadata
Rank Oldbie
Rank
Oldbie
villeneuve wrote on 2021-11-05, 16:10:
Yesterplay80 wrote on 2021-11-02, 10:12:

I finally replaced my NAS with a new one and the ECE homepage should be reachable much better again!

There seems to be an issue though currently.

What kind of issue? Here everything looks normal currently.

My full-featured DOSBox SVN builds for Windows & Linux: Vanilla DOSBox and DOSBox ECE (Google Drive Mirror)

Reply 1402 of 1446, by villeneuve

User metadata
Rank Newbie
Rank
Newbie

Hm, I've now actually read the error message instead of just suspecting a 404 error. The issue is with the SSL connection which as I've now found out only happens when using my old Firefox (56.0.2). The exact error message is:

SSL_ERROR_PROTOCOL_VERSION_ALERT

Accessing the ECE homepage in a current Waterfox works though. So unless you're also targeting outdated browsers it's not an issue on your side.

Reply 1404 of 1446, by Yesterplay80

User metadata
Rank Oldbie
Rank
Oldbie

Should be working again. Note to self: Always update your DDNS settings after changing your DDNS password. 😉

However, there's nothing new on my site.

My full-featured DOSBox SVN builds for Windows & Linux: Vanilla DOSBox and DOSBox ECE (Google Drive Mirror)

Reply 1406 of 1446, by morphinejh

User metadata
Rank Newbie
Rank
Newbie

Yesterplay, I use your source regularly to keep a hardware OPL modified version of DosboxECE running on Linux. Long story short I'm innately familiar with a lot of it at this point.

I noticed what I think is a copy/paste error around line 673 in (r4469):
/src/hadware/adlib.cpp

...
case MODE_DUALOPL2:
//Not a 0x??8 port, then write to a specific port
if ( !(port & 0x8) ) {
Bit8u index = ( port & 2 ) >> 1;
DualWrite( index, reg.dual[index], val );
} else {
//Write to both ports
DualWrite( 0, reg.dual[0], val );
DualWrite( 1, reg.dual[1], val );
}
break;
}
}
else if (oplemu == "nuked") {
handler = new NukedOPL::Handler();
}

Seems the NukedOPL handler is being initialized in a PortWrite() function.

Reply 1407 of 1446, by Yesterplay80

User metadata
Rank Oldbie
Rank
Oldbie

I'm currently compiling r4470 because the diff for the NukedOPL patch didn't apply correctly after the changes introduced in r4468 and I had to update my patch first. Download the new source in a few minutes and try again, please!

UPDATE: All versions of r4470 are online!

My full-featured DOSBox SVN builds for Windows & Linux: Vanilla DOSBox and DOSBox ECE (Google Drive Mirror)

Reply 1408 of 1446, by morphinejh

User metadata
Rank Newbie
Rank
Newbie
Yesterplay80 wrote on 2021-11-17, 20:14:

I'm currently compiling r4470 because the diff for the NukedOPL patch didn't apply correctly after the changes introduced in r4468 and I had to update my patch first. Download the new source in a few minutes and try again, please!

UPDATE: All versions of r4470 are online!

Works great!

Reply 1409 of 1446, by zirkoni

User metadata
Rank Member
Rank
Member

FYI, DOSBox ECE is available from AUR: https://aur.archlinux.org/packages/dosbox-ece/

There were some annoyances in installing the package:
- The package version is old (r4465 vs 4470)
- The source download link is wrong (partially because of the old version but looks like the URL doesn't work even if you edit the pkgVersion)
- The installed binary is named "dosbox" which conflicts with other DOSBox installations (like SVN). I renamed the binary to dosbox_ece
- There was a spelling error in the created desktop-file (dosbox-eve)

https://www.youtube.com/user/zirkoni88

Reply 1410 of 1446, by Yesterplay80

User metadata
Rank Oldbie
Rank
Oldbie
zirkoni wrote on 2021-11-25, 13:52:

FYI, DOSBox ECE is available from AUR: https://aur.archlinux.org/packages/dosbox-ece/

Pardon my ignorance, but is there anything I could/shoud do there? I never heard from AUR before, the only Linux experience I have is from the VM I use to compile ECE.

A quick update on the latest builds of ECE (r447o and onward): I updated mt32emu to version 2.5.3 but scrapped the support for external Glide wrappers again, I personally prefer the internal one, because it doesn't have external depencies. And I couldn't notice any difference between both, so I decided to keep it as simple as possible and ditched the external one. So it's just kekkos patch again.

My full-featured DOSBox SVN builds for Windows & Linux: Vanilla DOSBox and DOSBox ECE (Google Drive Mirror)

Reply 1411 of 1446, by xcomcmdr

User metadata
Rank Oldbie
Rank
Oldbie

AUR is a 3rd party "repository" of sorts for Archlinux users, by Archlinux users.

In other words, someone made DOSBox ECE available from the Arch User Repo by contributing a PKGBUILD file for it.

Reply 1412 of 1446, by zirkoni

User metadata
Rank Member
Rank
Member

AUR is explained in the Arch Wiki: https://wiki.archlinux.org/title/Arch_User_Repository

For example, to install DOSBox ECE on some Arch based distro with yay (yay is an AUR helper):
yay -S dosbox-ece

It's really nice to be able to install software from source code with a single command. And yay can check and do updates as well.

Yesterplay80 wrote on 2021-12-11, 19:47:

is there anything I could/shoud do there?

Not really unless you want to. I think the number of users who install DOSBox ECE from the AUR is quite low.

The biggest problem with DOSBox ECE is that it does not use any proper version control system. And every time DOSBox ECE is updated the download link for the newest source code archive changes. And this breaks the AUR PKGBUILD script.

https://www.youtube.com/user/zirkoni88

Reply 1413 of 1446, by morphinejh

User metadata
Rank Newbie
Rank
Newbie

A quick update on the latest builds of ECE (r447o and onward): I updated mt32emu to version 2.5.3 but scrapped the support for external Glide wrappers again, I personally prefer the internal one, because it doesn't have external depencies. And I couldn't notice any difference between both, so I decided to keep it as simple as possible and ditched the external one. So it's just kekkos patch again.

Compiling on Ubuntu 20.04 using the Glide changes in r4471 a few errors have popped up on my end. I'm still sorting through it all. There seems to be a conflict between declarations of OpenGL versions and functions. It's going to take some time to sort through it.

In file included from /usr/include/GL/gl.h:2050,
from /usr/include/SDL/SDL_opengl.h:46,
from voodoo_vogl.h:28,
from voodoo_vogl.cpp:28:
/usr/include/GL/glext.h:54: note: this is the location of the previous definition
54 | #define GL_GLEXT_VERSION 20190805
|
In file included from voodoo_vogl.h:28,
from voodoo_opengl.h:33,
from voodoo_emu.cpp:81:
/usr/include/SDL/SDL_opengl.h:116: warning: "GL_GLEXT_VERSION" redefined
116 | #define GL_GLEXT_VERSION 29
|
In file included from voodoo_vogl.h:28,
from voodoo_opengl.h:33,
from voodoo_opengl.cpp:28:
/usr/include/SDL/SDL_opengl.h:116: warning: "GL_GLEXT_VERSION" redefined

Yesterplay, for reference what Linux build environment are you using?

Reply 1414 of 1446, by morphinejh

User metadata
Rank Newbie
Rank
Newbie

I was able to track down the source of the conflict.

Previous version snippet of voodoo_vogl.h around line 27:

#include "SDL.h"
#ifndef _WIN32
#define GL_ARB_multitexture
#include <GL/gl.h>
#undef GL_ARB_multitexture
#include "config.h"
typedef Bit32s INT32;
#endif
#include "SDL_opengl.h"

The r4471 version looks like this around the same line:

#include "SDL.h"
#include "SDL_opengl.h"

My guess is on Windows this isn't a problem, but for Linux it causes some redefinition of datatypes and functions. On Ubuntu 20.04 it is required to install OpenGL dev(libglu1-mesa-dev) libraries with SDL1.2 dev librarires (libsdl1.2-dev). I couldn't see away to fix the conflict without the modified header file for voodoo_vogl.h

Reply 1415 of 1446, by willow

User metadata
Rank Member
Rank
Member
Yesterplay80 wrote on 2021-12-11, 19:47:
zirkoni wrote on 2021-11-25, 13:52:

FYI, DOSBox ECE is available from AUR: https://aur.archlinux.org/packages/dosbox-ece/

Pardon my ignorance, but is there anything I could/shoud do there? I never heard from AUR before, the only Linux experience I have is from the VM I use to compile ECE.

A quick update on the latest builds of ECE (r447o and onward): I updated mt32emu to version 2.5.3 but scrapped the support for external Glide wrappers again, I personally prefer the internal one, because it doesn't have external depencies. And I couldn't notice any difference between both, so I decided to keep it as simple as possible and ditched the external one. So it's just kekkos patch again.

glide wrappers allow to have hd resolution in glide game instad of only 640x480. It's very usefull for games like lands of lore 2.

Reply 1416 of 1446, by SedrynTyros

User metadata
Rank Member
Rank
Member
Yesterplay80 wrote on 2020-11-10, 09:33:
krcroft wrote on 2020-11-05, 15:44:

If someone wants to pick this up , the CDDA code is relatively self-contained (src/lib/decoders/*, src/dos/cdrom_image.cpp, src/dos/cdrom.h).

So a DIFF from those files from both the latest SVN and dosbox-staging should come up with a patch rather easily, unless the staging team made other, unrelated changes that affect one of those files. And if the changes don't depend on SDL2.

If I find the time I'll give it a shot and see what comes out of it.

Hello there! Did anyone ever get around to creating a DIFF file for an updated version of krcroft's audio patch for current DOSBox SVN? It'd be great to have an updated standalone patch for that if there's one available.

Reply 1417 of 1446, by Ringding

User metadata
Rank Member
Rank
Member
SedrynTyros wrote on 2021-12-22, 17:46:

Hello there! Did anyone ever get around to creating a DIFF file for an updated version of krcroft's audio patch for current DOSBox SVN? It'd be great to have an updated standalone patch for that if there's one available.

What do you want exactly? v13 of the cdda patch was made against svn (r4267). Do you want that to be applied to current svn? Or do you want the current cdda patch (v14) against current svn? The latter is going to be difficult because it has been merged into dosbox-staging, and all audio-related changes were done on top of the dosbox-staging code base with its numerous type and formatting changes. Extracting things from there would not be fun.