Topic actions

First post, by Oldtype

User metadata
Rank Newbie


I have a problem with Genewars, it looks like here:
Genewars in windows xp

I use Gentoo Linux with an ATI Radeon 9500pro.
I tried a few versions of dosbox: 0.65,CVS, and even the tseng svga patch
I tried different output settings in the config too.

So any ideas?

Reply 1 of 31, by ErikGG

User metadata
Rank Member

This remembers me of a situation that a user had with Space Marines.

[Solved] Graphical error with Game "Space Marines"

Try his solve to the problem.

Glitches in the screen like static on a TV screen and bad drawings.

Do the following to install the game.
Use the CVS build from http://cvscompile.aep-emu.de/dosbox.htm
1.) First, you must obviously install the Game. You can do this from Dosbox or not, BUT: The game scans for its CD, and it want's the drive letter you installed it from.
2.) If you haven't already, get Univbe. See http://www.agiusa.com/files/pub/resix-sw.shtml for more info.
3.) now the config.... I increased videoram=xxx to 4096 in the dosbox.cfg...
4.) start the uvconfig in your univbe directory
5.) configure your emulated video card. check "disable vbe 2.0 extensions"
6.) start univbe.
7.) start the game
8.) ignore the odd fact that the game told you to activate these vbe 2.0 extensions as you installed it earlier.

Read the new FAQ.doc

Reply 2 of 31, by ErikGG

User metadata
Rank Member

Found a better spot to download univbe,


This one is freeware and contains the UVCONFIG.EXE program.

And make that ykhwongs CVS Build.

I'm trying it as we speak to get genewars running.

Edit : Can't get it to run properly too, the univbe 6.7 is not even able to detect the s3. Strange though because the 5.1 version could but doesn't have config exe. Have tried to increase the video memory, change the chipset and the SDL output parameter, but to no avail. Maybe sombody has another thought?


Read the new FAQ.doc

Reply 3 of 31, by Oldtype

User metadata
Rank Newbie

Well the game runs fine for me, exept for the looks.
univbe does not seem to work for me either, I did not use the dosbox version you recomended though. That has some funky dependencys on linux, so I built my own with just the svga patch.

Reply 4 of 31, by ErikGG

User metadata
Rank Member

The looks problem is my problem too, exacly the same. The game runs fine, except for the colors, have played four missions that way. It seems an SVGA pallet problem. But I'm no expert in DOS so. I'm lost here too.

I tried every output parameter in the conf file and tried changing my desktop color depth from 16bit to 32bit, to no avail. The problem happens even when running in Windowed mode so it I guess it is an DOSBox incompatibility graphics problem.

I tried DOSBox 0.65, CVS (of today) and ykhwongs build.

I'm running a Windows 2k pro also with an ATI graphicscard.


Read the new FAQ.doc

Reply 5 of 31, by Qbix

User metadata
Rank DOSBox Author
DOSBox Author

newer versions of univbe try to detect the video card using the pci bus.
DOSBox doesn't have one. So that why you need to use older versions of univbe

So the game works when you disable vbe2. That is interresting.
you could hack the source of dosbox to disable them.
(there is a vesa detection call that tells which version of vbe is supported)

Water flows down the stream
How to ask questions the smart way!

Reply 6 of 31, by ErikGG

User metadata
Rank Member

Disabeling vbe2 doesn't work for genewars, don't know yet, need some more info on the 5.x version on univbe how to disable it.

It seems it does for Space Marines. But Space Marines isn't confirmed so don't change anything yet, I don't have the game to confirm it.

If I get it to work then I'll put it in the FAQ for Genewars and Space Marines.

Edit : Had found a version with config util and that didn't work.


Read the new FAQ.doc

Reply 7 of 31, by Oldtype

User metadata
Rank Newbie

mmhh there seem to be some people who can run the game without those problems. Maybe they can tell what version of dosbox they use and on what machine etc.
Maybe it is a driver problem or ATI specific, but I doubt it.
Also you can speed up the game using dos32a to replace dos4gw, does not help with the grafik though.

Reply 8 of 31, by Oldtype

User metadata
Rank Newbie

OK, I tried it in Windows XP without dosbox. It runs,no errors, but only without sound and too fast.
Anyway I tried it in dosbox under XP too and for some reason it looks even worse there:


  • Genewars.png
    File size
    140.38 KiB
    File license
    Fair use/fair dealing exception

Reply 9 of 31, by ErikGG

User metadata
Rank Member

My guess is that it is a result of a bad version on H.O.U., but as you can run it without DOSBox on XP without graphicsproblems seems to indicate a DOSBox problem. But it could also be a SDL problem, so swapping driver values is a possible fix for that.

Type in google, Genewars Strange Colors and you know what I mean. It seems to be a commen problem for that version.

The only way to do a fast fix is to find someone with a good version. And well as VOGONS isn't a swap/sharing forum this isn't allowed here.

The DOS32a replacement is good way to speed up all Protected Mode games as DOS4GW is a monster on DOSBox.

I knew a thread on the forum mentioning to change values of the ATI Catalyst driver, like color depths, alpha blending and so on to standard. This had worked for that guy (seems), but as I'm running a mobility card this is out of the question.

I must admit I had abandoned on Genewars but I'll try it on my gaming computer (need to kick my brother off of it). Runs an X300 PCIEX so fiddeling around with those values is possible on that one.

Let you know what I come up with.


Read the new FAQ.doc

Reply 10 of 31, by Oldtype

User metadata
Rank Newbie

My version is not from HOTU. Anyway I doubt the version I am using is the problem, since the exact same version does not have those errors when run in XP.
Also the fact that dosbox official 0.65 build, when run in windows has even worse problems than the 0.65 self compiled under linux is strange.
dosbox and SDL are likely suspects, but I have no idea how to make sure.

Reply 13 of 31, by wd

User metadata
Rank DOSBox Author
DOSBox Author

Yep, but at the moment i can't even exclude that the rip just works
because of some xp oddity. The palette loading is quite straightforward
(it looks like a part of the palette is messed up to me) so no idea what
could really go wrong.

Reply 15 of 31, by mefistotelis

User metadata
Rank Newbie

Gene Wars works fine for me.

I have NVidia graphic card, but I don't think this is SDL problem, so this is probably insignificant.

On Dosbox v0.65, with the patch from this site:

and config file I attached - it should work.

If it's not, you have bad version. Mine has 98MB when installed.

Oh, ofcourse you must configure sound (SETSOUND.EXE or INST.EXE), and enter proper paths into CONFIG.INI, for example:



  • Filename
    File size
    5.17 KiB
    File comment
    Gene Wars - working config file for dosbox 0.65
    File license
    Fair use/fair dealing exception

Reply 16 of 31, by ErikGG

User metadata
Rank Member

I first tried the recommendations mefistotelis said, but that didn't fix the graphicscorruption on my laptop or XP machine running the 0.65 and the 0.66 CVS.

Then I tried it natively for my XP Home edition and the game worked perfect. I then ran this version, I ran previously natively, in DOSBox 0.65 and it too worked perfect under XP. Whilest it didn't work earlier.
I copied that version to my laptop and ran it in DOSBox 0.65, and well IT WORKED.

I reextracted the game from the original archive I had and as expected the game had the graphicscorruption.

I then started comparing the files and then found a few files that where differant. One of wich the file Fade.dat. I removed the file, restarted GeneWars in DOSBox 0.66 CVS and it WORKED.

Now the really strange thing, if I now delete all files of Genewars, ReInstall it and run it in DOSBox without removing fade.dat, the game still works without graphicscorruptions. Strange, just strange.

Anyways, in short, use mefistotelis's recomendations for Config.ini, use DOSBox 0.66 CVS from AEP and remove DATA\Fade.dat from the Genewars directory.

If it works or even if it doesn't let me know. Then I know if I should add it to the FAQ or not.


Read the new FAQ.doc

Reply 19 of 31, by OSH

User metadata
Rank Member

I have other problem...
When I launch GW I see a black screen. After exiting DOSBOX I see in the main game directory a file called "gw.err". This is log error:

ERROR loading sound.ini!
ERROR loading data/text.dat!
ERROR loading data/main.pal!
ERROR loading data\creature\dino.anb!
ERROR loading data\creature\crab.anb!
ERROR loading data\creature\frog.anb!
ERROR loading data\creature\bird.anb!
ERROR loading data\creature\mule.anb!
ERROR loading data\creature\dinocrab.anb!
ERROR loading data\creature\dinofrog.anb!
ERROR loading data\creature\dinobird.anb!
ERROR loading data\creature\dinomule.anb!
ERROR loading data\creature\crabfrog.anb!
ERROR loading data\creature\crabbird.anb!
ERROR loading data\creature\crabmule.anb!
ERROR loading data\creature\frogbird.anb!
ERROR loading data\creature\frogmule.anb!
ERROR loading data\creature\birdmule.anb!
ERROR loading data\creature\crabdino.anb!
ERROR loading data\creature\frogdino.anb!
ERROR loading data\creature\frogcrab.anb!
ERROR loading data\creature\birddino.anb!
ERROR loading data\creature\birdcrab.anb!
ERROR loading data\creature\birdfrog.anb!
ERROR loading data\creature\muledino.anb!
ERROR loading data\creature\mulecrab.anb!
ERROR loading data\creature\mulefrog.anb!
ERROR loading data\creature\mulebird.anb!
ERROR loading data/b32a.dat!
ERROR loading data/eff.anb!
ERROR loading data/ethereal.anb!
ERROR loading data/building/BGENE.ANB!
ERROR loading data/building/BFARM.ANB!
ERROR loading data/building/BPOWE.ANB!
ERROR loading data/building/BMINE.ANB!
ERROR loading data/building/BWIND.ANB!
ERROR loading data/building/BSOLA.ANB!
ERROR loading data/building/BVAT.ANB!
ERROR loading data/building/BSHIE.ANB!
ERROR loading data/building/BTURR.ANB!
ERROR loading data/building/BSAWM.ANB!
ERROR loading data/building/BLAUN.ANB!
ERROR loading data/building/BOPER.ANB!
ERROR loading data/building/BOBSE.ANB!
ERROR loading data/plant/grass1.anb!
ERROR loading data/plant/grass2.anb!
ERROR loading data/plant/grass3.anb!
ERROR loading data/plant/desert1.anb!
ERROR loading data/plant/desert2.anb!
ERROR loading data/plant/desert3.anb!
ERROR loading data/plant/snow1.anb!
ERROR loading data/plant/snow2.anb!
ERROR loading data/plant/snow3.anb!
ERROR loading data/plant/all1.anb!
ERROR loading data/plant/all2.anb!
ERROR loading data/plant/all3.anb!
ERROR loading data/plgbl.anb!
ERROR loading data/pointers.dat!
ERROR loading data/pointers.tab!
Show last 15 lines
ERROR loading data/font0.dat!
ERROR loading data/font0.tab!
ERROR loading data/font1.dat!
ERROR loading data/font1.tab!
ERROR loading data/font3.dat!
ERROR loading data/font3.tab!
ERROR loading data/font4.dat!
ERROR loading data/font4.tab!
ERROR loading data/font5.dat!
ERROR loading data/font5.tab!
ERROR loading data/font7.dat!
ERROR loading data/font7.tab!
ERROR loading data/creature/bones.anb!
ERROR loading data/fade.dat!

But all these files are in the right place!
I don't know, why GW can't loading properly. I've tested on 0.60, 0.61 and 0.72 but without success...
Any idea?