First post, by nikiniki

User metadata
Rank Member

Warlords 2 supports sound and midi but I can't change the volume.

The music's too loud and I hear barely sounds.

I noted that dosbox 0.74 supports sb mixer but I don't have one.

Reply 1 of 6, by IIGS_User

User metadata
Rank Oldbie
nikiniki wrote:

I noted that dosbox 0.74 supports sb mixer but I don't have one.

I don't think this must be a real one. Have you ever seen a SoundBlaster card built into a Macintosh (refering to Mac version of DOSBox with this comment) ?


Reply 3 of 6, by Dominus

User metadata
Rank DOSBox Moderator
DOSBox Moderator

Why don't you adjust this with your hosts mixer? Midi volume and wave volume (or what it's called) in the Windows sound mixer (if you are on windows).
Then there is thebuilt in mixer of dosbox, see the manual

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox
DOSBox SVN snapshot for macOS (10.4-11.x ppc/intel 32/64bit) notarized for gatekeeper

Reply 5 of 6, by ripsaw8080

User metadata
Rank DOSBox Author
DOSBox Author

DOSBox doesn't influence the volume values in MIDI events, so if the game doesn't have it's own MIDI volume control then you can only change volume external to DOSBox (i.e. on the synth device or host volume control).

If the SB sound seems unusually low in any game that does not have its own volume control then try the sbmixer=false setting.