VOGONS


First post, by V15UAL K3YS

User metadata
Rank Newbie
Rank
Newbie

Hey, I have a Logitech G920 racing wheel and am trying to get it to work in NFSSE with Dosbox. I have it detected as a 4-Axis Wheel (4axis in .conf file) and DOSBox recognizes the wheel and maps it appropriately. In NFSSE, I have run the JCU.exe file to configure the game to run with the wheel and used the Generic Racing Wheel configuration, enabling all buttons and axis. However, when I start the game, the controls go out of whack and the game acts like it is cycling through the selections on its own at random rates, making it nearly impossible to simply navigate the menu screen. Holding the wheel to the side far enough will get it to stop going up and down but then it will automatically cycle left or right, and I can't make selections this way. I even disconnected the wheel while the game was running and it was still acting the exact same way, even with the wheel disconnected.

If you have any suggestions or anything I could do to fix it, that would be great.

Reply 1 of 4, by V15UAL K3YS

User metadata
Rank Newbie
Rank
Newbie

I managed to stop the controls acting up by disabling timed intervals (setting timed=false in .conf file), but now I have another issue. It brings me straight to joystick calibration when I start the game, and it recognizes the wheel just fine. It detects both pedal inputs and I can move the joystick on screen from left to right easily using the wheel, but I can't get past that. It says to move the joystick through all the gears and press a button (I can only move it left and right using the wheel) and when I go to press a button, absolutely nothing happens. I have enabled all the buttons and axis in the JCU.exe file and I have pressed every button on the joystick and keyboard, and nothing happens. I have to exit the calibration using ESC but then I can't use the wheel because it hasn't been calibrated.

Help would be much appreciated!

I should also note that the calibration screen is very glitchy with the graphics as well (the joystick and pedal meters on screen constantly flicker).

Reply 4 of 4, by mashakos

User metadata
Rank Newbie
Rank
Newbie

In dosbox conf file make sure joystick parameters are as follows:
joysticktype=auto
timed=true
autofire=false
swap34=false
buttonwrap=false

In JSU set the joystick to generic 2-button
in the game options:
set accel/brake to joystick up/down
set steering to joystick left/right
set shift to joystick button1/2

IMPORTANT: make sure you exit the game via the game's own EXIT menu after you've set control options for the first run, if you exit via dosbox exit shortcut your settings won't save

As an aside, I have found these settings make the game run full speed:-
machine=svga_s3
...
core=200000
cputype=pentium_slow
cycles=auto
cycleup=1000
cycledown=1000