VOGONS


First post, by henk717

User metadata
Rank Newbie
Rank
Newbie

Hello Everyone,

This 10 year old hardware will be quite new for this forum so i hope i am posting this in the right category, but with this topic i'd like to go over my current attemps at a Z68 based time machine using a Core i5 2500. Why this machine? Its my old gaming rig so i had all the parts at hand, its old enough to be able to run a legacy award bios but new enough to have a UEFI bios flashed on to it. The system is perfect for Windows XP gaming and up, but i'd like to see how far i can push this retro barrier by adding some PCI hardware from the time and adding software based fixes to get older operating systems to run. If successful a build like this paired with a PCI GPU like a Voodoo 2 and a PCI Soundcard should allow for every era of Windows gaming making it scale up nicely on newer operating systems as the more modern components take over.

Specifications

  • Motherboard : GA-Z68XP-UD3P
  • Chipset / Socket : Z68 - Socket 1511
  • CPU : Core i5 2500
  • GPU : Nvidia GTX770 4GB
  • Memory : 12GB of ram DDR3, multiple brands so no nice uniformity
  • DVD-RAM Drive: TSSTCorp CDDVDRW SH-2
  • HDD : WD Green 2TB HDD 5400RPM (Not the best, but its one of my drives in the better conditions and very fast for Win98)
  • PCI Audio : AOPEN AW744L II - Yamaha XG YMF744
  • PCI Wifi : Atheros Wifi Card
  • Onboard Audio: Realtek ALC889
  • Storage interface: Onboard SATA and a onboard Marvell 88SE9172
  • USB: Intel Chipset USB + Etron 3.0
  • IEEE 1394: VIA VT6308
  • IO Controller: iTE IT8728

Bios configuration
As i mentioned in the opening this motherboard originally shipped with what they call a Hybrid EFI DualBios, which was a Award BIOS with some EFI features backported. It also featured a secondary BIOS that you can use to recover your main bios. In my case i indeed ended up with a permanently broken bios that is beyond repair as it corrupted itself during regular use, so the secondary bios definitely saved me in the past. I have not done to much testing with the AWARD bios, given that i noticed it was not able to properly use my USB mouse in DOS and these compatibility features where missing.

So currently i am running the latest beta bios for the board U1G which transforms it to a UEFI system when flashed trough DOS, this enables proper USB device emulation so the BIOS is able to facilitate the translations for USB 2.0, USB Keyboards and USB Mice as well as Port 60/64 emulation. Any form of IRQ control is missing in both the AWARD bios and the UEFI bios.

MS-DOS 7.1 - What works, what does not work?
For MS-Dos i mostly make use of JEMMEX and HIMEMX to limit the total amount of ram, but the machine appears to have no trouble booting with EMM386 and HIMEM with the /NUMBHANDLES=64 tweak.
Working:

  • SATA CD-ROM Support using the GCDROM.SYS driver, the Marvell controller needs to be disabled in the bios for this to work
  • USB Sticks, will be mapped as a harddrive on boot regardless of the boot device you choose
  • USB Keyboards
  • USB Mouse
  • YMF744 - Wave / FM Synth
  • Partitions of 2TB* - The UEFI seems to handle this as i did not notice any conflicts when formatting the whole drive and using it, but i don't have enough files to know for certain

Partially working:

  • Graphics, some games have the same distortion Win98 and Win3.11 have without drivers, no SuperVGA.
  • YMF744 - No SB support without DSDMA and thus EMM386/Jemmex

Not working:

  • Hardware based slowdown tools (At least i have not found one compatible)
  • Possibly the YMF744 game port, WIndows XP informs me the motherboard leaves no resources for this to function this could translate to DOS i have no device to test this.

Windows 98 - What works, what does not work?
Working:

  • Native USB 2.0 Support - USB Sticks, Keyboard, Mouse, Xbox Controllers, etc
  • Regular SATA Controller - DVD Drive, HDD, etc (Needs Rloew SATA patch but then works fine)
  • HDD Partitions of 2TB? I had no issues with this partition size but am not experienced enough to know if this limit would have caused problems this early, it could be the UEFI handles it and removes the limitation.

Kinda working:

  • Display Output - Extremely glitchy during setup, but will work well with the VBEMP with the obvious exception of acceleration. I have not managed to try the Scitech driver since its interface is very mouse driven and hangs the system easily.
  • General stability - The system runs stable but certain actions will cause it to hang for a while before it continues. Most notably opening DOS windows. Other drivers and software like for example the Scitech Driver interface or YMF744 VXD driver lock up the system entirely. Sometimes the system boots, sometimes it won't.

[*] YMF744 - Only the WDM driver is working right now (After a few power cycles if the system hangs during original setup), the VXD driver completely locks up the system during initialization.
Not Working:

  • Onboard Audio
  • USB 3.0 ports

Windows XP - What works, what does not work?
It is clear that this board has official support for Windows XP, with almost everything working smoothly.

Working:

  • Almost everything

Not working :

  • YMF744 Native MIDI and SB (Might be able to fix it later using different drivers, the bundled one with Windows doesn't support this)
  • YMF744 Game Port (Motherboard occupies the needed resources no matter what i disable)

What do i need help with?
Currently i am struggling to overcome the stability issues on Windows 98, the tiniest action like opening a MS-DOS Command prompt window can cause the system to hang for a while. And especially tools that interact with the hardware like the YMF744 VXD driver or sci-tech utility can completely lock up the system unrecoverably. I tried every single bios setting i could get my hands on, so if a device can be disabled or configured differently i have tried the setting with no success (The only exception being a switch to the Marvel controller, given i have well working SATA and the behavior of the freezes is the same with SATA fixed i doubt this is the issue).

For MS-DOS i have not been able to resolve the graphics glitches in games like Commander Keen 4 (Distorted text), this also happens when run inside windows.

I would love to hear your thoughts and similar experiences on more modern hardware.

Last edited by henk717 on 2020-03-18, 16:29. Edited 1 time in total.

Reply 1 of 3, by Horun

User metadata
Rank l33t
Rank
l33t

You cannot get Win9x or DOS to work proper with your board and all the components you have. It just will never happen. You can compromise and get some things working under those but the board was designed for true 32bit OS and neither Win9x or DOS (of any flavor) will give you that.

Hate posting a reply and then have to edit it because it made no sense 😁 First computer was an IBM 3270 workstation with CGA monitor.

Reply 2 of 3, by BinaryDemon

User metadata
Rank Oldbie
Rank
Oldbie

I think you should try to prevent Win3.1 from seeing drive volumes >2gb and Win98SE from seeing drive volumes >127gb. I believe both scenarios cause instability.

Check out DOSBox Distro:

https://sites.google.com/site/dosboxdistro/ [*]

a lightweight Linux distro (tinycore) which boots off a usb flash drive and goes straight to DOSBox.

Make your dos retrogaming experience portable!

Reply 3 of 3, by henk717

User metadata
Rank Newbie
Rank
Newbie

Spend a while messing with the system again and i made good progress but am now once again stuck.
The initial hardware not found issue was resolvable by using the /pi switch but this would cause the system to hang on boot, turns out that was a SATA issue given the SATA controller was now found properly along with the other hardware. Installing the R Loew SATA Patch resolved this issue and makes SATA behave properly including DVD-Rom support.

Using the YMF744 WDM driver i have also managed to get the sound card to work now that it was detected, bypassing the lockup i get on its VXD driver.
And last but not least i have gotten the USB 2.0 native support to work using U98SEUSB.exe you can find inside the SP3.CAB file of the Unofficial Servicepack 3 release. I had better luck with this than NUSB. While NUSB worked this driver seems more stable and contains more drivers given it also supports Xbox Controllers without further installations.

But unfortunately the system instability still remains and i have as of yet not been able to install a patch for it, autopatcher and the unofficial service pack 3 are incredibly difficult to install with all the freezes going on, so installing the required (unofficial) patch manually or doing the correct tweaks will likely be a better option.

So currently i am stuck at solving the general stability at the moment, the system sometimes boots, sometimes hangs on boot, freezes for a while on certain tasks like opening command.com windows and can completely lock up during certain actions like Scitech's control panel loading or the YMF744 initializing with its VXD driver.

@BinaryDemon , I have since repartitioned the system to have a 40GB partition for Windows 98 with no noticable differences in stability.
@Horun, Its possible you are correct and i now hit the final road block that kills the project and we have to conclude that while i got all the essential components working (GPU, SATA, Sound and USB) it will never be fully functional or stable. But given we have come so far with an almost working build i am not giving up without asking for help one last time to be certain no stability patches exist that can solve this issue.

Ultimately i hope someone experienced similar lockups and knows what has to be done in order to resolve them, then we can find out if these fixes are possible on my hardware.
The GPU issues happen on my other modern ryzen build, and the lockups seem to happen on my Lenovo E540 laptop. So it does not seem to be an isolated case on this build.