First post, by Dracolich

User metadata
Rank Member

I just got a new keyboard with builtin trackball to use with my two retro systems via Belkin 2-port PS/2 KVM. The keyboard has a split PS/2 cable with the separate purple and green connectors. On my MS-DOS 7.1/WfW 3.11 machine both parts work great. My Win98SE machine is not being so cooperative.
Edit 02/03/2021: The DOS/WfW machine is a Socket7 QDI Titanium IB (430TX) with 128MB SDRAM

The keyboard part works fine but the trackball only works in safe mode. Additionally, it only works in safe mode if "USB Keyboard" and USB Mouse" are enabled in BIOS. If USB is disabled in BIOS then the keyboard still works but the trackball does not. When trying to use the trackball in normal mode the pointer will jump across the screen a few times then stop responding. I can connect a USB mouse and the pointer will begin responding to the mouse and work fine.

I do have another PS/2 keyboard and mouse set that works fine. I would really like to use this new one, though, because the compact all-in-one design is a space saver on my desk.

The specs of this machine are:
Biostar M7VIG400 Rev 7.1
Sempron 2800 (2.0GHz)
Win98SE with unofficial SP3.65
SB Live! CT4780
Lucent 4-port USB 1.1 card
GeForce FX5200 with driver 45.23
Rocketfish 3.5" bay multi-card reader connected to mobo USB header
Perixx 505+ compact keyboard + mini trackball

Things I have tried so far:
Uninstalling DMA and USB 2.0 utilities added by the unofficial SP3
Uninstalled Zone Alarm and Avast!
Uninstalled nvidia drivers then clean install
CCleaner to fix registry errors
Removed all mouse, keyboard and HID items from Device Manager in safe mode
Removed all USB items from Device Manager in safe mode
Connected directly to computer without KVM
Connected directly to computer via PS/2 -> USB active converter
Loading BIOS defaults and resetting ESCD
Switching PnP OS from no to yes in BIOS

With the mouse lead of the KVM connected to the active PS/2 to USB converter it does work in both safe mode and normal mode, however Windows randomly freezes often when navigating files and folders.

Edit 02/03/2021 - Tried a couple more things:
Disabled shell extensions from MagicISO, XnView, 7-Zip, Nvidia
New keyboard's purple connector with old PS/2 mouse does work
After removing all USB items from Device Manager, disabled all USB controllers in current hardware profile.
Disabled EHCI support in BIOS
Used msconfig to temporarily disable DaemonTools

Edit 02/05/2021 - Also tried
Various PS/2 to serial adapters on COM1 and COM2

Edit 11/20/2021 -
I finally got a chance to attack this again. I tried disconnecting the Rocketfish card reader. No help. I renamed the Windows folders to a backup, did a clean install of 98se in PCem emulating a 430VX, then copied the new Windows folder to my disk. I thought of this for two reasons: 1) to identify or rule out the unofficial SP3 as a culprit, and 2) to watch the hardware detection and find out at which point it knocks out the trackball.

Using this method I did discover that the trackball works fine during hardware detection, but as soon as it installs a driver for the PCI to USB host controller is when the trackball stops working. On this mobo Windows finds three VIA Tech 3038 PCI to USB Host Controllers and one VIA VT 8235 USB 2.0 Enhanced Host Controller. In safe mode I tried replacing the VIA drivers with the Windows Standard but that didn't help.

So, I wonder if the ps/2 mouse port is on the usb bus, but not the ps/2 keyboard connector. Also, maybe the Perixx keyboard uses an integrated usb to ps/2 conversion.

Does anyone have any ideas I can try?

Last edited by Dracolich on 2021-11-26, 13:56. Edited 3 times in total.

Reply 1 of 3, by Dracolich

User metadata
Rank Member

While investigating this, using WinTop to view resource usage, I found that any time I connect a USB keyboard + mouse MSGSRV32.EXE begins using 50-70% CPU. When that happens D3D games and DOSBox become very laggy. The Ddraw and D3D tests in DXDIAG also have some stutter. This happens even when there is no PS/2 keyboard + mouse connected.

Reply 2 of 3, by Dracolich

User metadata
Rank Member

During the holiday weekend I decided to try Windows 2000. I renamed the Windows folder again as a backup and did a clean install of Win2k Pro. Right away the trackball was not working, whether plugged into the PS/2 or using the USB converter. Also, the USB mouse was not working, whether on mobo usb ports or on the Lucent PCI card. I continued through the entire install process and the trackball still did not work on PS/2 but finally did using the USB converter.
That was no better so I restored my Win98se. Another thing I have been noticing is that when 98 has booted sometimes the DVD drive is not in Explorer. It has been like that since I first installed 98 on this computer, and it was the same in Win2k. This weekend I disabled the boot logo and added some config.sys/autoexec.bat lines to load MSCDEX and VIDE-CDD.SYS in all three of my configs: normal, safe, and command prompt. In all modes MSCDEX sometimes does not find the drive.
I am beginning to think there may be a connection between the random DVD drive detection failure and the frequent system freeze when navigating drives in Explorer. Is that a possibility, such as a failing IDE controller? I have a spare Foxconn Winfast 761GXK8MC-S I could swap with. I remember using it in the past before switching to the Biostar, but I don't remember why I switched. Is anyone familiar with Win98se compatibility on the SiS761GX ? I would be using my own sound and video cards but need the onboard lan.
Edit: corrected the model of the Foxconn mobo

Reply 3 of 3, by Dracolich

User metadata
Rank Member

Ok, I spent the weekend swapping the motherboard to the 761GX, and doing a clean install of 98se without the unofficial SP3, and everything is working great now. Nusb 3.6 is working perfectly for the card reader and I copied several GB of games from an SD card without any problem. I had a little difficulty getting the SB Live drivers to install, kept BSOD'ing when installing the Creative SB16 Emulation device, but I disabled it from Safe Mode and all is good now.

I also remember why I originally chose the Biostar over the Foxconn. The Foxconn's size and placement of the IDE and FDD headers partially obstructs the lowest 5.25" bay blocking long CD drives, and it has only 2 PCI slots + 2 PCIe where the Biostar has 3 PCI + 1 AGP. But those are minor details considering the apparent difference in compatibility. 2 PCI is enough for my cards, and the mobo has enough USB ports that I don't need a supplement card.

Does anyone have similar experience on a VIA KM266 Pro with the VT8235 chipset?