First post, by TechieDude

User metadata
Rank Member

A little backstory:
So, my Logitech F710 died yesterday, specifically two tiny resistors next to the IC of the receiver broke off, making it paperweight, not seen by the PC at all, not even as an unknown device. Now, if I had those tiny (and I mean REALLY tiny!) parts and a hot air station, I would try, since the pads are there, but alas, I don't, so I'm probably just keeping it for parts or until I do manage to fix the damn thing. Shame really, it was the best. Worked with everything. I even modded it with an 18650 Li-Ion battery...
Anyway, I had tried other controllers, like the DualShock 2 with a USB adapter and it worked really well, but I had no Rumble, which I wanted to have. I also had a Trust GXT 540 (also no Rumble in Dinput mode) but I ended up scrapping it for parts because the shoulder buttons broke off, taking the pads with them. Bodge wires did nothing sadly.

I also have an original XBOX console, along with a Duke controller. To oversimplify, the XBOX is basically a PC with a non-PC BIOS. Even the controller ports are USB ports with an extra pin that's not really used for anything. As such, its controllers are basically USB HID devices with non-standard HW IDs. I soldered a normal USB connector on top of the XBOX connector solder joints, making it have both plugs. An adapter cable would make more sense, but that's besides the point.
XBCD v.1.07 offers compatibility with plenty of XBOX controllers, rumble, and even full customization for EVERY button, allowing you to map them to axis so that you can take advantage of the pressure sensitivity. It also works on Windows 98!

EXCEPT IT DOESN'T! I can test it all day long on the Gaming Options menu with everything working exactly as it's supposed to. Even better on XBCD setup, it shows exactly how hard you press the buttons, but when I try to play games with it, THEY ALL CRASH WITHIN MERE SECONDS! Always some sort of exception. I've tried limiting the buttons and axes, disabling rumble, I'm running the latest DX9.0c that can run on them. Hell, I have two different Win9x rigs with wildly different configs and they both have the same exact behavior. Am I missing something here? For the record, I have none of these issues with other controllers. It's just this one in particular.
Any idea what's going on? Other than the obvious fact something is wrong with the driver.

EDIT: Am I really the only one crazy enough to use an original XBOX controller on Win9x-era games? Anyway, it seems to work slightly better with the older XBCD v.0.57, though way too many games refuse to work at all when it's plugged in. I'm at a loss.